Nvidia Powermizer "Performance" settings reset on reboot

I’ve done a plethora of things over the past month trying to get nvidia settings to persist on reboot. The only thing I couldn’t resolve was having my gpu set to “Performance” mode instead of adaptive in the nvidia-settings gui. I’ve saved settings through

“sudo nvidia-settings”

and saving to /etc/X11/mhwd.d. Changing xorg.conf manually in the X11 folder has worked for me on mostly every other nvidia-settings configuration. I’ve also tried the option

"Option “RegistryDwords” “PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefault=0x2; PowerMizerDefaultAC=0x2"”

on multiple configurations to no avail. I cannot find a wiki for xorg.conf’s options so this is all I have to go on.

Single GPU system with dual 2560x1440p monitors on Kde Plasma with latest proprietary Nvidia driver

I’ve looked through this forum to issues similar to mine but it seems like nobody has an answer, only potential solution is a workaround. Troubleshooting Manjaro has been my life for the past month or so so if I’m forgetting any information to include please ask, my system should be public on my profile and forgive me if I don’t know how to format, I haven’t used a forum since 2006. Thanks.

EDIT: Only solution seems to be the workaround I was using as seen in omano’s post.

Try that in a terminal (“Adaptive”=0 “Prefer Maximum Performance”=1 and “Auto”=2)

nvidia-settings -a '[gpu:0]/GPUPowerMizerMode=1'

Then start nvidia-settings and check if it switched to performance mode. If yes, then add this command to your startup.

//EDIT: to give proper system info, give the output of command inxi -Fazy

script should have this inside:


nvidia-settings -a “[gpu:0]/GpuPowerMizerMode=1”

I’m doing this as a workaround. Was hoping there was a better solution. Would you like my inxi output? Thanks.

Not sure this is necessary, might be a dual gpu situation as omano’s answer was and is sufficient on my system.

1 Like

You can still edit your first post to add it, but I don’t want it personally, if my solution works but doesn’t suit your need.

The question is, is it supposed to stay after a reboot, maybe this is the expected behavior, that after a reboot the Powermizer resets.

I suppose. I can just see plenty of Windows users moving over to Manjaro and having issues with this. This workaround will work for me it’s just unfortunate to not see another solution. Don’t like that I have to bloat my auto-start with a ton of scripts in Manjaro due to poor compatibility. Thanks omano

I don’t really see this as an issue, I mean the default Adaptive is good for everyone I guess. Your use case of forcing the PowerMizer is kinda weird to me actually, unless your goal is to force paying more electricity :nerd_face: (I force it, for the sake of it, with GameMode program when I run specific games, but it is not even needed).

In both Windows and Manjaro with a very efficient gpu I lose performance in games due to the power setting. If anyone primarily plays videogames on their pc I could very well see this applying to their situation. This isn’t exclusive to this system either. This is past the point of proper configuration of feral gamemode, cpu power governors, and sync settings; still causing performance loss. It’s even noticeable with kde’s compositor with performance set to adaptive.

I mean GameMode specifically has a setting for the Nvidia PowerMizer, if you want the PowerMizer setting for games.

So another workaround.

You’re the first person I see complaining about ‘performance issue’ with KDE’s compositor. And you have a RTX 3090 :open_mouth:

Maybe you have another issue I don’t know.

I don’t, I can say that with confidence as I’ve spent a disgusting amount of time on this issue and performance mode fixes the problems. I appreciate your help but I think you are beyond your depth, as I’ve seen plenty of people have performance issues with kde’s compositor and this topic has strayed from the issue of wanting performance mode to be set on boot… Just try a quick search on duckduckgo “kde compositor performance issues”

I think what you consider performance issues on KDE with Nvidia, is a lack of proper configuration in KDE/Nvidia but OK.

And I think you are speaking without enough knowledge of my configuration because you didn’t have a solution that wasn’t a workaround.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.