Nvidia only driver won't boot, only hybrid-intel-nvidia drivers boot [not specific to dec 30th update]

Hi, I’m using Manjaro Gnome on my laptop (Lenovo Ideapad 310) with Intel i5-7200U cpu and Nvidia 920MX dgpu.
I couldn’t get nvidia only driver to boot. Only the hybird-intel-nvidia works for me.
I’ve tried with 4.4, 5.4, 5.8, 5.9 and 5.10 kernel. Was using hybrid-intel-nvidia-455xx
before the latest update.I wanted to install just nvidia-only because I couldnt set optimus-manager to nvidia mode. If i switched to Nvidia only mode, it lags so much that in games like csgo i could only get around 9fps.
Whatever I do, nvidia only driver wont boot.
After latest update, I’ve tried to install video-nvidia driver.
It installs without any error message, but it wont boot.
Tried nvidia-smi in tty in video-nvidia driver. It says no process found in the last line.

Hi @soorajsp :wink:

According to the readme: Appendix A. Supported NVIDIA GPU Products Version 390xx should work. Check the ID: 134F

1 Like

According to the NVIDIA website, 455xx should work just fine.

@soorajsp I think the problem that needs to be solved is optimus-manager, because if you don’t have the necessary MUX chips, I’d say using the video-nvidia configuration will not work out the way you expect. First of all, for games, prime-run should work fine, is that not the case for you?

1 Like

thanks, ill check it.
But 455 driver also supports my chip

prime-run works. Optimus-manager switching doesn’t work good
I’m trying to do this just to increase battery backup. I’m currently setting launch options in steam game properties, so gaming with nvidia gpu isn’t an issue. It’s just I’m concerned with battery backup more.
In terms of battery backup I feel Windows > Ubuntu > Manjaro.
And I dont feel like switching, cos manjaro feels very fresh and great.