Nvidia no X driver

When I try to launch nvidia-settings, it tells me that I don't have the X driver, after running sudo nvidia-xconfig et re-launching nvidia-settings, It gives me the same error.
After seeing this post I've tried to follow the guide but it failed.
I'm using a Lenovo ThinkPad T430 with a Nvidia NVS 5400M
Do you know what can I do?

Try this

optirun -b none nvidia-settings -c :8

If the drivers are installed correctly it should open nvidia settings.
To make permanent changes of settings use sudo, cause w/o sudo it keeps the settings only for this session.

You probably mean "X driver is not running", which means you need that specific command

Assuming you have installed hybrid-bumblebee...
Check

mhwd -li

When I try to do optirun it tells:

[ 304.845868] [ERROR]You've no permission to communicate with the Bumblebee daemon. Try adding yourself to the 'bumblebee' group
[ 304.845942] [ERROR]Could not connect to bumblebee daemon - is it running?

And yes, I run hybrid-bumblebee.

> Installed PCI configs:
--------------------------------------------------------------------------------
NAME VERSION FREEDRIVER TYPE
-------------------------------------------------------------------------------->
video-hybrid-intel-nvidia-390xx-bumblebee 2018.08.09 false PCI

Warning: No installed USB configs!

Run this to add you to the group and enable the bumblebee daemon.

sudo gpasswd -a $USER bumblebee

sudo systemctl enable bumblebeed

The you need to reboot and run:

optirun glxgears

to check if the drivers are installed. If you see gears and FPS count in terminal you are good to go.

Then for nvidia-settings you can use this

optirun -b none nvidia-settings -c :8

*If you are using Steam and want to activate your nvidia GPU for specific game, you should set launch options of that game like this

primusrun %command%

When I run these command it give me these errors :

[  132.730137] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) 

[  132.730182] [ERROR]Aborting because fallback start is disabled.

Do you have open-source or proprietary driver installed?

I have proprietary (non-free) driver and after doing this steps it works fine.

I have the propietary 390xx hybrid driver.

Could you post output of this?

optirun -vv glxgears

Maybe this can help you

Here is the output:

[ 2377.805224] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 2377.805616] [INFO]Configured driver: nvidia
[ 2377.805916] [DEBUG]optirun version 3.2.1-2017-02-27-Format:%h$ starting...
[ 2377.805945] [DEBUG]Active configuration:
[ 2377.805953] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 2377.805960] [DEBUG] X display: :8
[ 2377.805966] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia:/usr/lib:/usr/lib32
[ 2377.805991] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 2377.806005] [DEBUG] Accel/display bridge: auto
[ 2377.806030] [DEBUG] VGL Compression: proxy
[ 2377.806045] [DEBUG] VGLrun extra options: 
[ 2377.806075] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[ 2377.806164] [DEBUG]Using auto-detected bridge virtualgl
[ 2379.057164] [INFO]Response: No - error: [XORG] (EE) 

[ 2379.057198] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) 

[ 2379.057211] [DEBUG]Socket closed.
[ 2379.057233] [ERROR]Aborting because fallback start is disabled.
[ 2379.057241] [DEBUG]Killing all remaining processes.

As for the wiki link, none of the it can help as it seem I don't have a 20-intel.conf file nor a 10-monitor.conf file and the BusID of the Nvidia card is the right one.

For me it worked on XFCE and i3 with 4.19.36-1-MANJARO kernel.

I don't know. Wait for help from someone more experienced.
:unamused:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.