Nvidia no display out after non free drivers

Happy New Year

For a while now I have been able to use my thunderbolt dock and support two external monitors along side the laptop screen. After getting a few programs and wanting to use the non-free nvidia drivers, I lost the ability to use any display out. Just the laptop screen works. What the heck did I mess up?

The thunderbolt and the regular hdmi out do not work. The laptop screen flickers like it wants to change over and then does not. (Yes monitors are on and have worked before)

nvidia-settings only show one monitor in the gui, and still no output. I used to see both here.

~ Huge thanks to every and anyone

System info below:

~ >>> mhwd -li                                                                                                              [1]
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI

~ >>> inxi -G                                                                                                                  
Graphics:  Device-1: Intel UHD Graphics driver: i915 v: kernel 
           Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] driver: nvidia v: 455.45.01 
           Device-3: IMC Networks USB Camera type: USB driver: uvcvideo 
           Display: x11 server: X.org 1.20.10 driver: modesetting,nvidia unloaded: intel,nouveau 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.3.1 

~ >>> mhwd-kernel -li                                                                                                          
Currently running: 5.10.2-2-MANJARO (linux510)
The following kernels are installed in your system:
   * linux510
   * linux54

~ >>> nvidia-smi                                                                                                          [130]
Mon Jan  4 21:44:00 2021       
| NVIDIA-SMI 455.45.01    Driver Version: 455.45.01    CUDA Version: 11.1     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  GeForce RTX 2060    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   40C    P8     6W /  N/A |      5MiB /  5934MiB |      0%      Default |
|                               |                      |                  N/A |

It doesn’t seem like you actually installed the non free driver. What happens when you run mhwd -i video-nvidia also maybe try seeing if switching to the LTS kernel helps.

I had that hunch because I always get this error:

~ >>> sudo mhwd -i pci video-nvidia                                         [1]
Error: config 'video-nvidia' conflicts with config(s): video-hybrid-intel-nvidia-prime

I thoght the hybrid driver was the non free since it says false for free driver? That is what mhwd -a pci nonfree 0300 gave me.

I will look at LTS

Same video-nvidia error above on LTS kernel

The issue seems to be the same as here, please try the workarounds suggested there.

Thanks! I got one monitor to work with that, not both. nvidia-settings and xrandr -q both see my two monitors though…

I can live with the one for now!

Switching to LTS did not allow the video-ndivia to be installed, but I did finally get display out. Only 1 of 2 monitors but still something. Thanks for your time!

video-hybrid-intel-nvidia-prime is what you need, not video-nvidia.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.