Nvidia losing video signal, solution

So I did a Web search on Nvidia Issues with losing the Display signals and found one here:

I turn off VT-x as one Poster there said and just played XCOM in Windows 10. Now solved. I’m going to reinstall the NVIDIA Drivers for Manjaro and check again later. As mentioned:




Munkey_Luv said: I found that this issue only started from me when I turned on VT-x on the CPU settings in the BIOS, which I needed to do some work with Virtual Machines. I noticed once I turned it off the no connection issue went away for me. I think that it might be an avenue people want to look at if they are getting this issue. I only created an account to post this as it had been driving me up the wall. Hope this helps someone edit PS VT-X is Intel’s Virtualisation technology there is another part to this but I can’t remember what its called in my BIOS. If you don’t need to set up a Virtual Machine you won’t miss this being turned off
yes indeed ur trick worked i disable the intel virtualization and the issue is gone thx a lot for the tip the ting is intel virtualization was always on in my bios whit my old asus q24 monitor and it was working fine but ever since i bought a new monitor the dell S2716DG 27 this issue started happening for no reason

So simply turn off VT-X and it should now work.

No it didn’t. I wonder why this in Windows but not Linux. Some more research…

Because Windows and Linux are fundamentally different environments.

Good Point there. But at least got XCOM: Enemy Within working now.

Now to discover why turning off Intel VT-X doesn’t work in Linux.


If there is problem then in 99% of all errors, there is a message in /var/log/Xorg.0.log

Just check them all:

for x in /var/log/Xorg*; do echo -e "\n--- $x ---\n$(cat $x)"; done
1 Like

What am I looking for?

Look for (EE) Messages… but maybe better upload it?
Upload command:

for x in /var/log/Xorg*; do echo -e "\n--- $x ---\n$(cat $x)"; done | curl -F'file=@-' https://0x0.st

and post the link here.

If there is really nothing, then it is not Xorg or Driver related. Then it has something to do with opengl or the hardware. Or maybe you run games with wine/proton, then there could be a bug located.

The Issue started Linux Games on Steam. Even with Proton/Wine.

I’m thinking of putting back in my GTX 970 to see if there is anything wrong it. The Video-Linux Drivers works without the Issue, at least for the GTX 760 w/ 4GB.

While I did test one game the Issue occurred. I reset the BIOS/UEFI to default settings sometime ago. I just reinstalled the Nvidia drivers and was able to play one game that was losing the Signal with those drivers. It didn’t it this time.

I do need to test other games however. I’ll post results later.

I did put back in the 970 but didn’t post, and it now works with both Drivers.