NVIDIA lists settings that are out of range


I’m using the NVIDIA graphics driver 450.66 with a GTX 1080 and it’s connected to an ASUS ROG PG27AQ display that is 3840x2160 @ 60Hz.

In Windows this combination is capable of all sorts of resolutions, and so you would think it is in Linux, and the NVIDIA driver does indeed say exactly that.

Unfortunately only 640x480, 800x600, 1024x768, and the native 3840x2160 resolutions actually work. Everything else makes my display go dark, write “OUT OF RANGE” and then revert to normal after 15 seconds.

All of my games also detect all these terrible resolutions, and many of them will automatically attempt to use them. For Warcraft 3 Reforged, I want to use a 1080p resolution because the game runs like trash, but it’s still Warcraft 3 and I love it, but I can’t select it because, if I do, I get no display output.

The selectable resolutions also change with each release of the graphics driver. I can’t quite figure out the pattern, but it’s on long timeframe. It doesn’t change between reboots or anything like that. More like when I update sometimes. Sometimes it writes (Scaled) after everything and the GPU works as normal. Sometimes they just straight up aren’t there. And sometimes, like now, they are listed but don’t work.

Anybody know what’s going on?

open a terminal and returns

xrandr -q
Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected primary (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 connected 3840x2160+0+0 (normal left inverted right x axis y axis) 600mm x 340mm
   3840x2160     60.00*+  59.97    29.98    24.00  
   3200x1800     59.96    59.94  
   2880x1620     59.97    59.96  
   2560x1600     59.99    59.97  
   2560x1440     59.96    59.95  
   2048x1536     60.00  
   2048x1152     59.91    59.90  
   1920x1440     60.00  
   1920x1200     59.95    59.88  
   1920x1080     59.96    59.93    60.01    59.97  
   1856x1392     60.01  
   1792x1344     60.01  
   1680x1050     59.95    59.88  
   1600x1200     60.00  
   1600x900      59.95    59.82    59.99    59.94  
   1440x810      60.00    59.97  
   1400x1050     59.98  
   1400x900      59.96    59.88  
   1280x1024     60.02  
   1280x960      60.00  
   1280x800      59.99    59.97  
   1280x720      60.00    59.99  
   1024x768      60.00  
   1024x576      59.96    59.95  
   960x600       60.00    59.93  
   960x540       59.99    59.96  
   840x525       60.01    59.88  
   800x600       60.32  
   800x450       59.95    59.82  
   700x525       59.98  
   700x450       59.96    59.88  
   640x480       59.94  
DP-3 disconnected (normal left inverted right x axis y axis)

Have you tried changing the resolution using xrandr, arandr, or in the system settings?

I use nvidia-settings to change it. I don’t have the system settings plugin for KDE to change resolution installed at all.

I have never tried using xrandr or arandr to set my resolution.

By the way, even if we do manage to restore the (Scaled) resolutions, they don’t show up in Wine for some absurd reason. That’s gonna be the next step.

EDIT: Currently fiddling around over here:

I’m sure everything will be x’D

arandr is intuitive and simple, I’d try it first before diving deep into the realm of configuring Xorg manually.

That documentation is really old. Please select the appropriate documentation for your version here.

That documentation had the answer. Had a really hard time figuring some of this out, but … yeah.

The first point of confusion was Manjaro’s graphics handling, which meant that all my xorg changes weren’t taking effect. Well, the magic takes place inside mhwd.d.

All of the broken resolutions were caused by the setting Option “ModeValidation” “AllowNonEdidModes”

Now, I didn’t set that. I had no idea it even existed. I think the reason why it keeps changing is that some people in the Manjaro community, when packing these, sets that option, while others do not. Not good - that’s not a setting that should be enabled by default from reading what it does.

Once this line was gone I also got my scaled resolutions back!

As for wine, it’s broken at some point. 5.7-fshack works, 5.14 does not. Not sure why exactly, but doesn’t matter for the time being. It works.

1 Like

That’s interesting indeed, I wonder why AllowNonEdidModes is there, honestly, it doesn’t seem like something that should be enabled by default, but I guess there are reasons.

That may be true, but you’re always better off reading the documentation of the driver you use: Index of /XFree86/Linux-x86_64