Nvidia GT 210 Manjaro 21

Hello. I am trying to install Manjaro 21 KDE. Since my video card is Nvidia GT 210, I selected the “Boot with proprietary drivers” option in the setup but the message ‘Reached target Graphical Interface’ is stuck. What should I do?

1 Like

Hi @mehmet, and welcome!

That is quite old, according to me. It might not be supported by the officially available drivers.

Best would be to boot and install with the open-source drivers.

I believe they would provide ample performance for the card.

Hope this helps!


Install with the free (open-source) option.

From Nvidia’s driver support page the version supporting the device is v340.108

Search the forum for nvidia340 - the proprietary driver was discontinued in 2020.

One possible unsupported option is to build the driver by hand - but then are on your own. If you venture into this - at the very least you should use an LTS kernel

Ok. I finished the installation by selecting “open sources” How can I manually install the driver?

As I previously mentioned, It seems to be an older card, that might not be supported by the drivers available, so those would probably be your best bet. To see if any others are supported, open a terminal and run:

mhwd --list

And provide the output here.


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

I believe you want/need the 340 driver, following these instructions might work for you:

In any case, as mentioned in that post, installing an unsupported driver adds a lot of extra work for yourself, it’s going to be up to you to remember to rebuild it every time the kernel is updated.

mhwd --list                                                                                   
> 0000:01:00.0 (0300:10de:0a65) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Yes, only the open-source one is officially available for your graphics card. Check the post @ydar linked to:

The installation is now complete. Is there anything additional I should be doing at this point?
Edit: I rebooted, however sleep mode is still not working. Also, screen tearing occurs while playing a video.

Does everything work to your liking and your expectation? If not, then please ask again, if yes, then “welcome to the real world”. :red_circle:

1 Like

No idea about sleep not working, as for screen tearing, enabling Force Full Composition Pipeline may help.

Indeed for screen tearing with Nvidia, enable the Composition (or Full) Pipeline in the Advanced Settings from the Nvidia Settings panel. The settings need to be then written to the /etc/X11/mhwd.d/nvidia.conf file i na normal setup, not sure which Xorg file it would use in your case (for that, reopen Nvidia Settings, and click the Save to X Configuration button, then browse to the file I mentioned, and save without merging, then reboot). You also need to select the proper refresh rate for the display (some monitors show multiple 60Hz for example, but only one is the perfect one for the monitor).

A friend of mine has this card (99% sure this is this one) and I don’t know why but after I removed the 340 drivers last year because of an issue we were trying to troubleshoot, MHWD started to give the option to install the 390 drivers for the card, and so far it works. The card is not compatible in theory but it works and is available in MHWD GUI.

Try the GUI to see if there is another option to install (it shouldn’t be but this was the case for my friend I think).

Nvidia Settings won’t open. So I don’t see a panel in front of me.

Did you reboot?

Yes, I rebooted.

Usually that happens when something didn’t get installed properly, what does inxi -G show you?

Mine looks like this:

  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] driver: nvidia v: 510.60.02
  Display: x11 server: X.Org v: driver: X: loaded: nvidia
    gpu: nvidia resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 750 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.60.02
  Device-1: NVIDIA GT218 [GeForce 210] driver: nouveau v: kernel
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.0 driver:
    X: loaded: modesetting gpu: nouveau resolution: 1920x1080~60Hz
  OpenGL: renderer: N/A v: N/A

As you can see, you’re still using the open source driver.

Not sure what went wrong with your installation, hopefully someone else can offer some support.

Probably because info are outdated in the thread he followed and he’s missing some steps. Here was a separate thread for the instructions, with more up to date info regarding Xorg (also you’re using Wayland that will probably be another issue even if you fix Xorg compatibility).

Follow the info here and see if that works.

I think it may be necessary to disable or uninstall the Nouveau driver. If I do the installation in the link you gave, there may be a conflict with the previous nvidia packages I installed.