Nvidia GPUs zurzeit unnutzbar mit Linux?

#1

Hallo Zusammen!

Hatte eine Ewigkeit ein Problem (Nvidia GPU Problem nach Installation). Das wurde wie im verlinktem Beitrag ersehbar gelöst.

Nun habe ich mich dieses Wochenende damit beschäftigt die Maschine "umzuziehen". Und nun habe ich wieder ein neues Problem, das laut "das Internet" ein Bug von Nvidia Grafikkarten wäre, und somit nicht lösbar (außer man wechselt nach AMD).

Das kann ich ehrlich gesagt nicht glauben! Wahrscheinlich nutzen millionen Menschen Linux und haben Nvidia GPUs verbaut!

Dieses Problem tritt mit den freien Treiber auf (jedoch nicht so schlimm) und mit den propiertären. Und zwar funktioniert die 3D Beschleunigung einwandfrei. Man kann sogar Spiele spielen, oder bei Youtube selbst 8k u. 4k Video abspielen lassen. Ohne das es ruckelt oder stottert. Selbst gleichzeitig das aktive Firefoxfenster wie verrückt "hin und her schleudern". Alles läuft butterweich was mit der GPU's zu tun hat.

Will man jedoch ein Fenster verkleinern oder vergrößern, dann stottert es extremst. 2-3 FPS.

Dieses Problem tritt mit jeder Distribrution auf. Mit jedem Treiber (frei, oder properitär. Egal welche Version). Mit jeder Desktopumgebung. Mit jedem Fenstermanager.

Folgende Distribrutionen habe ich selbst getestet:

-Manjaro
-Antergos
-Debian
-Ubuntu
-Fedora
-Pop!_OS
-OpenSuse

Folgende Desktopumgebungen:

-Gnome
-KDE
-Cinnamon
-Xfce
-i3
-bundgie

Egal ob X oder Wayland. Egal ob bei KDE kwin oder mit Fluxbox oder Openbox.

Habe aktuell 4 Maschinen hier stehen, die alle das Problem haben:

Maschine A:
i7-6700k
32gb RAM
1x Nvidia 1070

Maschine B:
AMD Phenom X6 1100T
8gb Ram
1x Nvidia 980Ti

Maschine C:
Threadripper 1950x
64gb RAM
2x 1080Ti's

Maschine D (Notebook):
Lenovo T530 (im Bios eingestellt NUR die nvidia GPU zu nutzen. Kein Bumblebee oder Prime oder Optimus (im Bios sowieso deaktiviert))

Die AMD RX 580's laufen wie erwähnt einwandfrei.

So sieht das Problem aus:
https://grenangen.se/node/92




Hier ein Video: https://www.youtube.com/watch?v=tPYytsf1zLU (dient nur zu verdeutlichung wie das aussieht)

Wenn man googelt, empfiehlt der Großteil einfach auf AMD zu wechseln, oder unter KDE den "Window Resize" Effekt auszuschalten. Dabei ändert sich der Fensterinhalt erst nachdem man aufgehört hat das Fenster zu vergrößern/verkleinern.

Ich weiß nur, das ich vor 14 Jahren nicht das Problem hatte! :smile:

PS: Da dies eigentlich nichts mit Manjaro zutun hat und Treiber unabhängig ist, an wem kann ich mich da wenden bzw das Problem melden?

#2

TL;DR

Bei mir fluppt alles mit Nvidia aber demnächst nur noch AMD.

#3

Kann ich nicht nachvollziehen.
Dabei ist die 960A auch wirklich das unterste Limit für die WQHD Auflösung.

Report direkt an Nvidia.
Wer für den freien Treiber unter Manjaro/Arch zuständig ist siehst im Pacman.

1 Like
#4

Falls du eine Lösung für Kwin probieren möchtest, empfehle ich diese hier:


(die erste Antwort)
Meine Probleme mit Nvidia waren danach gelöst.

#5

Ja das Glück habe ich leider nicht. Bin leider finanziell gesehen an nvidia gebunden, wegen der immens besseren performance in vergleich zu AMD.

Danke, diesen Tipp hatte ich auch schon gefunden. Brachte leider nichts.

Macht aber auch nichts mehr! Habe mir gestern bei Mediamarkt eine AMD RX550 von Saphire gekauft. Hat Displayport und kann 4k@60fps. Für rein Desktop reicht das alle mal. Und dank Singleslot passt die gut zwischen den zwei wassergekühlten Grafikkarten.

Nur steh ich wieder vor einem neuen Problem: Wie sage ich Manjaro (am besten schon Grub) das er seine Ausgabe auf die AMD GPU auf Displayport schmeißen soll? Weil selbst wenn ich die nvidia und vesa Treiber nicht lade, schmeißt Manjaro und Grub sein Bild auf die erste (unterste) nvidia Karte.