NVIDIA GPU not working, possibly related to latest driver

Oh, glxinfo is now part of mesa-utils package. So install mesa-utils and lib32-mesa-utils first. Anyway, you can just try launching OBS with prime-run and see if it can see your GPU.

Still no display, only camera and audio work.
I found this,

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

and this

info: OBS 27.1.3-3 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
	samples per sec: 48000
	speakers:        2
info: ---------------------------------
info: Initializing OpenGL...
info: Using EGL/Wayland
info: Initialized EGL 1.5
info: Loading up OpenGL on adapter Intel Mesa Intel(R) UHD Graphics 620 (WHL GT2)
info: OpenGL loaded successfully, version 4.6 (Core Profile) Mesa 21.3.5, shading language 4.60
info: ---------------------------------
info: video settings reset:
	base resolution:   1920x1080
	output resolution: 1920x1080
	downscale filter:  Bicubic
	fps:               60/1
	format:            NV12
	YUV mode:          709/Partial
info: NV12 texture support not available
info: Audio monitoring device:
	name: default
	id: default

The/usr/bin/prime - run: line 2: Segment 8987 error    (core dumped) __NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=NVIDIA_only __GLX_VENDOR_LIBRARY_NAME=nvidia "$@"

Try launching OBS with these instead of prime-run: __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia

Oh, before that, can you install mesa-utils and try glxinfo again? Just to make sure nvidia prime offload is actually working.

On second note, it maybe just wayland problem. From my quick research, OBS does have screen capture issue under wayland. So you might want to login to X11 (GDM) instead.

What is the output of mhwd -li and mhwd -l

From your inxi there is no Nvidia driver loaded for your Nvidia card.

$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime   2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

$ mhwd -l
> 0000:02:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:01:00.0 (0302:10de:1d13) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime      2021.12.18               false            PCI
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI

> 0000:00:02.0 (0300:8086:3ea0) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime      2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Maybe you could try to remove the video-hybrid-intel-nvidia-prime driver from MHWD, and try to reinstall it, or install the 470 driver instead.

If inxi still doesn’t show Nvidia driver loaded for your Nvidia card, make sure you don’t have blacklist somewhere forbidding loading the Nvidia module (optimus manager or bumblebee might do that, you said you don’t have it but that doesn’t mean you didn’t install it at some point).

For additional info give output of ls /usr/lib/modprobe.d/ and ls /etc/modprobe.d/

1 Like
qt.qpa.wayland: setGrabPopup called with a parent, QtWaylandClient::QWaylandXdgSurface(0x5649c9c4e380) which does not match the current topmost grabbing popup, QtWaylandClient::QWaylandXdgSurface(0x5649c9c7ede0) According to the xdg-shell protocol, this is not allowed. The wayland QPA plugin is currently handling it by setting the parent to the topmost grabbing popup. Note, however, that this may cause positioning errors and popups closing unxpectedly because xdg-shell mandate that child popups close before parents

And where is that warning come from? OBS or GDM?

From OBS .

I removed the video-hybrid-nvidia-prime and try install it, then I got this,

> Installing video-hybrid-intel-nvidia-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing software package databases...
Core is downloading...
Extra is downloading...
Community is downloading...
Multilib is downloading...
Error: Not found target: Linux513-nvidia
Error: Not found target: Linux514-nvidia
Error: pacman failed!
Error: script failed!
$ ls usr/lib/modproobe.d
bluetooth-usb.conf  nvdimm-security.conf  README  systemd.conf  uvesafb.conf
$ ls etc/modprobe.d
$ cat mhwd-gpu.conf
## Generated by mhwd - Manjaro Hardware Detection

You have unsupported kernels, this is why it is important to not cut down information you give (like you did with inxi).

Install supported kernel.

mhwd-kernel -i linux515

Reboot, and remove the unsupported kernels

mhwd-kernel -r linux513
mhwd-kernel -r linux514

Before doing that maybe give full list of kernels used with mhwd-kernel -li so we can have a better view. Also a full inxi -Fazy


Oh, my god, I’m using vbox with linux514, I’m not sure if I should reinstall it !

Currently running: 5.14.21-2-MANJARO (linux514)
The following kernels are installed in your system:
   * linux513
   * linux514

Install kernel 5.15, give the command output now.

sudo mhwd-kernel -i linux515

Linux515 has been installed successfully.

Currently running: 5.14.21-2-MANJARO (linux514)
The following kernels are installed in your system:
   * linux513
   * linux514
   * linux515

Give the output of the command I gave in previous post to check your concerns about virtualbox.

Anyway, you should be able to reboot on kernel 5.15 and then you could remove linux513 and linux514, then install Nvidia driver again.

Don’t be mad, Bro, I removed the kernel 513 and 514, and the NVIDIA driver has been installed successfully.

$ inxi -Fazy
  Info: model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Whiskey Lake
    family: 6 model-id: 0x8E (142) stepping: 0xB (11) microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 685 high: 700 min/max: 400/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 700 2: 700 3: 700 4: 700
    5: 700 6: 641 7: 693 8: 651 bogomips: 28808
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep
    ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave
    xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
$ inxi -G
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] driver: i915 v: kernel
  Device-2: NVIDIA GP108M [GeForce MX250] driver: nouveau v: kernel
  Device-3: Realtek USB Camera type: USB driver: uvcvideo
  Display: wayland server: X.org driver: loaded: modesetting
    failed: nvidia resolution: <missing: xdpyinfo>
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2)
    v: 4.6 Mesa 21.3.5
$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

You once again cut down the inxi output. Give the output as I asked. No need for your other inxi -G output if you give what I asked.

We can also see that the Nvidia driver is still not loaded. Either you’re not installing properly the driver (how do you install it, where are the commands output?), or you have something blacklisting/forbidding the module to load.

You reboot after installing drivers, right?

What do you mean? That is all inxi -fazy's output, I installed the driver by

$ sudo mhwd -i pci video-hybrid-nvidia-prime

and rebooted.

No that’s not, read what you posted. It is missing the beginning and the end, you copied randomly in the middle.

Then that should have installed drivers properly. Come back to command in this post and give the output (but as seen in inxi, Nvidia module is not loaded so that shouldn’t work).

As I suggested, try the 470 hybdrid driver to see if it works.

1 Like

That’s all.


$ prime-run glxinfo | grep opengl
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  50
  Current serial number in output stream:  51