Nvidia gpu doesn't work after latest updates

On some day after R515 driver release I’ve noticed, that I can’t run games with nvidia card and my nvidia-settings provides wrong information. Seems similar to: NVIDIA X Server Settings only showing two options - #2 by Olli

Also can’t load into any game when selecting Nvidia Proprietary in lutris’s settings’s vulkan ICD.

porvide formated output from:
inxi -Fazy
mhwd -l && mhwd -li

inxi -Fazy:

System:
  Kernel: 5.17.9-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.17-x86_64
    root=UUID=9561de22-96e5-46aa-9810-bb027c4815e9 rw rootflags=subvol=@ quiet
    apparmor=1 security=apparmor
    resume=UUID=095652b9-970d-4821-b278-407d8bcae184 udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Nitro AN515-45 v: V1.08
    serial: <superuser required>
  Mobo: CZ model: Scala_CAS v: V1.08 serial: <superuser required>
    UEFI: Insyde v: 1.08 date: 07/21/2021
Battery:
  ID-1: BAT1 charge: 56.0 Wh (99.6%) condition: 56.2/57.5 Wh (97.7%)
    volts: 17.5 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
    status: N/A
CPU:
  Info: model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 3269 high: 4064 min/max: 400/4280 boost: enabled
    scaling: driver: amd-pstate governor: schedutil cores: 1: 3303 2: 3291
    3: 2949 4: 2904 5: 3117 6: 3281 7: 3115 8: 3255 9: 4064 10: 4064 11: 3076
    12: 2813 bogomips: 79090
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]
    vendor: Acer Incorporated ALI driver: N/A alternate: nouveau pcie: gen: 3
    speed: 8 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
  Device-2: AMD Cezanne vendor: Acer Incorporated ALI driver: amdgpu
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s ports: active: eDP-1 empty: none bus-ID: 06:00.0
    chip-ID: 1002:1638 class-ID: 0300
  Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 3-3:2
    chip-ID: 0408:a061 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x1521 built: 2020
    res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.9-1-MANJARO)
    v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
  Device-1: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
    vendor: Acer Incorporated ALI driver: N/A alternate: snd_pci_acp3x,
    snd_rn_pci_acp3x, snd_pci_acp5x, snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 06:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.17.9-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 04:00.0
    chip-ID: 10ec:2600 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: Lite-On driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 05:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp5s0 state: up mac: <filter>
Bluetooth:
  Device-1: Lite-On Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 04ca:3802 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 3 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 1.38 TiB used: 562.36 GiB (39.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: Kingston model: OM8PDP3512B-AA1
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: EDFK0S03 temp: 50.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
    model: WDS100T1X0E-00AFY0 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 614600WD temp: 62.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
    used: 255.92 GiB (27.7%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 572 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
  ID-3: /home raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
    used: 255.92 GiB (27.7%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
    used: 255.92 GiB (27.7%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 1.64 GiB (18.6%)
    priority: -2 dev: /dev/nvme1n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 56.0 C mobo: N/A gpu: amdgpu temp: 62.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 327 Uptime: 1m wakeups: 1 Memory: 15.05 GiB
  used: 3.69 GiB (24.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: apt: 0 pacman: 1851 lib: 550 flatpak: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15

mhwd -l && mhwd -li:

> 0000:01:00.0 (0300:10de:2520) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-amd-nvidia-prime            2021.12.18               false            PCI
video-hybrid-amd-nvidia-470xx-prime            2021.12.18               false            PCI
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:06:00.0 (0300:1002:1638) Display controller ATI Technologies Inc:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-amd-nvidia-prime            2021.12.18               false            PCI
video-hybrid-amd-nvidia-470xx-prime            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
video-hybrid-amd-nvidia-prime            2021.12.18               false            PCI


Warning: No installed USB configs!

By the way, after booting into latest timeshift I have (17.05.2022) I’ve noticed that on that point everything works as expected. Is there a way to get diff between timeshift’s backup packages and latest boot?

instead of timeshifting you should have try installing the 470xx drivers and see if that would help…
also noticed that youre running 5.17.9-1 kernel, are you on unstable/testing branch?

Yes, I’m on unstable branch

maybe thats the reason? you could switch to stable, downgrade your packages, reboot and check

Since the nvidia driver is not properly installed, maybe try removing it and install the dkms driver, or just reinstall it.

Could be maybe a kernel mismatch of the nvidia module.

1 Like

After restoring to timeshift I got the following error on update:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: nvidia-dkms and linux515-nvidia are in conflict
 -> error installing repo packages

Seems like the problem was because of that conflict, last time I’ve removed the linux515-nvidia and linux517-nvidia packages to resolve conflict. What should I do to update now?

Since you installed it by mhwd, you need to remove it there:

sudo mhwd --remove pci video-hybrid-amd-nvidia-prime

(no that will only remove nvidia, amd is include in video-linux)

Then you can install the dkms module.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.