Nvidia GPU does not appear to be utilized when trying to run game through Proton


I’ve just setup Manjaro KDE and was hoping to use it as a gaming PC. I followed the standard installation and tried running Dishonored through Proton on Steam. What I found was that MangoHUD was reporting 0% usage on GPU and the frame rate was < 1fps. I tried multiple Proton targets and didn’t seem to make a difference. nvidia-smi reports 0% usage also and says the GPU is OFF.

Here’s inxi -GC:

CPU:       Info: Quad Core model: Intel Core i7-4770K bits: 64 type: MT MCP cache: L2: 8 MiB
           Speed: 3498 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3498 2: 1244 3: 3498
           4: 3333 5: 3300 6: 3499 7: 3498 8: 3499

Graphics:  Device-1: NVIDIA GK104 [GeForce GTX 770] driver: nvidia v: 470.63.01
           Display: x11 server: X.Org 1.20.13 driver: loaded: nvidia resolution: 2560x1440~60Hz
           OpenGL: renderer: NVIDIA GeForce GTX 770/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01

mhwd -li:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
          video-nvidia            2020.11.30               false            PCI

Warning: No installed USB configs!

I’m quite new to Linux for gaming so if there’s any more info I can give to shed more light please let me know. I’ve looked at lots of forum post with similar issues but hard to pin down what is relevant and what isn’t as 90% of the time those appear to be related to hybrid drivers for laptops, I’m using desktop with discrete GPU and monitor is plugged into GPU.

Other things that might be worth mentioning…

  • Steam was installed via flatpak (Manjaro didn’t seem to have Steam installed by default even though I think I read somewhere it should do?)
  • GPU isn’t being utilized even for glxgears for example
  • DE is running smoothly, no stutter or tearing
  • nonfree drivers installed via Manjaro settings

This can be a problem. flatpaks are made to be isolated.
Steam is installed by default in most editions … but if not, it is also available in the repos. Arguably easier than flatpaks as it doesnt require any extra software … and it works like you would expect too.

Wait, what?

glxinfo | grep 'renderer string'
1 Like

Thanks for your quick response!

glxinfo | grep 'renderer string' gives me:

OpenGL renderer string: NVIDIA GeForce GTX 770/PCIe/SSE2

I don’t know if GPU was being used or not, just going off nvidia-smi output.

I’ll also try installing Steam a different way, what is recommended, pacman?

pacman is the Arch traditional (:+1: )
pamac is manjaro’s own tool and is both cli and gui.
You can use either:

sudo pacman -Syu steam-manjaro


pamac install steam-manjaro

… or also
“Add/Remove Software” application (Pamac GUI)

[it is worth mentioning there is more than one option for steam, notably steam-native]

I will also leave this:

1 Like

Uninstalled flatpak Steam and installed via pacman and now getting solid FPS in Dishonored. Bit of stutter at the start, I assume that is part of the way Proton works, once I was in a level it was running very smooth. Won’t speak too soon because I have a lot of other games to test out but using flatpak Steam definitely seemed to be my issue.

Thanks for your help!

No, that’s what happens when Steam forgets to download and cache the shaders beforehand. It’s been doing that to me lately as well. :man_shrugging:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.