Nvidia Ekran Kartı Sürücüsü Kurulumu Hk


#1

sevgili açık kaynak severler, merhabalar!

bir linux aşığı olarak senelerdir kullanmaktayım, fakat windows’a olan bağımlılığımdan dolayı kopamıyordum, yanına ubuntular mintler, fedoralar kurdum, şimdi de arch bataklığına düştüm :d

gemileri yakıp sildim windows’u, tek sistem manjaro 18 kurdum, kde.

sıra geldi driver kurulumuna, her şeyi açık kaynak yaptım ama ekran kartı sürücüsünü kapalı kaynak yüklemek istiyorum, beceremedim… hadi ondan vazgeçtim açık kaynağını da yükleyemiyorum.

donanım yapılandırma aracından (mhwd) yükleyeme çalıştığımda

Waiting for user input…
Starting
> Installing video-hybrid-intel-nvidia-bumblebee…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-bumblebee/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases…
warning: bumblebee-3.2.1-22 is up to date – skipping
warning: xf86-video-intel-1:2.99.917+855+g746ab3bb-1 is up to date – skipping
warning: lib32-primus-20151110-4 is up to date – skipping
warning: lib32-nvidia-utils-1:415.25-1 is up to date – skipping
warning: linux419-bbswitch-0.8-9 is up to date – skipping
core is up to date
extra is up to date
community is up to date
multilib is up to date
resolving dependencies…
looking for conflicting packages…
:: linux419-nvidia and linux419-nvidia-340xx are in conflict. Remove linux419-nvidia-340xx? [y/N] error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

:: linux419-nvidia and linux419-nvidia-340xx are in conflict
Error: pacman failed!
Error: script failed!

Tamam …

bu hatayı alıyorum.

optirun komutuyla terminalde uygulama açmaya çalıştığımda ise

23761.109878] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[23761.109960] [ERROR]Could not connect to bumblebee daemon - is it running?

bu hatayı almaktayım :ı

yardımlarınızı bekliyorum, iyi akşamlar!


#2

Sisteminizde çakışan nvidia paketi var. octopiden linux419-nvidia-340xx paketini kaldırmanız gerekiyor. manjaronun donanım aracı sorunsuz kuruyor aslında.


#3

teşekkür ederim. octopi’den sistemimde ne kadar nvidia paketi varsa hepsini kaldırdım. nvidia paketlerini kaldırırken mhwd paketlerini de kaldırdım sanırsam. sistem ayarlarından mhwd kayboldu, terminalden tekrar yükledim mhwd paketini. sonra da

sudo mhwd -a [pci or usb connection] [free or nonfree drivers] 0300

bu komutla kurmaya çalıştım driverı, yine bir hata aldım. bir de mhwd’den deneyeyim dedim 340 hata veriyorsa 390’la deneyeyim dedim, yüklendi sanırsam :d

Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI
         network-r8168            2016.04.20                true            PCI
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

sanırsam kurdum bilmiyorum…


#4

konsol’dan glxgears komutuyla görebilirsiniz.


#5

düz glxgears komutuyla 60 fps alırken optirun glxgears komutunu girdiğimde 2000 fps alıyorum, galiba oldu. çok teşekkür ederim!


#6

60 fps üzeri gözle seçilmez diye biliyorum. 2000 frame 5 saniye içindir. Benim kart 300 frame per 5 second veriyor mesela. sizin kart yeni olmalı.


#7

tekrardan teşekkür ederim değerli bilgileriniz için, yeni sayılır evet. nvidia gtx960m kullanıyorum.