NVIDIA Drivers Seem To Not Be Working

Hello,

Just updated my system through Pamac a few minutes ago, restarted, and was met with only a black screen and terminal to log in by pressing Ctrl + Alt + F2

GPU - GeForce GTX 1070
CPU - AMD Ryzen 7 2700X

I had a similar problem like this about a month ago, something to do with the NVIDIA drivers and the Kernel update. I was instructed to make sure I was using a kernel that was LTS or supported. I tried to apply that here but I had no luck, however I’m not even sure I even did it properly. I’m still pretty new to Linux so I really don’t know what I’m doing when it comes to this kinda stuff.

I checked to see what kernels were running on my system, and it said that I had linux414 and linux511.

I really don’t know what to do at this point. Also, I am afraid of this happening again, how would I prevent this from happening in the future?

Any help would be greatly appreciated.

Hello,

That kernel is EOL, only the rt is still active in MHWD.
From TTY run this commands:
sudo mhwd-kernel -i linux510
or
sudo mhwd-kernel -i linux513
if you prefer latest stable, not LTS kernel.
then
sudo mhwd -f -i pci video-nvidia
then to be sure run
sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf
reboot your system with
systemctl reboot

Report back how it goes.

1 Like

I installed linux513 kernel and it seems to have worked, but when I try the command:
sudo mhwd -f -i pci video-nvidia
it tells me Error: script failed! and it also says above that it could not satisfy dependencies.

You must have partial update. Please run:
sudo pacman-mirrors -f5 && sudo pacman -Syyu
then run that command again to install the driver.

I ran the command
sudo pacman-mirrors -f5 && sudo pacman -Syyu
and it went through, however it still gives me the error message when it input
sudo mhwd -f -i pci video-nvidia

really weird … so, booting the 5.13 kernel still didn’t give you access to your desktop?

It did not, linux513 is definitly the kernel that is running, and this command:
sudo pacman-mirrors -f5 && sudo pacman -Syyu
Seemed to have installed everything perfectly.

Ok, so your system is working now?

Oh no it’s not I’m sorry, what I meant was that my system is saying that linux513 is the kernel that it is currently running, and that the command: ‘sudo pacman-mirrors -f5 && sudo pacman -Syyu’ installed without any errors occurring. But when I reboot I’m still met with a black screen and terminal only. Also, the command:
‘sudo mhwd -f -i pci video-nvidia’
still gives me the script fail error when I try it out. Sorry for the miscommunication.

Can you please post

cat /etc/mkinitcpio.conf

Maybe you need to add nvidia to your MODULES.

Afterwards, run

sudo mkinitcpio -P

and reboot.

I’m sorry but I don’t know if I understand. I entered:

cat /etc/mkinitcpio.conf

and it just gave me a ton of information. I don’t think I know how to add nvidia to my modules. Sorry but like I said I’m pretty new to linux so I’m still learning this kinda stuff so sorry about that.

What would happen if I just ran:

sudo mkinitcpio -P

Post this here.

This only makes sense when we have seen the content of your /etc/mkinitcpio.conf and adjusted it.




Oh okay sorry about that, here are the pics that I took

OK.

Edit the file by

sudo nano /etc/mkinitcpio.conf

There is one line starting MODULES:

MODULES=""

Change this into

MODULES=(nvidia)

Save the file and then enter

sudo mkinitcpio -P
sudo update-grub

and reboot.

1 Like

I edited the module to MODULES=(nvidia) and ran the command: sudo mkinitcpio -P
But it kept saying
ERROR: module not found: ‘nvidia’
and at the end it said
WARNING: errors were encountered during the build. Image may not be complete.
I still did the update grub command and rebooted but it didn’t work.


It still brought me to the same black screen

I got my system working, kind of.
What I did was I went back and did
sudo pacman -R cuda
and
sudo pacman -S cuda
and the system booted to a desktop, however some things are definitely wrong.
It still would not do anything when I entered
sudo mhwd -f -i pci video-nvidia
when I removed cuda. Now when I’m booted into the system, there is some lag, all the sizing of icons is different, and it says that I don’t have any nvidia drivers installed.


Correct me if I’m wrong, but the video-nvidia-390xx driver is much older than what should be available. I’m a bit scared to install anything because I don’t know if this is going to cause the same problem that started this post in the first place.

Video-nvidia is the latest driver, think its at 470 atm. Its a rolling driver and will get updated to the latest release whenever there is an update

The Arch Wiki does! NVIDIA - ArchWiki

1 Like

You need to use kernel under 5.10, try the one with LTS under it (5.4 I believe). I have a 1060 and this solved it for me.

The latest Video-nvidia driver, how would I go about properly installing that onto my system?
Also, the newer nvidia drivers won’t work with linux513 kernel?