Nvidia drivers not working in fresh install

drivers
kde
nvidia
optimus

#1

Hello, Folks!

I just installed Manjaro KDE, but I am having some trouble with the GPU drivers. I have a laptop with integrated Intel graphics card, as well as a Nvidia GeForce GTX 1050 Ti. When installing, I had to boot the installation drive with the free drivers, otherwise the installation pen would not boot. However, with the free drivers the installation went smoothly and it works great… as far as I do not need to use the dedicated graphics card :frowning:. To solve this, I first tried to go into the Settings and then go to the Hardware Configuration tab, to see if I could find the nvidia drivers. Unfortunately, clicking in the Hardware Configuration tab, brings the System Settings to a freeze.

Then I decided to use the arch wiki, in order to try and install optimus, when I stumbled upon the optimus-manager package on AUR. So, I did as the package repro on GitHub told, and installed the nvidia drivers through pacman (choosing the right 419 kernel version). However, now when using the optimus-manager to switch to nvidia GPU, the computer freezes :frowning:.

Can anyone please help me to get the nvidia drivers to work? I do not mind completely disabling the integrated GPU.

Quick note, lspsi command yields no result, it just appears to be running ad eternum.


#2

common issue, and the 1050Ti can be more temperamental than some of the others.

what are you looking for? best performance? best battery life? the answer to those questions is what really matters.

if you have the option to disable one of the GPU’s from bios, you could certainly do that and then remove current drivers and install free/nonfree for just the one card, avoiding optimus mess. (this option is not very common, some have it, most dont)

prime- best performance and uses both intel/nvidia, but can also use more power since both cards remain on, your card has decent power management so it will stay in a lower power state using less power until demand calls for it, but will still use more power than the other options.

optimus-manager- which you seem to have already attempted and didnt work, i had the same result each time i tried also so i cant really comment on optimus-manager.

bumblebee- if you want to use the intel most of the time and run gpu intensive apps/games on the nvidia on-call using primusrun or optirun to run each from command line, this is the default nonfree setup for manjaro but often needs added kernel parameters to boot properly. there is no vulkan support if thats something your looking for.

optimus-switch- is my recent creation that is both nvidia prime and intel-only. the install script sets up prime for you and allows you to set default boot mode in either prime or intel-only.
intel/nvidia prime mode works exactly like the prime option mentioned above.
intel-only mode will set the default boot mode to an intel only session that disables/powers-down the nvidia card entirely so your only using the intel gpu and you gain a lot of battery life when its needed. switching between modes are done with simple commands and be done as often as you like. switching is only needed once when changing modes, not every boot. this is what i currently use and its been working great.

sudo set-nvidia.sh (you will boot to prime mode by default)
sudo set-intel.sh (sets intel-only for much improved battery life when needed)

up to you, i can help you set up either of them. although i would be appreciative if you would try optimus-switch as its new, and yes it does work and works well.


#3

If you have time, could you have a look here and make any tweaks?

Might as well have one thing to link to instead of pasting/re-typing stuff…


#4

yes, i agree. i didnt notice that thread. i can add a short description of optimus-switch, just wasnt sure if it was ok yet as my test base is small, all working fine but still, small. thanks.


#5

It’s an option and it works for people. You could always include a disclaimer if it makes you feel better. :wink:


#6

added.


#7

First of all, thank you very much, @dglt!

Yeah, I’ve noticed that 1050Ti can be quite temperamental, as you say

I am not concerned with battery life at all, as I said, I would not mind at all if I could disable the Intel card and have the Nvidia card do all the work.

Unfortunately, I do not have this option on my BIOS

From the options that you kindly listed, optimus-switch does seem the best one! However, I stumbled upon a problem, following your setup instructions: as I said before, lspci yields no results, neither does mhwd. This means that I can neither check the BusID of my GPU, neither check the drivers that I have already installed…


#8

yeah, it happens with nouveau alot when you make any call to the nvidia gpu like inxi -G or lspci, or if you try and change drivers with mhwd. the easiest way for you to do this and also for me to walk you through any issues that may come up would be to do it from the manjaro live usb and you chroot in (its much simpler than it sounds).

boot your manjaro live usb (use free option if that is what boots, it doesnt matter)
connect to network, and come back here. and from terminal:
manjaro-chroot -a (this should drop you to a #shell on your installed manjaro)

systemctl disable optimus-manager
optimus-manager --cleanup
pacman -R optimus-manager
pacman -Qs bbswitch (this shows anything bbswitch related thats installed, remove all)
mhwd -li (this will list which mhwd installed video drivers are installed.)
remove any gpu drivers listed like this:
mhwd -r pci video-linux (free drivers are video-linux/nouveau)
then remove anything you installed regarding optimus-manager, any drivers you installed via pacman. we will use mhwd to install video-nvidia.

the important part is making sure optimus manager and bbswitch are gone, and then start installing optimus-switch.


#9

Thank you very much @dglt!!
I followed your instructions and then piked up the rest from the optimus-switch github page.
It works like a charm!


#10

nice, glad it worked out for you. thanks for letting me know.


closed #11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.