Nvidia drivers don't work

Nvidia settings do not open and Nvidia drivers don't work (as optirun -v glxgears doesn't work). I have followed most other related posts and couldn't fix it. I've modified my /etc/default/tlp to add exceptions, added my user to bumblebee group. Still nothing works. Below are some outputs for info:

mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
         network-r8168            2016.04.20                true            PCI


Warning: No installed USB configs!
optirun -v glxgears
[ 1014.613170] [INFO]Configured driver: nvidia
[ 1014.808199] [INFO]Response: No - error: Could not enable discrete graphics card

[ 1014.808242] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[ 1014.808285] [ERROR]Aborting because fallback start is disabled.
systemctl status bumblebeed
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor >
   Active: active (running) since Wed 2019-06-12 18:53:27 IST; 18min ago
 Main PID: 618 (bumblebeed)
    Tasks: 1 (limit: 4915)
   Memory: 2.2M
   CGroup: /system.slice/bumblebeed.service
           └─618 /usr/bin/bumblebeed --use-syslog

Jun 12 18:53:27 sintan-pc systemd[1]: Started Bumblebee C Daemon.
Jun 12 18:53:27 sintan-pc bumblebeed[618]: /usr/bin/bumblebeed 3.2.1-2017-02-27>
Jun 12 18:54:12 sintan-pc bumblebeed[618]: Could not enable discrete graphics c>
Jun 12 18:55:40 sintan-pc bumblebeed[618]: Could not enable discrete graphics c>
Jun 12 18:55:48 sintan-pc bumblebeed[618]: Could not enable discrete graphics c>
Jun 12 18:58:03 sintan-pc bumblebeed[618]: Could not enable discrete graphics c>
Jun 12 18:58:21 sintan-pc bumblebeed[618]: Could not enable discrete graphics c>
Jun 12 19:03:04 sintan-pc bumblebeed[618]: Could not enable discrete graphics c>
Jun 12 19:10:17 sintan-pc bumblebeed[618]:
inxi -Fxxcz
System:
  Host: sintan-pc Kernel: 5.1.8-1-MANJARO x86_64 bits: 64 compiler: gcc
  v: 8.3.0 Desktop: KDE Plasma 5.15.5 tk: Qt 5.12.3 wm: kwin_x11 dm: SDDM
  Distro: Manjaro Linux
Machine:
  Type: Laptop System: HP product: HP Pavilion Laptop 14-bf1xx
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10
  serial: <filter>
  Mobo: HP model: 83CE v: 59.38 serial: <filter> UEFI: Insyde v: F.31
  date: 10/30/2017
Battery:
  ID-1: BAT1 charge: 10.2 Wh condition: 36.5/42.1 Wh (87%) volts: 10.6/11.6
  model: Hewlett-Packard PABAS0241231 serial: <filter> status: Discharging
CPU:
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP
  arch: Kaby Lake rev: A L2 cache: 8192 KiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 31880
  Speed: 1800 MHz min/max: 400/1800 MHz Core speeds (MHz): 1: 1800 2: 1800
  3: 1800 4: 1801 5: 1800 6: 1800 7: 1800 8: 1800
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
  v: kernel bus ID: 00:02.0 chip ID: 8086:5917
  Device-2: NVIDIA GM108M [GeForce 940MX] driver: N/A bus ID: 01:00.0
  chip ID: 10de:134d
  Display: x11 server: X.Org 1.20.5 driver: intel compositor: kwin_x11
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
  v: 4.5 Mesa 19.0.6 compat-v: 3.0 direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71
  Sound Server: ALSA v: k5.1.8-1-MANJARO
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Hewlett-Packard driver: r8168 v: 8.047.01-NAPI port: 3000
  bus ID: 02:00.0 chip ID: 10ec:8168
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3000
  bus ID: 03:00.0 chip ID: 8086:095a
  IF: wlo1 state: up mac: <filter>
Drives:
  Local Storage: total: 1.03 TiB used: 521.96 GiB (49.7%)
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
  speed: 6.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: SanDisk model: SD8SN8U-128G-1006 size: 119.24 GiB
  speed: 6.0 Gb/s serial: <filter>
Partition:
  ID-1: / size: 48.72 GiB used: 16.95 GiB (34.8%) fs: ext4 dev: /dev/sdb5
  ID-2: /home size: 59.67 GiB used: 17.39 GiB (29.2%) fs: ext4
  dev: /dev/sdb2
  ID-3: swap-1 size: 8.10 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3
Sensors:
  System Temperatures: cpu: 49.0 C mobo: 29.8 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 258 Uptime: 15m Memory: 7.71 GiB used: 2.08 GiB (27.0%)
  Init: systemd v: 242 Compilers: gcc: 8.3.0 Shell: fish v: 3.0.2
  running in: fish inxi: 3.0.34

you probably need acpi_osi parameters for compatibility. this thread explains what to do.

1 Like

First, please provide system info when asking for hardware / driver assistance.

inxi -Fxxcz

Next, forum search, these sort of issues are many.

If you cannot get bumblebee to work there are other options available.

1 Like
inxi -Fxxcz
System:
  Host: sintan-pc Kernel: 5.1.8-1-MANJARO x86_64 bits: 64 compiler: gcc
  v: 8.3.0 Desktop: KDE Plasma 5.15.5 tk: Qt 5.12.3 wm: kwin_x11 dm: SDDM
  Distro: Manjaro Linux
Machine:
  Type: Laptop System: HP product: HP Pavilion Laptop 14-bf1xx
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10
  serial: <filter>
  Mobo: HP model: 83CE v: 59.38 serial: <filter> UEFI: Insyde v: F.31
  date: 10/30/2017
Battery:
  ID-1: BAT1 charge: 10.2 Wh condition: 36.5/42.1 Wh (87%) volts: 10.6/11.6
  model: Hewlett-Packard PABAS0241231 serial: <filter> status: Discharging
CPU:
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP
  arch: Kaby Lake rev: A L2 cache: 8192 KiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 31880
  Speed: 1800 MHz min/max: 400/1800 MHz Core speeds (MHz): 1: 1800 2: 1800
  3: 1800 4: 1801 5: 1800 6: 1800 7: 1800 8: 1800
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
  v: kernel bus ID: 00:02.0 chip ID: 8086:5917
  Device-2: NVIDIA GM108M [GeForce 940MX] driver: N/A bus ID: 01:00.0
  chip ID: 10de:134d
  Display: x11 server: X.Org 1.20.5 driver: intel compositor: kwin_x11
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
  v: 4.5 Mesa 19.0.6 compat-v: 3.0 direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71
  Sound Server: ALSA v: k5.1.8-1-MANJARO
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Hewlett-Packard driver: r8168 v: 8.047.01-NAPI port: 3000
  bus ID: 02:00.0 chip ID: 10ec:8168
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3000
  bus ID: 03:00.0 chip ID: 8086:095a
  IF: wlo1 state: up mac: <filter>
Drives:
  Local Storage: total: 1.03 TiB used: 521.96 GiB (49.7%)
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
  speed: 6.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: SanDisk model: SD8SN8U-128G-1006 size: 119.24 GiB
  speed: 6.0 Gb/s serial: <filter>
Partition:
  ID-1: / size: 48.72 GiB used: 16.95 GiB (34.8%) fs: ext4 dev: /dev/sdb5
  ID-2: /home size: 59.67 GiB used: 17.39 GiB (29.2%) fs: ext4
  dev: /dev/sdb2
  ID-3: swap-1 size: 8.10 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3
Sensors:
  System Temperatures: cpu: 49.0 C mobo: 29.8 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 258 Uptime: 15m Memory: 7.71 GiB used: 2.08 GiB (27.0%)
  Init: systemd v: 242 Compilers: gcc: 8.3.0 Shell: fish v: 3.0.2
  running in: fish inxi: 3.0.34

The posts you linked to provide solutions for Skylake CPUs and mine is Kabylake. Is it safe to try them out? I would rather be cautious messing with GRUB parameters.

@SinTan You will not cause any damage to the CPU with the suggested kernel parameters. It does not matter what generation your CPU is. Kabylake and Skylake are very close in their underlining architecture.

So I should just add acpi_os=! acpi_osi="Windows 2015" to /etc/default/grub, then do sudo update-grub and reboot, right?

EDIT: Tried both acpi_os=! acpi_osi="Windows 2015" and acpi_os=! acpi_osi="Windows 2009". Still the problem is present.

EDIT2: I'm dumb. Added to GRUB_CMDLINE_LINUX_DEFAULT this time. Still nothing.
Here's my /etc/default/grub:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="acpi_os=! acpi_osi='Windows 2017' quiet resume=UUID=4517ac81-4ac6-42a0-8e7a-a5870b5f98df"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

Am I still doing something wrong? @dglt

looks ok to me, just make sure you sudo update-grub after each grub edit. try the different parameters listed on the thread @linesma made. you can also try different kernel versions
sudo mhwd-kernel -i linux419

linux50 is end of life but you can try installing it as a diagnostic step.

before you go too deep into the rabit hole that is bumblebee,

you may want to see if your efforts are wasted time. compare with the other options and see what fits your needs. bumblebee has no vulkan support and wont perform as well as the other options. it's manjaro's default for optimus laptops but almost never works OOTB without some sort of modification, or ever in my case.

1 Like

Yes, I did update-grub and currently using linux51. I'll try other options I guess. Any suggestion to start from?

@SinTan Welcome to the world of trying to get Bumblebee to work properly! :grin: I personally have never been able to make Bumblebee work.

  1. You have an error in your kernel parameter

This should read acpi_osi=!

  1. I would only use that kernel parameter as a last resort. It has been known to cause issues with the touchpad and sometimes even the wireless. I would try with just this parameter first:

I had to go through a number of kernel parameters myself until I found the one that worked properly with my laptop. That is why I wrote the article you were linked to.

  1. If that does not work, I would suggest using a different option. My laptop is of similar hardware to yours, and I use the Optimus-Switch method on my laptop. It works wonderfully. I run the nVidia GPU 95% of the time, and when I need the battery life, I switch over to the Intel GPU.
My Laptop
System:
  Host: Manjaro-FX504G Kernel: 4.19.49-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.3.0 Desktop: Gnome 3.32.2 wm: gnome-shell dm: GDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: TUF GAMING FX504GD_FX80GD v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: FX504GD v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: FX504GD.314 date: 09/28/2018 
Battery:
  ID-1: BAT1 charge: 42.5 Wh condition: 42.7/48.1 Wh (89%) volts: 3.8/11.7 
  model: ASUS A32-K55 serial: <filter> status: Discharging 
CPU:
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 53004 
  Speed: 4001 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 3962 2: 3949 
  3: 4007 4: 4003 5: 3967 6: 3978 7: 3923 8: 3951 9: 3988 10: 3950 11: 4004 
  12: 4003 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK 
  driver: nvidia v: 430.14 bus ID: 01:00.0 chip ID: 10de:1c8d 
  Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: gnome-shell 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 430.14 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k4.19.49-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel port: 5000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.14 TiB used: 348.70 GiB (29.9%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 250GB 
  size: 232.89 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  ID-2: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
  speed: 6.0 Gb/s serial: <filter> 
Partition:
  ID-1: / size: 227.74 GiB used: 31.38 GiB (13.8%) fs: ext4 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 50.0 C mobo: 27.8 C gpu: nvidia temp: 43 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 333 Uptime: N/A Memory: 15.52 GiB used: 1.14 GiB (7.3%) 
  Init: systemd v: 242 Compilers: gcc: 8.3.0 Shell: bash v: 5.0.7 
  running in: gnome-terminal inxi: 3.0.34

This is what I have for my Grub:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi='Windows 2018' rd.udev.log-priority=3 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash nvme_core.default_ps_max_latency_us=5500"

I hope this helps.

2 Likes

Yeah. I gave up too. Using nvidia-prime with prime-switch currently. Works great.

@SinTan Can you share what you did so others may benefit?

1 Like

I simply followed this guide to properly configure nvidia-prime drivers and then installed prime-switch-sddm for easy switching (since I use KDE). Works perfectly.

2 Likes

Glad to hear that you found a solution that works for you. As I said before, I could never make bumblebee work properly, no matter what distro I was using. Enjoy!

1 Like

just want to mention that if you're first using the guide by jonathon you should remove the x11 conf and module files. (and undo the display manager changes) to avoid redundant files.

After removing bumblebee stuff it should be sufficient to build and install the package (just dont forget to install the nvidia kernel module(s) and nvidia-utils ("regular" and 32 bit package)) and set a config afterwards

1 Like

It's working though. But now that I've done these and installed your package (working perfectly, great job!), what exactly do you say I should change?

just check if you still have the /etc/X11/xorg.conf.d/optimus.conf config file and remove (or temporarily move to e.g. $HOME/someFolder, so if you run into issues you can move it back and further check whats causing the issue [shouldn't happen])

also check if you have other gpu related files other than "mhwd-gpu.conf" in /etc/modules-load.d and /etc/modprobe.d. If so remove (or move) them [but only gpu related module files, except mhwd-gpu.conf]

edit;
/etc/X11/xorg.conf.d should look something like this:

ls -l /etc/X11/xorg.conf.d/
total 8
-rw-r--r-- 1 root root 320 Mar 29  2016 00-keyboard.conf
-rw-r--r-- 1 root root 644 Jul 20  2018 01-mouse.conf
lrwxrwxrwx 1 root root  27 Jun  9 11:58 90-mhwd.conf -> /etc/X11/mhwd.d/nvidia.conf

/etc/modprobe.d /etc/module-load.conf like this:

$ ls -l /etc/modprobe.d/ /etc/modules-load.d/
/etc/modprobe.d/:
total 12
-rw-r--r-- 1 root root 77 Feb 23 12:24 acer_wmi.conf
-rw-r--r-- 1 root root 79 Nov 30  2015 blacklist-pcspkr.conf
-rw-r--r-- 1 root root 61 Jun  9 11:58 mhwd-gpu.conf

/etc/modules-load.d/:
total 20
-rw-r--r-- 1 root root 38 May 31 20:40 linux414-virtualbox-host-modules.conf
-rw-r--r-- 1 root root 38 May 31 20:50 linux419-virtualbox-host-modules.conf
-rw-r--r-- 1 root root 38 May 31 20:31 linux49-virtualbox-host-modules.conf
-rw-r--r-- 1 root root 44 Jun  9 11:58 mhwd-gpu.conf
-rw-r--r-- 1 root root 34 Sep 30  2018 modules.conf
1 Like

I did what you said. I was using Intel then. It booted properly. I switched to Nvidia to test. Now I'm getting this:

Edit : As far as I remember, I deleted optimus.conf fromxorg.conf.d of which I have a backup. Then, I removed nvidia and nvidia-drm from /etc/modprobe.d/ of which I do not have a backup. Please help me out.

Edit2 : Running sudo prime-switch -d intel, I can boot again. So, what might be causing it? @vetzki

Edi3: Here's my current state of those folders:

ls -l /etc/X11/xorg.conf.d/ /etc/modprobe.d/ /etc/modules-
load.d/
/etc/modprobe.d/:
total 12
-rw-r--r-- 1 root root 18 May 19 21:42 blacklist.conf
-rw-r--r-- 1 root root 61 Jun 13 21:27 mhwd-gpu.conf
-rw-r--r-- 1 root root 16 May 18 19:37 r8169_blacklist.conf

/etc/modules-load.d/:
total 8
-rw-r--r-- 1 root root 44 Jun 13 21:27 mhwd-gpu.conf
-rw-r--r-- 1 root root 34 Sep 30  2018 modules.conf

/etc/X11/xorg.conf.d/:
total 4
-rw-r--r-- 1 root root 266 May 18 19:37 00-keyboard.conf
lrwxrwxrwx 1 root root  26 Jun 13 21:27 90-mhwd.conf -> /etc/X11/mhwd.d/intel.conf

Edit4: I restored the backed up optimus.conf and I can use the nvidia gpu again. So, what might be the actual problem here? @vetzki

did you only restore old optimus.conf or also sudo prime-switch -d nvidia ?

can you check the difference between /etc/X11/xorg.conf.d/optimus.conf and /etc/X11/mhwd.d/nvidia.conf ?

edit:
only difference seems AllowEmptyInitialConfiguration option, which should be already in /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf . Can you check if you have that file (and also in xorg.log if option is used?)

1 Like

No. I only restored the old optimus.conf when my laptop was stuck after running sudo prime-switch -d nvidia.

diff /etc/X11/xorg.conf.d/optimus.conf /etc/X11/mhwd.d/nvidia.conf
1,2c1,34
< Section "Module"
<     Load "modesetting"
---
> # nvidia-xconfig: X configuration file generated by nvidia-xconfig
> # nvidia-xconfig:  version 430.14
> 
> Section "ServerLayout"
>     Identifier     "Layout0"
>     Screen      0  "Screen0"
>     InputDevice    "Keyboard0" "CoreKeyboard"
>     InputDevice    "Mouse0" "CorePointer"
> EndSection
> 
> Section "Files"
> EndSection
> 
> Section "InputDevice"
>     # generated from default
>     Identifier     "Mouse0"
>     Driver         "mouse"
>     Option         "Protocol" "auto"
>     Option         "Device" "/dev/psaux"
>     Option         "Emulate3Buttons" "no"
>     Option         "ZAxisMapping" "4 5"
> EndSection
> 
> Section "InputDevice"
>     # generated from default
>     Identifier     "Keyboard0"
>     Driver         "kbd"
> EndSection
> 
> Section "Monitor"
>     Identifier     "Monitor0"
>     VendorName     "Unknown"
>     ModelName      "Unknown"
>     Option         "DPMS"
6,9c38,62
<     Identifier "nvidia"
<     Driver "nvidia"
<     BusID "PCI:1:0:0"
<     Option "AllowEmptyInitialConfiguration"
---
>     Identifier     "Device0"
>     Driver         "nvidia"
>     VendorName     "NVIDIA Corporation"
> 	Option "NoLogo" "1"
> EndSection
> 
> Section "Screen"
>     Identifier     "Screen0"
>     Device         "Device0"
>     Monitor        "Monitor0"
>     DefaultDepth    24
>     SubSection     "Display"
>         Depth       24
>     EndSubSection
> EndSection
> 
> Section "Extensions"
>     Option         "COMPOSITE" "Enable"
> EndSection
> 
>  
> Section "InputClass"
>     Identifier          "Keyboard Defaults"
>     MatchIsKeyboard        "yes"
>     Option              "XkbOptions" "terminate:ctrl_alt_bksp"
10a64
>  
file /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf 
/usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf: ASCII text

What do you want me to check in xorg.log? I didn't get it.

Edit: I'm currently using intel gpu, should I give the outputs after switching? Does that matter?