Nvidia driver from official Nvidia site

Guys,
If I install the latest driver from the Nvidia website and then later run a full update/upgrade of my system will Pamac/Pacman detect and upgrade the driver when a newer driver is added to the manjaro repositories?.. or will I have to step through an alternate set of Nvidia driver upgrade steps? The reason I ask is that there is an issue with the 470.63 driver with some applications.

No, if you install that driver from Nvidia’s website, then your package manager will have no knowledge of its existence on your system, and then you might even run into breakage later.

Never install third-party software if the software is available from the repos or even from the AUR.

2 Likes

Thanks. What you describe is exact what I was concerned about. The current driver is unavailable from the repos.

Correction: the latest driver from Nvidia is not in the stable branch. My bad.

No it isnt … unless you mean some point release.

What you describe is the wrong way to handle drivers.

It is unsupported and will likely break things.

The search function in the top-right can help you find others like you.

For this and other topics, consult the wiki.
https://wiki.manjaro.org/index.php/Configure_Graphics_Cards

1 Like

Thanks @cscs. It was suggested that I could switch from the stable branch to testing or unstable, but I don’t want to mix a stable install base with software from the other 2 branches right now. I’ll wait a bit more before I consider branch switching.

Or ever really. You should not mix.
Choose a branch, and sync with it. Even if temporarily. But do not mix.

1 Like

@cscs:
I’m sorry bud. I really did not communicate that effectively or clearly. I’m currently on the stable branch of Manjaro KDE v21.1.6. I don’t want to pull stuff from the testing or unstable branch into my install. I would setup a separate install specifically for such endeavors (and most likely in a VM first). With that in mind I will be waiting a bit long to see if some short-term future Manjaro updates bring in a later Nvidia driver version.

You don’t understand the concept of switching branch, it doesn’t mean you pick and chose and mix packages X or Y from the multiple branches, that means you change the branch, and then you have packages available from the branch, Testing has more recent packages, Unstable has even more recent packages. When you switch branch, you update the system and you have newer packages overall.

Switching to Testing or Unstable just means you get the updates sooner (depending on the version packages currently are on the specific branch).

https://wiki.manjaro.org/index.php/Switching_Branches/en

I understood the concept. Its just that I prefer to do testing with non-stable branch software in a separate environment. However, I decided to give it a try, in a separate Manjaro install of course.

Once on the testing branch, I’m still encountering the same problem. This most likely means the issue is a Nvidia driver bug that has yet to be resolved by them or something specific to Manjaro. The odd thing is once I switched to the testing branch and did a full system update/upgrade, I’m running a v495.44 driver version. This is newer than what is available at Nvidia’s website. Nvidia’s website offers a v470.86 driver for Linux 64bit for RTX 2060 cards. If I select Windows 10 for the same RTX card they offer a v496.49 driver. Again, on other Linux distros they are running v470.7x and v470.8x. The v470.82 driver does not produce the problem on Linux Mint. I replaced the Linux Mint install with Manjaro Cinnamon v21.1.6 which upgrades to v21.2.0 in the testing branch.

So, this is quite strange.

Did I miss something? what problem?

The problem with with Lutris and specific games. A reddit user said that the problem is caused by a bug in the Nvidia driver. On non-Manjaro distros with a slightly newer Nvidia driver the problem does not occur. So, I figured maybe the bug is limited to driver versions older than v470.82. This lead to me looking to upgrade the driver on Manjaro. Now that I setup a separate Manjaro install, switched to the testing branch and did the full system update/upgrade, I’m on the v495.44 driver which is newer than what Nvidia is offering at their website. This seems quite odd to me that Manjaro would have a driver version that is newer and not available on the manufacturer’s website, and said driver is major revisions ahead (v48x.x was completely leap frogged). Despite the newer v495.44 driver the problem in Lutris persists.

As far as I know there is no 480 driver branch available to the public.
There is obviously a 495 driver branch, provided by Nvidia, available. Linux x64 (AMD64/EM64T) Display Driver | 495.44 | Linux 64-bit | NVIDIA

Now if you have an issue I suggest you open a support thread explaining in details the situation, and providing proper system information.

I see now… You are searching through the new features branch versus the production branch.

Production Branch = optimal stability and performance
New Features Branch = early adopters and bleeding edge developers

I like being on the cutting edge and having the latest/freshest production ready software. I don’t want to test Nvidia’s bleeding edge packages at this time. As far as issues are concerned I’m not sure if the problem is unique to Manjaro or if the problem is a Nvidia’s driver. Further investigation is probably warranted before involving the Manjaro team/community.

@Aragorn, @cscs, @omano:
Thank you guys for your patience and straight answers. I have a workaround for now and it works on the live v21.1.6 Manjaro and testing branch (the old and new Nvidia driver). A command string is run before launching the game in Lutris and the game behaves normally. This is the command string:
sudo nvidia-modprobe -u -c=0

If it can be demonstrated that the issue is unique to Manjaro then I will return to the forums with more information and request help.