Nvidia Clock Speed inconsistency


I have observe a strange behavior. I have an Nvidia RTX 2070 (using nvidia closed-source 495.44 in KDE) and the clock speed doesn’t go below 1100Mhz.
On the nvidia-settings and in PowerMizer the Performance Level is on 4 meaning min 300mhz and max 2100. Also the preferred mode is on auto (current Adaptive).
I have try some settings on the xorg.conf file but nothing working.

Interesting is that with coolbits if I set the offset to -100 or more the clock goes to 1050Mhz regardless the offset value, like it is the minimum.
Has anyone has something similar or solved it?

I noticed as soon as you use a program the clock speed ramps up, but if you don’t use the computer, and look in the Nvidia Settings Powermizer page, it goes down progressively. It is not instant or as responsive as it could be on Windows, it takes some time to go down.

For me no, never. Only related to something with nvidia I can say I have a small applet which shows the temp from nvidia-smi. From this one actually I started to be worry because it is steady to 52-54 with fans running while I’m in Windows is around 34 with fans stopped.

I don’t know maybe there is a bug with your kernel/driver/card combo if it never goes down, it may be worth trying to ask on Nvidia forum?

If I understand the question correctly, you want to increase the GPU clock correct?

If so, just set the Preferred Mode to “Prefer Maximum Performance” and it should force it to level 4.