NVIDIA-bumblebee stops working, needs to be reinstalled


#21

And a shutdown/boot later:
glxinfo | grep -i vendor
shows the same

but there is 2 errors more with
/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=/app/bin/steam-wrapper --file-forwarding com.valvesoftware.Steam @@u %U @@

Couldn’t find dpkg, please update steamdeps for your distribution.
Running Steam on org.freedesktop.platform 1.6 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1522709999)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast


#22

Driver should work according to
glxinfo | grep -i vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

Everything seems to work ok.
For me the problem isn’t solved. Steam is why I notice this and it’s not working. Please remember that everything works after installing video-hybrid-intel-nvidia-bumblebee, but only after the first bootup with it. Also AFIK the nvidia driver on this card, doesn’t allow videodecoding or the use of hwencoding of videos, so I need the intel card to.

inxi -b
System: Host: hc-pc Kernel: 4.16.7-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.12.5
Distro: Manjaro Linux 17.1.10 Hakoila
Machine: Type: Laptop System: Dell product: Vostro 5568 v: N/A serial: N/A
Mobo: Dell model: 0CWJTV v: A00 serial: N/A UEFI [Legacy]: Dell v: 1.1.4 date: 06/02/2017
Battery: ID-1: BAT0 charge: 42.0 Wh condition: 39.1/42.0 Wh (93%)
CPU: Dual Core: Intel Core i5-7200U type: MT MCP speed: 1893 MHz min/max: 400/3100 MHz
Graphics:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 396.24
Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 396.24
Network: Card-1: Intel Wireless 3165 driver: iwlwifi
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168
Drives: HDD Total Size: 698.65 GiB used: 90.86 GiB (13.0%)
Info: Processes: 191 Uptime: 9m Memory: 15.49 GiB used: 3.33 GiB (21.5%)
Shell: bash inxi: 3.0.07


#23

Have a nice time!


#24

Thank you for your time spend on this error.

I can’t play any games the requieres nvidia more than after the first install of the drivers, so it’s not just steam


#25

I thought I was going crazy! I have this issue too, and somehow couldn’t find this discussion using the forum search.

Tried discussing this here, however this thread has a much better description of what I find in my system.

My conclusion is same as OP, this is a driver issue and there is nothing much to do with this, except fill a report and wait for fixes. Also, would like to add that installing Nvidia prime is not working as well in my case.


#26

I HAD the exact same issue.

i had to remove already installed bumblebee, reinstall it. reboot, cross fingers, after every second or third boot.

for the last week i didn’t have to do anything. if anyone can tell me to see what updates/changes i made to my system via add-remove-software and tell me how to find a log i can provide it to see how it got resolved by itself.


#27

package changes (updating/uninstalling/installing) are logged in /var/log/pacman.log.

if you encounter that issue again you could check xorg.log and maybe dmesg (and if you’re using a display-manager systemctl status output)


#28

I believe this was a bug in kernel-alive which is now fixed. If it is not fixed, remove kernel-alive to verify.


#29

I’m sorry for you, who also has this annoying problem, but glade I’m not the only one. :angel:

I have made the following change in
/etc/bumblebee/bumblebee.conf

Under
[driver-nvidia]
I changed:
PMMethod=auto
to
PMMethod=bbswitch

It seems as that made the reinstalls needed to go down to something like 3-5 shutdowns, before the driver is gone again.
Note: I have no evidence that the change does anything…

I now use this method to un/reinstall:
Login on another screen and run a script with:

mhwd -r pci video-hybrid-intel-nvidia-bumblebee
wait
mhwd -i pci video-hybrid-intel-nvidia-bumblebee

logout of the normal session and do a
ctrl+alt+deletebackspace

and login again and check with
primusrun inxi -Gxzc0


#30

I have never had this installed.


#31

Yesterday I upgraded to the 1/7 update.
The problem is still there.

primusrun inxi -Gxzc0
sh: line 1: 13296 Segmentation fault (core dumped) /sbin/glxinfo 2> /dev/null
Graphics: Card-1: Intel HD Graphics 620 driver: i915 v: kernel bus ID: 00:02.0
Card-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 396.24 bus ID: 01:00.0
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
Message: No advanced graphics data found on this system.


#32

I also have similar issues, but it does not happen so often.

What I noticed, that on the fresh boot, the bumblebee works fine. But after suspend it is broken.
I do not need to reinstall, just a restart works.

I have the similar problem with Plasma and currently on Gnome.

Later I will add the exact error when I try to use primus/opt - run after a suspend.


#33

Works just fine for me since forever with PMMethod=auto

Some kernel releases are sketchier than others but optirun both starts and shutdowns correctly with 4.17.3-1-MANJARO even after resume from hibernate(!).

System:    Host: mjr-inspiron Kernel: 4.17.3-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.13.2 
           Distro: Manjaro Linux 17.1.11 Hakoila 
Machine:   Type: Laptop System: Dell product: Inspiron 7577
CPU:       Topology: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 1058 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1100 2: 1100 3: 1100 4: 1100 
Graphics:  Card-1: Intel driver: i915 v: kernel 
           Card-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: N/A 
           Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 18.1.3 
/etc/bumblebee/bumblebee.conf
# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d
# Xorg binary to run
XorgBinary=Xorg

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia:/usr/lib32/nvidia:/usr/lib:/usr/lib32
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau
/etc/bumblebee/xorg.conf.nvidia
Section "ServerLayout"
    Identifier "Layout0"
	Option "AutoAddDevices" "true"
EndSection

Section "Device"
	Identifier  "Device1"
	Driver      "nvidia"
	BusID       "PCI:1:0:0"
	VendorName "NVIDIA Corporation"
	Option "NoLogo" "true"
	Option "ConnectedMonitor" "DFP"
	Option "UseEDID" "true"
EndSection
/etc/default/tlp
TLP_ENABLE=1
TLP_DEFAULT_MODE=AC
TLP_PERSISTENT_DEFAULT=0
DISK_IDLE_SECS_ON_AC=0
DISK_IDLE_SECS_ON_BAT=2
MAX_LOST_WORK_SECS_ON_AC=180
MAX_LOST_WORK_SECS_ON_BAT=300
CPU_HWP_ON_AC=balance_performance
CPU_HWP_ON_BAT=balance_power
SCHED_POWERSAVE_ON_AC=0
SCHED_POWERSAVE_ON_BAT=1
NMI_WATCHDOG=0
ENERGY_PERF_POLICY_ON_AC=performance
ENERGY_PERF_POLICY_ON_BAT=power
DISK_DEVICES="sda sdb"
DISK_APM_LEVEL_ON_AC="254 254"
DISK_APM_LEVEL_ON_BAT="128 128"
DISK_SPINDOWN_TIMEOUT_ON_AC="0 100"
DISK_SPINDOWN_TIMEOUT_ON_BAT="0 70"
SATA_LINKPWR_ON_AC="max_performance"
SATA_LINKPWR_ON_BAT="max_performance"
AHCI_RUNTIME_PM_TIMEOUT=15
PCIE_ASPM_ON_AC=performance
PCIE_ASPM_ON_BAT=powersave
RADEON_POWER_PROFILE_ON_AC=default
RADEON_POWER_PROFILE_ON_BAT=low
RADEON_DPM_STATE_ON_AC=performance
RADEON_DPM_STATE_ON_BAT=battery
RADEON_DPM_PERF_LEVEL_ON_AC=auto
RADEON_DPM_PERF_LEVEL_ON_BAT=auto
WIFI_PWR_ON_AC=off
WIFI_PWR_ON_BAT=on
WOL_DISABLE=Y
SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=1
SOUND_POWER_SAVE_CONTROLLER=Y
BAY_POWEROFF_ON_AC=1
BAY_POWEROFF_ON_BAT=1
BAY_DEVICE="sr0"
RUNTIME_PM_ON_AC=on
RUNTIME_PM_ON_BAT=auto
RUNTIME_PM_DRIVER_BLACKLIST="amdgpu nouveau nvidia radeon"
USB_AUTOSUSPEND=1
USB_BLACKLIST_BTUSB=0
USB_BLACKLIST_PHONE=1
USB_BLACKLIST_PRINTER=1
USB_BLACKLIST_WWAN=1
USB_AUTOSUSPEND_DISABLE_ON_SHUTDOWN=1
RESTORE_DEVICE_STATE_ON_STARTUP=1
DEVICES_TO_DISABLE_ON_STARTUP=""
DEVICES_TO_ENABLE_ON_STARTUP="wifi bluetooth"
DEVICES_TO_DISABLE_ON_SHUTDOWN=""
DEVICES_TO_DISABLE_ON_BAT="wwan"
DEVICES_TO_DISABLE_ON_BAT_NOT_IN_USE="wifi wwan"
DEVICES_TO_DISABLE_ON_LAN_CONNECT="wwan"
DEVICES_TO_DISABLE_ON_WIFI_CONNECT="wwan"
DEVICES_TO_DISABLE_ON_WWAN_CONNECT="wifi"
DEVICES_TO_ENABLE_ON_LAN_DISCONNECT="wifi wwan"
DEVICES_TO_ENABLE_ON_WIFI_DISCONNECT="wwan"
DEVICES_TO_ENABLE_ON_WWAN_DISCONNECT="wifi"

Bumblebee error - Could not enable discrete graphics card
#34

This is not a bug that everyone has, only the selected few :wink:

System:    Host: hc-pc Kernel: 4.17.3-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.13.2 
           Distro: Manjaro Linux 17.1.11 Hakoila 
Machine:   Type: Laptop System: Dell product: Vostro 5568
CPU:       Dual Core: Intel Core i5-7200U type: MT MCP speed: 1365 MHz min/max: 400/2500 MHz 
Graphics:  Card-1: Intel HD Graphics 620 driver: i915 v: kernel 
           Card-2: NVIDIA GM108M [GeForce 940MX] driver: N/A 
           Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 18.1.3

I don’t use a swap partition, so can’t say anything about hibernate.

Thankyou for sharing your settings, here are the diffs from yours and mine. Maybe someone can spot if there’s any fatal differences:

/etc/bumblebee/bumblebee.conf
That file is equal to yours. It seems to get changed to default on every update?,
so now I also have
PMMethod=auto
I’ll keep it to see if it does change the frequent of needed un/installs.

diff -w slet /etc/bumblebee/xorg.conf.nvidia  
8c8
<       Option "AutoAddDevices" "true"
---
>     Option "AutoAddDevices" "false"
14d13
<       BusID       "PCI:1:0:0"
16a16
>     Option "UseEDID" "false"
18d17
<       Option "UseEDID" "true"
19a19
>


/etc/default/tlp
cat /etc/default/tlp | sed -e 's/\#.*//' | sed '/^\s*$/d' >slet2
diff -w slet slet2
6,7c6,7
< MAX_LOST_WORK_SECS_ON_AC=180
< MAX_LOST_WORK_SECS_ON_BAT=300
---
> MAX_LOST_WORK_SECS_ON_AC=15
> MAX_LOST_WORK_SECS_ON_BAT=60
18,21c18,19
< DISK_SPINDOWN_TIMEOUT_ON_AC="0 100"
< DISK_SPINDOWN_TIMEOUT_ON_BAT="0 70"
< SATA_LINKPWR_ON_AC="max_performance"
< SATA_LINKPWR_ON_BAT="max_performance"
---
> SATA_LINKPWR_ON_AC="med_power_with_dipm max_performance"
> SATA_LINKPWR_ON_BAT="med_power_with_dipm max_performance"
37,38c35,36
< BAY_POWEROFF_ON_AC=1
< BAY_POWEROFF_ON_BAT=1
---
> BAY_POWEROFF_ON_AC=0
> BAY_POWEROFF_ON_BAT=0
42,43c40,41
< RUNTIME_PM_DRIVER_BLACKLIST="amdgpu nouveau nvidia radeon"
< USB_AUTOSUSPEND=1
---
> RUNTIME_PM_DRIVER_BLACKLIST="amdgpu nouveau nvidia radeon pcieport"
> USB_AUTOSUSPEND=0
45c43
< USB_BLACKLIST_PHONE=1
---
> USB_BLACKLIST_PHONE=0
48,61c46
< USB_AUTOSUSPEND_DISABLE_ON_SHUTDOWN=1
< RESTORE_DEVICE_STATE_ON_STARTUP=1
< DEVICES_TO_DISABLE_ON_STARTUP=""
< DEVICES_TO_ENABLE_ON_STARTUP="wifi bluetooth"
< DEVICES_TO_DISABLE_ON_SHUTDOWN=""
< DEVICES_TO_DISABLE_ON_BAT="wwan"
< DEVICES_TO_DISABLE_ON_BAT_NOT_IN_USE="wifi wwan"
< DEVICES_TO_DISABLE_ON_LAN_CONNECT="wwan"
< DEVICES_TO_DISABLE_ON_WIFI_CONNECT="wwan"
< DEVICES_TO_DISABLE_ON_WWAN_CONNECT="wifi"
< DEVICES_TO_ENABLE_ON_LAN_DISCONNECT="wifi wwan"
< DEVICES_TO_ENABLE_ON_WIFI_DISCONNECT="wwan"
< DEVICES_TO_ENABLE_ON_WWAN_DISCONNECT="wifi"
< 
---
> RESTORE_DEVICE_STATE_ON_STARTUP=0

#35

I would focus on xorg config.

Contrary to what I pasted, mine also includes a plethora of commented-out lines because unfortunately getting it to work just right seems to be akin to devising a magical incantation that changes every so often with kernel/xorg/mesa releases.


#36

I tested, but it seems not to be related. Unfortunately. Thanks for trying to help.


#37

Well, I found a workaround, which requires an extra reboot. I either remove 20-intel.conf or add it again depending on the state, then I reboot. This is working every time, so I suppose the problem is related to DRI.

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "DRI" "2"             # DRI3 is now default 
        Option      "AccelMethod"  "sna" # default
        #Option      "AccelMethod"  "uxa" # fallback
EndSection

#38

I’m running stable, if that has any influence on things.
Since the update to 1/7, I have had this bug twice, but only on the boot right after the update and then one more time a couple of boots later. Since then, the driver is loaded on every boot.

I don’t have 20-intel.conf

locate intel.conf
/etc/X11/mhwd.d/intel.conf

cat /etc/X11/mhwd.d/intel.conf
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
Section "Device"
    Identifier  "Device0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
    Option      "AccelMethod" "sna"
        Option      "DRI"    "true"
EndSection
 
 
Section "DRI"
        Group  "video"
        Mode   0666
EndSection
 
 
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER"    "Enable"
EndSection
 
 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

#39

This seems to be solved. I don’t know what solved it but, the driver always loads now.


#40

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.