NVIDIA-bumblebee stops working, needs to be reinstalled


#1

The proprietary drivers doesn’t stay in a working condition

I install video-hybrid-intel-nvidia-bumblebee from system settings - Hardware Configuration
I reboot and the driver is there and working.

I shutdown and boot the driver is, well not really gone, but not working.
I have to uninstall the driver, shutdown, boot, install, shutdown and boot to make them work one more time.
Shutdown is needed it seems. A reboot seems not to install the driver in a working condition.
I have to do this on two laptops. The error is there with kernel 4.14 and 4.16.
I don’t know if the error was the before the 28-04-2018 stable update.

Anyone else have this problem or an idea about what is wrong?
I now run nvidia 396 from todays upgrade, but the errors are the same.

Driver installed and working
inxi without primusrun:

Graphics: Card-1:
Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: N/A
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 18.0.1

inxi with primusrun:

Graphics:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: N/A
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 390.48

Driver not working
inxi without primusrun:

Graphics:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 390.48
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: N/A v: N/A

inxi with primusrun:

sh: line 1: 2582 Segmentation fault (core dumped) /sbin/glxinfo 2> /dev/null
Graphics:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 390.48
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
Message: No advanced graphics data found on this system.

From konsole when starting steam:

optirun /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=/app/bin/steam-wrapper --file-forwarding com.valvesoftware.Steam @@u %U @@
Couldn’t find dpkg, please update steamdeps for your distribution.
Running Steam on org.freedesktop.platform 1.6 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1522709999)
Installing breakpad exception handler for appid(steam)/version(1522709999)
Installing breakpad exception handler for appid(steam)/version(1522709999)
OpenGL GLX extension not supported by displayMain.cpp (323) : Assertion Failed: Fatal Error: OpenGL GLX extension not supported by display
Assert( Assertion Failed: Fatal Error: OpenGL GLX extension not supported by display ):Main.cpp:323

Installing breakpad exception handler for appid(steam)/version(1522709999)
assert_20180506103129_5.dmp[130]: Uploading dump (out-of-process)
/tmp/dumps/assert_20180506103129_5.dmp
assert_20180506103129_5.dmp[130]: Finished uploading minidump (out-of-process): success = no
assert_20180506103129_5.dmp[130]: error: Couldn’t connect to server
assert_20180506103129_5.dmp[130]: file ‘’/tmp/dumps/assert_20180506103129_5.dmp’’, upload no: ‘‘Couldn’t connect to server’’

[Stable Update] 2018-05-07 - Kernels, Mesa, Glibc, PHP, Nvidia, Plasma5, Firefox
/usr/lib/modules getting deleted on boot
#2

This is working so use this driver.
Check Update Announcement wiki post, please as ALWAYS. This is a well known issue and Manjaro devs gave a good solution.


#3

I know it’s a long read, but did you read all of it?
Your link is to Fermi support getting dropped, which has notting to do with my problem.
I also wrote that I’m running todays update with 396


#4

and how did you get to this conclusion?


#5

Please be more specific. It seems that I don’t understand what the wiki says or what you are trying to hint me about.


#6

I am sorry, I miss-read your issue. I was confused.

What do you mean by that. It doesn’t say something I can understand.

Which driver?

It seems you have 390xx installed as of your inxi reports.
Check:

mhwd -li

Because of the changes of the Update, it might have been needed to reboot after uninstall, but did you try uninstall and install before reboot?

That’s why I can’t understand how you got this


#7

@petsam

Next time your trying to help, which I appreciate, do not shout at people and do not automatic make the assumption that others don’t read the release wiki, thank you.

All your questions are answered in the first post. I even did show the inxi in a working state and in a non working state, which shows the driver is installed, but not working.

Just exchange the nvidia driver version with the new 396. The problem is the same and it’s annoying and I’m baffled about why it doesn’t stay fully installed.

Uninstall and install, before reboot doesn’t make the driver installed. I need to do the procedure as described in my first post.


#8

Still, he made a good observation, in both cases the inxi output from your post indicate that:

and not the NVIDIA 396.24, hence the confusion …


#9

Yes your right. I did write in the the first post that I’m using 396. It annoys me a bit, when someone start shouting and making assumptions about things they don’t know.


#10

I think we all do assumptions and somehow spirits get carried away sometimes, especially behind keyboards … we are all guilty of it :slight_smile:
But now that everything calmed down a bit, maybe you can give another try to the installer.
Is it that you want to use the legacy nvidia 39xx or you want the 396.24 one that seems to work on your GPU


#11

I’ll do it again. After todays stable update and a shutdown/boot, the driver was working as expected.
Another shutdown/boot, it’s there but not really which is now.
I’ll do a uninstall reinstall after this post

inxi -F without primusrun:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 396.24
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: N/A v: N/A

primusrun inxi -F
sh: line 1: 25570 Segmentation fault (core dumped) /sbin/glxinfo 2> /dev/null
Graphics:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 396.24
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
Message: No advanced graphics data found on this system


#12

I’m happy every time someone is wiling to try to help me. Sometimes misunderstandings will happen. There is not reason to treat misunderstanding that way. Bottom line, someone just tried to help.

Some members may be reluctant to help next time.


#13

I am sorry you thought I was shouting. I usually whisper :smile: . Some 20 years internet experience taught me that shouting is capital letters.
and trying to prevent that, I showed you the “why” of my assumptions.
No hard feelings, though.

Please provide the output of these commands

mhwd
mhwd -li

#14

There was “ALWAYS” and the assumption and I tryed in the politest way to tell you that I don’t like that.
Anyway, no hard feelings and let us put this behind us and start over.

Here is the driver in a working state:
I install the drivers from system-settings -> Hardware Configuration

inxi -F without primusrun
Graphics:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: N/A
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 18.0.3

primusrun inxi -F
Graphics:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: N/A
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 396.24

shutdown/boot and the error is back


#15

This is when the driver doesn’t work.

mhwd

0000:00:02.0 (0300:8086:5916) Display controller Intel Corporation:


              NAME               VERSION          FREEDRIVER           TYPE

video-hybrid-intel-nvidia-bumblebee 2018.05.04 false PCI
video-hybrid-intel-nvidia-390xx-bumblebee 2018.05.04 false PCI
video-linux 2018.05.04 true PCI
video-vesa 2017.03.12 true PCI

0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:


              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI

0000:01:00.0 (0302:10de:134d) Display controller nVidia Corporation:


              NAME               VERSION          FREEDRIVER           TYPE

video-hybrid-intel-nvidia-bumblebee 2018.05.04 false PCI
video-hybrid-intel-nvidia-390xx-bumblebee 2018.05.04 false PCI
video-nvidia 2018.05.04 false PCI
video-nvidia-390xx 2018.05.04 false PCI
video-linux 2018.05.04 true PCI

mhwd -li

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI

video-hybrid-intel-nvidia-bumblebee 2018.05.04 false PCI

Warning: No installed USB configs!


#16

Now I think is clear.
You need to install the 390 driver.
Uninstall video-hybrid-intel-nvidia-bumblebee
Install video-hybrid-intel-nvidia-390xx-bumblebee
Reboot (crossing fingers of course)


#17

I was using the 390 driver with the stable update from 28-04-2018, same thing was going on, so don’t cross those fingers to hard :wink:

And 396 does work, but only after the first shutdown/boot


#18

Does PRIME work for you?


#19

After following the how2 on the link:
glxinfo | grep -i vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

It’s getting much hotter with this, the fans run all the time.

I can’t run steam with this:
/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=/app/bin/steam-wrapper --file-forwarding com.valvesoftware.Steam @@u %U @@

Couldn’t find dpkg, please update steamdeps for your distribution.
Running Steam on org.freedesktop.platform 1.6 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!


#20

At least the driver is working. Or not?
Is everything else in your system and GUI working?
If this steam program is the problem you might mark this as solved and start another topic, or change the title of this one, since it doesn’t align with the issue.
In anyway you should post your system info.