NVIDIA broke their 3000 series graphics cards on Linux with a recent update

Excuse me gentlemen. I am a pretty massive linux noob, but after the direction windows is taking I couldn’t in good conscience use their product, and I still can’t.

Here’s what I’m struggling with. I purchased a top end new computer about 4 - 5 months ago (NIVIDIA geforce rtx 3080 graphcis card), Manjaro ran beautifully for me for that whole time. then about a week ago I started having problems with it. Some unrelated problems to do with the computer at first, which I resolved. And now an update came through more recently which seems to have broken the NVIDIA graphics drivers completely. I’ve looked across the forum and tried literally every solution available, and to date all I’ve succeeded in doing is wiping my installation and trying again 5 times in a row. I’ve spent a full 3 days tinkering with this accursed machine.

At first when I ran the update, I think it might’ve got corrupted, or failed to finish for some reason which caused the first breakage. Then I tried to reinstall everything with the 4 - 5 month old bootable drive I made when I first started with Manjaro. The updates once again resolved to a blackscreen.

So then I updated the bootable drive to the latest version, and I’ve done that for the last three attempts to get the computer working correctly, but to date all I think I have discovered is that the latest updates have broken the NVIDIA graphics drivers. I’m really a bit heartbroken about it. I’ve followed every guide here related to blackscreens, NVIDIA drivers and everything in between with no luck at all.

If I can get it working again at some point in the nearby future, I very strongly doubt I will be updating it regularly anymore.

What should I do?

Quick edit for future benefit of others:
NVIDIA released an update that breaks their 3000 series graphics cards for Linux. Brahma helped me fixed this by suggesting that we delete the offending drivers and revert back to an older version.

and what exactly is the issue? you ending up in a black screen?
can you enter into tty in the black screen: ctrl+alt+f2 or f1-f6 keys?

When applying a solution, do you understand what it does, and where the issue came from?

None of the tty terminals work at all to my knowledge. I have very little knowledge about what is causing the problem. I’m currently starting fresh again from the bootable drive. Running sudo pacman -Syyu and that’s it so far.

so if tty doesnt work, you probably affected with the latest nvidia drivers bug, that causes the 3000 series cards not to boot…
so boot into manjaro live usb, connect to internet and chroot by running this command:
manjaro-chroot -a
and provide output from:
mhwd-kernel -li && mhwd -l && mhwd -li

1 Like

Ahh yes that sounds like what it is. Ok I have a fairly slow internet, and the sudo pacman -Syyu command is about 40 percent finished. It’ll take a bit before it finishes. I will reconvene with that output you requested as soon as I am able. Give me 30 minutes or so.

and you running the syyu command in the live usb?

No I did a fresh install on the main SSD and ran the command in there. ~50% complete now. You can see why doing this 5 times has taken me 3 days xD

ok i see, so you are right now in your installation, so you dont have to boot into usb, you can just install the 470xx drivers after you finished with syyu…

I did this on a previous occasion and it broke. I was thinking maybe I should try rebooting it without the drivers to begin with, to see if anything in the sudo pacman -Syyu command breaks the OS. Then if it didn’t I was going to install the drivers and reboot again to see if it broke.

(Then I was thinking of switching to the live environment and running your commands :wink: )

open new terminal window and post output from:
mhwd-kernel -li && mhwd -l && mhwd -li

Copy that.

Here is the output:

mhwd-kernel -li && mhwd -l && mhwd -li                                                         ✔ 
Currently running: 5.15.60-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux515
> 0000:2d:00.0 (0300:10de:2216) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI
    video-nvidia-470xx            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI

Warning: No installed USB configs!

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

so when you done with the syyu command, remove video-nvidia:
sudo mhwd -r pci video-nvidia
and install this:
sudo mhwd -i pci video-nvidia-470xx

Yes boss.

Will let you know how it goes. :slight_smile:

Just a side note:

If you do this, you will end up with an unusable machine, there’s no two way about it. Manjaro requires you to keep it up-to-date. Read this, it’ll help:

Also, never install updates blindly. Keep an eye on the #announcements section for your branch. There is an announcement, with a list of gotchas and fixes before every #announcements:unstable-updates, #announcements:testing-updates and #announcements:stable-updates.

Hey Mirdarthos, I appreciate your honest response I really do, but I think things like this are what turn people off Linux if I’m honest.

The OS needs to be stable eventually, or people will just never use it in large numbers. Most people haven’t got time to futz around with forums and console commands to keep their computers running, which is probably why Microsoft has such a large market share of desktop computers.

The system being unstable when you do and don’t update it is not a good thing, and it shouldn’t stay that way forever.

It is possible to keep a stable system but it is not for casual user.

Maintaining a GNU/Linux system on bleeding edge requires dedication and willingnes to learn from your mistakes.

I have one system running on Arch testing - no issues for a month.

One essential is - do not stray from upstream theming - custom themes and extensions are the major cause of incidents when syncing system packages.

1 Like

If you’d rather like a fixed-release system, similar to Windows’ updates, look at Ubuntu LTS.

Manjaro is a (Curated) Rolling release. So it is, indeed, going to be more…DIY. Sure, it’s user-friendly, but it’s also still suitable for more advanced users. That’s just how it is.

1 Like

Hi brahma.

This appears to have worked. The computer successfully rebooted for the first time in quite a while lol. Thanking you kindly.