NVIDIA affecting input devices


I’m running on an intel-nvida system, using Optimus. When Optimus is set to Nvidia with no external display attached, I have issues with input devices, namely the trackpad or mouse and the keyboard. When doing something, the system freezes for a second, then duplicates the action. For example, when typing, if I stop for a short time, and then resume typing, the first character lags a second then it appears duplicated. This does not happen either with Optimus set to use the Intel card, nor when I have an external display attached when using the Nvidia card.

Any idea what is going on?

Here’s the output of inxi --basic:

Machine:   Type: Laptop System: LENOVO product: 20QNCTO1WW v: ThinkPad P53 serial: <superuser/root required> 
           Mobo: LENOVO model: 20QNCTO1WW v: SDK0J40697 WIN serial: <superuser/root required> UEFI: LENOVO v: N2NET37W (1.22 ) 
           date: 04/28/2020 
Battery:   ID-1: BAT0 charge: 68.2 Wh condition: 80.0/90.0 Wh (89%) 
CPU:       Info: 6-Core Intel Core i7-9850H [MT MCP] speed: 800 MHz min/max: 800/4600 MHz 
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA TU106GLM [Quadro RTX 3000 Mobile / Max-Q] driver: nvidia v: 440.100 
           Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: modesetting,nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: Quadro RTX 3000/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 
Network:   Device-1: Intel Ethernet I219-LM driver: e1000e 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi 
Drives:    Local Storage: total: 953.87 GiB used: 206.54 GiB (21.7%) 
Info:      Processes: 296 Uptime: 5h 41m Memory: 30.98 GiB used: 3.73 GiB (12.0%) Shell: Bash inxi: 3.1.08 

Try enabling Force Full Composition Pipeline under NVIDIA X Server Settings > X Server Display Configuration > Advanced.

1 Like

Thanks. I just tried it, but when I click Advanced nothing happens. I don’t get anything different from Basic, no new options.

Hmm, maybe your card doesn’t support that feature.

That’s a bummer

Since the 440.100 driver is being removed, have you tried the latest one?

sorry for the late reply, didn’t want to update in the middle of a project.

I updated to 455.45.01 and the problem persists.

This option appears only when an external display is connected.

Please start libinput debug-events, that should give you timing information about input events, based on that you can determine if the input events or the GUI stack lags. You should also check if there are relevant entries in the journal: journalctl -b | grep "event processing lagging".

journalctl -b | grep "event processing lagging shows no output.

In libinput debug-events I see the timing but not sure what I should expect. There is some lag when hitting a key, but then the output prints OK (with the same lag as the actual input event happening). Sometimes pressed events are duplicated, but not always. Sometimes I get a duplicate character while typing but there’s a single KEYBOARD_KEY ... pressed event logged. Sometimes they are duplicate. It’s not very consistent.

It’s kinda trivial but i managed to fix this issue by setting maximum performance in nvidia x server settings. By default its adaptive

1 Like

Nice! This seems to work. Thanks!

EDIT: Sorry, actually it didn’t solve the problem…

Is there a way to make this change permanent? It gets back to auto every time I reboot.