Nvidia-455xx-455.45.01-1 is not working

With the changes to nvidia
the “linux59-nvidia” driver is not working
am I missing something or is one of the files in need of an update?

I have “nvidia-utils” and “mhwd-nvidia” installed but none of it seems to work.

The above provides nvidia-455xx-455.45.01-1

Tried linx54 but still no joy.

It doesn’t load? What’s the output of sudo modprobe nvidia? Is the correct mhwd configuration applied?

modprobe: ERROR: could not insert ‘nvidia’: No such device

That’s interesting and I don’t think it should happen. What’s the output of mhwd -li and modinfo nvidia?

?1 ~ $ mhwd -li [1]
Warning: No installed PCI configs!
Warning: No installed USB configs!

?1 ~ $ modinfo nvidia                                                                                     [1]
filename:       /lib/modules/5.9.11-3-MANJARO/extramodules/nvidia.ko.gz
alias:          char-major-195-*
version:        455.45.01
supported:      external
license:        NVIDIA
srcversion:     9596FDF4ECB68196404E921
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
retpoline:      Y
name:           nvidia
vermagic:       5.9.11-3-MANJARO SMP preempt mod_unload modversions 
parm:           NvSwitchRegDwords:NvSwitch regkey (charp)
parm:           NvSwitchBlacklist:NvSwitchBlacklist=uuid[,uuid...] (charp)
parm:           nv_cap_enable_devfs:Enable (1) or disable (0) nv-caps devfs support. Default: 1 (int)
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_TCEBypassMode:int
parm:           NVreg_EnableStreamMemOPs:int
parm:           NVreg_EnableBacklightHandler:int
parm:           NVreg_RestrictProfilingToAdminUsers:int
parm:           NVreg_PreserveVideoMemoryAllocations:int
parm:           NVreg_DynamicPowerManagement:int
parm:           NVreg_DynamicPowerManagementVideoMemoryThreshold:int
parm:           NVreg_EnableUserNUMAManagement:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_KMallocHeapMaxSize:int
parm:           NVreg_VMallocHeapMaxSize:int
parm:           NVreg_IgnoreMMIOCheck:int
parm:           NVreg_NvLinkDisable:int
parm:           NVreg_EnablePCIERelaxedOrderingMode:int
parm:           NVreg_RegisterPCIDriver:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RegistryDwordsPerDevice:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_GpuBlacklist:charp
parm:           NVreg_TemporaryFilePath:charp
parm:           NVreg_AssignGpus:charp
√ ~ $

That could be a problem. Please use mhwd to install the drivers, or if you want a graphical interface, use Manjaro Settings Manager > Hardware Configuration.

If you don’t have an intel GPU or you don’t want to use it: sudo mhwd -i pci video-nvidia-455xx;
if you have an intel GPU and you want to use it: sudo mhwd -i pci video-hybrid-intel-nvidia-455xx-prime.

Or you can run sudo mhwd -a pci nonfree 0300 to let it automatically pick a configuration.

I had to install all the files “sudo mhwd -a pci nonfree 0300” wanted first. The one problem is “lib32-nvidia-utils” cals “nvidia-455xx” which no longer exits. Found the file in th AUR and downloaded, built and installed. Guess this file needs an update?
Then “sudo mhwd -a pci nonfree 0300” works happily skipping the previously installed files and doing its stuff. So it works now.

hi robin.
same error. and i found all the “455xx” seems no longer exits too in the AUR !
i can not get the “nvidia-455xx-utils”, which “lib32-nvidia-utils” needed from any channel.
so which package you use? please help me.

It’s now just video-nvidia as there’s now a unified driver.

It already was today.

❯ pacman -Qs nvidia
local/lib32-libvdpau 1.4-1
    Nvidia VDPAU library
local/lib32-nvidia-utils 455.45.01-3
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/libxnvctrl 455.45.01-1
    NVIDIA NV-CONTROL X extension
local/linux54-nvidia 455.45.01-2 (linux54-extramodules)
    NVIDIA drivers for linux.
local/linux59-nvidia 455.45.01-2 (linux59-extramodules)
    NVIDIA drivers for linux.
local/mhwd-nvidia 455.45.01-2
    MHWD module-ids for nvidia 455.45.01
local/mhwd-nvidia-390xx 390.132-1
    MHWD module-ids for nvidia 390.132
local/nvidia-utils 455.45.01-2
    NVIDIA drivers utilities

Thank you, Yochanan
it’s worked now .
a sync issue? i guess

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.