Nvidia-450xx-utils and nvidia-440xx-utils are in conflict

Remove nvidia-utils. That looks like a bottleneck. All of them.

You may be right:

❯ sudo pacman -R linux54-nvidia-440xx nvidia-440xx-utils
[sudo] password for nate: 
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-440xx-utils breaks dependency 'nvidia-utils' required by cuda
:: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils=440.100' required by linux58-nvidia-440xx
:: removing nvidia-440xx-utils breaks dependency 'nvidia-utils' required by nvtop

I’ll try that.

I managed to get on Kernel 5.8.6 while I was at it.

Add linux58-nvidia-440xx and cuda and nvtop to the list …

Good work, now get rid of all the 440 cruft. :grin:

❯ sudo pacman -R nvidia-utils
error: target not found: nvidia-utils

Any updates on the issue? I am experiencing the same… it doesn’t seem to want me installing the latest Nvidia drivers. Conflicting packages and all.

Removing all of it mhwd, lib32, utils, opencl and replacing it with the 450 breaks my system. I have to remove it all over again and reinstall the 440. Doesn’t matter which kernel I use (57 or 58).

EDIT: last time I did it lightdm didn’t want to start either.

❯ sudo pacman -R linux54-nvidia-440xx nvidia-440xx-utils linux58-nvidia-440xx cuda nvtop
checking dependencies...
:: blender optionally requires cuda: cycles renderer cuda support
:: ffmpeg optionally requires nvidia-utils: Nvidia NVDEC/NVENC support
:: ksysguard optionally requires nvidia-utils: NVIDIA GPU usage
:: steam-manjaro optionally requires vulkan-driver: packaged vulkan driver
:: vulkan-icd-loader optionally requires vulkan-driver: packaged vulkan driver

Packages (5) cuda-11.0.2-1  linux54-nvidia-440xx-440.100-14  linux58-nvidia-440xx-440.100-12  nvidia-440xx-utils-440.100-1
             nvtop-1.0.0-2

Total Removed Size:  5440.35 MiB

:: Do you want to remove these packages? [Y/n] y
:: Processing package changes...
(1/5) removing nvtop                                                           [#############################################] 100%
(2/5) removing cuda                                                            [#############################################] 100%
(3/5) removing linux58-nvidia-440xx                                            [#############################################] 100%
(4/5) removing linux54-nvidia-440xx                                            [#############################################] 100%
(5/5) removing nvidia-440xx-utils                                              [#############################################] 100%
xorg configuration symlink valid...
:: Running post-transaction hooks...
(1/4) Reloading system manager configuration...
(2/4) Arming ConditionNeedsUpdate...
(3/4) Updating module dependencies...
(4/4) Updating the desktop file MIME type cache...

Try nvidia-440xx-utils

Yup. Got it, as can be seen from in my previous post. Thanks :wink:

1 Like

There could be light at the end of the tunnel. Now install nvidia-450xx-utils, or is that premature, I’m not sure…Check Pamac.

I’m a step ahead of you :smiley:

https://imgur.com/a/zPptvAI

1 Like

Yep, fair play :laughing:

Follow (tracking) this thread, it seems we’re close to a solution :crossed_fingers: :smile:

Note: I updated to 450xx in System > Hardware Configuration and uninstalled the 440xx there as well, this after I ran:

sudo pacman -R linux54-nvidia-440xx nvidia-440xx-utils linux58-nvidia-440xx cuda nvtop
1 Like

:white_check_mark:
Your System is up to date!

:checkered_flag:

1 Like

Rock ‘n’ Roll! :metal: :grin:

Leave the thread open because @Olomorn needs to read this too. I think he’s crashed out for now but it might be useful when he wakes up :laughing:

To sum up (I think):

  • I installed Kernal 5.8.6 using System Settings > Kernel
  • I edited Grub: sudo nano /etc/default/grub and changed GRUB_TIMEOUT from 0 to: GRUB_TIMEOUT=10 (may not be an issue for you if you get Grub Menu already.)
  • I ran sudo update-grub and rebooted.
  • I hit the Shift key (and tried F8 while at it but, it may have just went straight there, not sure which) to get the Grub menu.
  • I choose a menu option (but forget which) and selected Kernel 5.8.6.
  • I ran the following command to remove the 440xx: sudo pacman -R linux54-nvidia-440xx nvidia-440xx-utils linux58-nvidia-440xx cuda nvtop
  • I installed video-nvidia-450xx using System Settings > Hardware Configuration ( https://imgur.com/a/zPptvAI)
  • I uninstalled video-nvidiea-440xx while there.
  • Updated using Pamac, now with no conflicts.

Aside: I’m in the process of reinstalling cuda using Pamac, this for Blender’s sake and I left nvtop uninstalled, as I don’t use it.

Thanks for your help everyone!

3 Likes

Good summary, kudos :smile:

Well, I run into the same error message about 440 and 450 driver conflict. I was not alarmed and manually removed nvidia 440 driver. Run installation. It succeeded and … lightdm failed to start on reboot.

I was able to login using console. Then as root I executed the following command to let it autodetect my card and install drivers for it:

mhwd -a pci nonfree 0300

I took command from wiki documentation on " Configure Graphics Cards".

Reboot again and I am back in business and reporting the solution to this thread.

Here is what I see if I list installed packages on my machine:

pacman -Qqe | grep nvidia
lib32-nvidia-450xx-utils
linux57-nvidia-450xx
linux58-nvidia-450xx
nvidia-450xx-utils
1 Like

There seems to be a lot of issues between the free and non-free drivers still. I have had similar issues that were unrelated to nvidia but affected my trackpad and hotkeys. It goes on and on…

But it’s good to know we all share our knowledge and experiences :grin: