Nvidia 440xx driver works, but updating to 450 boots to a black screen

Hi guys, I tried to search so I’m sorry if this is a duplicate, but I was unable to solve this issue with information from other threads.

I’ve been running the 440 kernel and it works, but after updating to 450 I always boot to a black screen. I can’t even access TTY so I have to go boot from a usb to fix.

My System:
Operating System: Manjaro Linux
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.73.0
Qt Version: 5.15.0
Kernel Version: 5.8.6-1-MANJARO
OS Type: 64-bit
Processors: 6 × Intel® Core™ i5-8600K CPU @ 3.60GHz
Memory: 15.6 GiB of RAM
Graphics Processor: GeForce GTX 1060 6GB/PCIe/SSE2

Output of mhwd -li
Installed PCI configs:
video-nvidia-450xx 2019.10.25 false PCI
video-modesetting 2020.01.13 true PCI
video-linux 2018.05.04 true PCI

Things I’ve tried:

  • Changing kernel version
  • Installing the hybrid drivers instead (video-intel-nvidia-hybrid)
  • Changing xorg config
  • Removing other drivers and then installing

Sample install log, I didn’t see any errors:

Thanks guys, I’m loving manjaro a lot, I just need to update these drivers to get cuda working

Please run inxi -Fza somehow on the installed operating system, not in a live session. Have you tried completely removing the nvidia drivers and any (related) Xorg configuration?

Yes I’ve tried removing all the drivers and xorg configuration (as far as I know, its possible I missed something)

I’m currently running 440 driver on system and ran inxi -Fza. I don’t know how I could do it on the operating system with 450 because I can’t even open up a terminal without a black screen.

System:    Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
       parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=b07453a6-cfde-4f37-8e50-6f90b53b72b6 rw quiet apparmor=1 
       security=apparmor udev.log_priority=3 
       Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM Distro:     Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: Z370M MORTAR (MS-7B54) v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: 1.20 date: 03/08/2018 
CPU:       Topology: 6-Core model: Intel Core i5-8600K bits: 64 type: MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: D6 L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 43212 
           Speed: 3556 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 4292 2: 4287 3: 4251 4: 4297 5: 4290 6: 4284 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Micro-Star MSI driver: nvidia v: 440.100 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c03 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: nvidia display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3520x1080 s-dpi: 101 s-size: 885x272mm (34.8x10.7") s-diag: 926mm (36.5") 
           Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") diag: 547mm (21.5") 
           Monitor-2: DP-1 res: 1600x900 hz: 60 dpi: 94 size: 432x240mm (17.0x9.4") diag: 494mm (19.5") 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a2f0 
           Device-2: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f1 
           Sound Server: ALSA v: k5.8.6-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           chip ID: 8086:15b8 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB driver: r8188eu bus ID: 1-13:4 
           chip ID: 0bda:8179 serial: <filter> 
           IF: wlp0s20f0u13 state: down mac: <filter> 
           Device-3: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a bus ID: 2-3:2 chip ID: 0b95:1790 
           serial: <filter> 
           IF: enp0s20f0u3 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.07 TiB used: 1.06 TiB (51.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC26 scheme: GPT 
           ID-2: /dev/sdb model: SATA SSD size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
           serial: <filter> rev: 61.2 scheme: GPT 
           ID-3: /dev/sdc type: USB vendor: Lexar model: USB Flash Drive size: 14.92 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 1100 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: 43.95 GiB size: 43.00 GiB (97.86%) used: 23.86 GiB (55.5%) fs: ext4 dev: /dev/sdb5 
           ID-2: /home raw size: 735.62 GiB size: 723.08 GiB (98.29%) used: 35.76 GiB (4.9%) fs: ext4 dev: /dev/sda3 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 3.84 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb6 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A gpu: nvidia temp: 41 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 35% 
Info:      Processes: 247 Uptime: 50m Memory: 15.60 GiB used: 4.28 GiB (27.4%) Init: systemd v: 246 target: graphical.target 
           Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1351 pacman: 1337 lib: 394 flatpak: 11 snap: 3 Shell: Zsh v: 5.8 
           running in: yakuake inxi: 3.1.05

You have a

and that’s supported by the 440 series and the 450 series still has a few issues to iron out.

Which functionality are you seeking in the 450 series that the 440 series does not have?

If none: Keep the 440 series and try again in a few months. (And the way I’m running too)
get your debugging hat out and file a bug with nVidia.


I was trying to upgrade to 450 for Cuda. It’s not a big deal I guess, gaming works fine. I was just under the impression that using outdated drivers would cause problems

1 Like

Nope. :innocent: We live and we learn… :wink: