NVIDIA 396.* driver drops support for Fermi-based GPUs

drivers
nvidia

#1

NVIDIA 396.* driver drops support for Fermi-based GPUs

If you have a Fermi-based NVIDIA GPU you need to switch to the 390xx driver, for example:

# Bumblebee/Optimus:
sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

# Single card/PRIME:
sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To check whether you have a Fermi-based GPU read this page: https://nvidia.custhelp.com/app/answers/detail/a_id/4656/~/list-of-fermi-series-geforce-gpus or https://nouveau.freedesktop.org/wiki/CodeNames/#NVC0

Check the update thread for other details: [Stable Update] 2018-05-07 - Kernels, Mesa, Glibc, PHP, Nvidia, Plasma5, Firefox


"Failed to start load kernel modules" and no ethernet connection
Bricked my boot (I think)
[Stable Update] 2018-05-17 - GCC8, Gimp, KDE, Gnome, Deepin, Firefox
Updated on Testing and broke my system
NVIDIA Corporation GF108 [GeForce GT 420] - not supported
Kodi-Manjaro-nvidia nonfree
[Stable Update] 2018-07-22 - Kernels, KDE, Gnome, Deepin, Mesa, Browsers, PHP
#2

#3

#4

#5