Nvidia 390 driver does not provide video hardware acceleration

Hello, long time Mint user switching to Manjaro.
I grabbed the Cinnamon distribution.

I used mhwd to install the nvidia drivers

$ sudo mhwd -a pci nonfree 0300
> Using config 'video-nvidia-390xx' for device: 0000:26:00.0 (0300:10de:1b82) Display controller nVidia Corporation GP104 [GeForce GTX 1070 Ti]
> Installing video-nvidia-390xx...

Which was successful, but once I rebooted, I still get the warning notification saying: Your system is currently running without video hardware acceleration.

And true enough, running a game shows poor performance.

I have looked around but didn’t see anything about this on the forumns. I am a little concered that it chose to install 390xx while according to nvidia, a GeForce GTX 1070 Ti should be on 455.45.01

I would prefer the newer driver, but I can’t seem to get it to install.

$ sudo pacman -S nvidia
warning: linux59-nvidia-390xx-390.138-2 is up to date -- reinstalling
inxi -Fazy
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=7753964c-880c-4c69-a5b5-e043f829a51d rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Cinnamon 4.8.3 tk: GTK 3.24.24 dm: LightDM 1.30.0 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASRock model: B450 Pro4 serial: <filter> 
  UEFI [Legacy]: American Megatrends v: P1.30 date: 07/04/2018 

  Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ 
  family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D L2 cache: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 81484 
  Speed: 1377 MHz min/max: 1550/3400 MHz boost: enabled Core speeds (MHz): 
  1: 1377 2: 1380 3: 1508 4: 1535 5: 1373 6: 1373 7: 1491 8: 1414 9: 1377 
  10: 1378 11: 1378 12: 1381 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: ASUSTeK driver: nvidia 
  v: 390.138 alternate: nouveau,nvidia_drm bus ID: 26:00.0 chip ID: 10de:1b82 
  Display: x11 server: X.Org 1.20.10 driver: nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3440x1440 s-dpi: 96 s-size: 910x381mm (35.8x15.0") 
  s-diag: 987mm (38.8") 
  Monitor-1: DP-0 res: 3440x1440 hz: 60 dpi: 110 size: 797x334mm (31.4x13.1") 
  diag: 864mm (34") 
  OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.3.1 
  compat-v: 3.1 direct render: Yes 
  Device-1: NVIDIA GP104 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 26:00.1 chip ID: 10de:10f0 
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel 
  v: kernel bus ID: 28:00.3 chip ID: 1022:1457 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: d000 bus ID: 25:00.0 
  chip ID: 10ec:8168 
  IF: enp37s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
  bus ID: 3-4.2:5 chip ID: 0bda:8153 serial: <filter> 
  IF: enp39s0f3u4u2 state: down mac: <filter> 
  Local Storage: total: 1.36 TiB used: 14.57 GiB (1.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200NP 
  size: 447.13 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: SVN139B temp: 29.9 C 
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 4B6Q 
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Generic model: USB Flash 
  size: 15 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 0.00 
  ID-1: / raw size: 447.13 GiB size: 439.11 GiB (98.21%) 
  used: 14.57 GiB (3.3%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 47.5 C mobo: N/A gpu: nvidia temp: 47 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 24% 
  Processes: 349 Uptime: 2m wakeups: 1 Memory: 15.63 GiB 
  used: 2.52 GiB (16.1%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.0 Packages: pacman: 1311 lib: 424 flatpak: 0 Shell: Bash 
  v: 5.1.0 running in: gnome-terminal inxi: 3.2.01 

This doesn’t sound right,
remove it with sudo mhwd -r pci video-nvidia-390xx,
install latest rolling with sudo mhwd -i pci video-nvidia

Hi and welcome to manjaro. I was a long time mint user myself and am running the cinnamon edition. Manjaro is now running a rolling nvidia driver. The latest on the stable branch is 455 but because its a rolling release its listed as video-nvidia or video-hybrid-intel-nvidia-prime for laptops.

If you have video-nvidia available which you should just install that and you will always be on the latest drivers

Please reinstall the mhwd-db package, then run sudo mhwd -a pci nonfree 0300 again. That should install the latest available NVIDIA driver.

$ sudo mhwd -i pci video-nvidia
Error: config 'video-nvidia' does not exist!
$sudo pacman -S mhwd-db
warning: mhwd-db-0.6.5-7 is up to date -- reinstalling
$sudo mhwd -a pci nonfree 0300
> Using config 'video-nvidia' for device: 0000:26:00.0 (0300:10de:1b82) Display controller nVidia Corporation GP104 [GeForce GTX 1070 Ti]
> Installing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...

Packages (3) lib32-nvidia-utils-455.45.01-3  linux59-nvidia-455.45.01-6  nvidia-utils-455.45.01-2

Woo, that worked. Going to reboot, thanks pobrn.
EDIT: It works great now.

I don’t really understand why it fixed it, as pacman said mhwd-db is up to date.

Reinstalling mhwd-db restores certain files that have been corrupted (or something like that) by the latest(?) update.

A bit odd I would need that though, as it was right after a fresh install. Should I file a bug?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.