Nvidia 390.25 & XFCE login problem (workaround)

Since Nvidia 390.25 driver was introduced it is not possible anymore to login properly on a XFCE System with Geforce 1050…

The problem is the anti-tearing entry in the /etc/X11/mhwd.d/nvidia.conf like

Option "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"

which I added some time ago and worked nicely until 390.25 came along. I came across this thread in which a workaround is proposed that also works for me:


  1. If not yet installed, install nvidia-utils
  2. Get rid of the anti-tearing entries in /etc/X11/mhwd.d/nvidia.conf, either by commenting it out, or by using the nvidia-settings tool (X Server Display Configuration > Advanced; uncheck composition Pipeline checkboxes; Save to X configuration file)
  3. Add
    nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
    to the XFCE autostart

After a reboot the login works again and anti-tearing is enabled by the autostart entry.

1 Like

@ottomops Thanks a bunch - it works!

Removed the anti-tearing-entry from nvidia.conf and added “nvidia-settings --assign CurrentMetaMode” to the bash scripts I am using for my dual monitor setup. Now it works again, as intended.

This one is called at systemstart, or in case I want to deactivate the 2nd screen:
xrandr --output HDMI-0 --off && nvidia-settings --assign CurrentMetaMode="DVI-D-0: nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}"

And this one in case I want to activate the 2nd screen:
xrandr --output HDMI-0 --auto --right-of DVI-D-0 && nvidia-settings --assign CurrentMetaMode="DVI-D-0: nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}, HDMI-0: nvidia-auto-select +1920+0 {ForceFullCompositionPipeline=On}"

Now I can happily change from single to dual screen and back again, without having to “tty-switch” afterwards.

Thanks again for solving this problem ottomops!

1 Like

I am on a single screen setup, so this is a valuable extension of the workaround for dual screen setups. Thank you :slight_smile:

what is Xfce autostart ?



From the link you provided at nvidia forum they report 390.25-10.1 has fixed the issue.
What version do you have installed?

Plain 390.25 according to nvidia-smi.

and the solution …
new version 390.42

Interesting to see if these will be any better - both the devtalk and archlinux forum threads say they make little to no difference.

This is still not fixed as of 396.24. But for this autostart method to work, I had to add a delay in the command.

sh -c "sleep 10 && nvidia-settings --assign CurrentMetaMode=\"nvidia-auto-select +0+0 { ForceCompositionPipeline = On }\""


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.