Nvaapi (video acceleration) on google chrome stable not working

Hello,

this is my first post, so I will try to do my best to explain my problem.
I recently migrated from Kubuntu to Manjaro, everything works.
The only thing I am not managing to get is video hardware acceleration on google chrome.
I have a NVIDA GTX 1050 Ti and drivers 495.46.
When I start Google Chrome with:

google-chrome-stable --use-gl=desktop --enable-features=VaapiVideoDecoder
I get

andrea@andrea-tobefilledbyoem:~$ google-chrome-stable --use-gl=desktop --enable-features=VaapiVideoDecoder
[9722:9722:0125/115701.166939:ERROR:vaapi_wrapper.cc(1119)] vaQuerySurfaceAttributes failed, VA error: invalid parameter
[9722:9722:0125/115701.167039:ERROR:vaapi_wrapper.cc(1066)] FillProfileInfo_Locked failed for va_profile VAProfileH264Main and entrypoint VAEntrypointVLD
[9722:9722:0125/115701.167083:ERROR:vaapi_wrapper.cc(1119)] vaQuerySurfaceAttributes failed, VA error: invalid parameter
[9722:9722:0125/115701.167151:ERROR:vaapi_wrapper.cc(1066)] FillProfileInfo_Locked failed for va_profile VAProfileH264High and entrypoint VAEntrypointVLD
[9722:9722:0125/115701.171009:ERROR:gpu_init.cc(457)] Passthrough is not supported, GL is desktop, ANGLE is 
[9680:9747:0125/115703.866844:ERROR:chrome_browser_main_extra_parts_metrics.cc(227)] START: ReportBluetoothAvailability(). If you don't see the END: message, this is crbug.com/1216328.
[9680:9747:0125/115703.866855:ERROR:chrome_browser_main_extra_parts_metrics.cc(230)] END: ReportBluetoothAvailability()

Output of vainfo

vainfo: VA-API version: 1.13 (libva 2.13.0)
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API - 0.7.4
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG4Simple            : VAEntrypointVLD
      VAProfileMPEG4AdvancedSimple    : VAEntrypointVLD
      <unknown profile>               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD

I cannot understand what is .
Anyway, no accelerated videos. Can someone help me?

I don’t think this is the right approach. For chrome you have to create ~/.config/chrome-flags.conf and populate it with the following:

--ignore-gpu-blocklist
--enable-gpu-rasterization
--enable-zero-copy
--enable-features=VaapiVideoDecoder

X11:

--use-gl=desktop

Thank you for your answer.
I already tried and still no hardware acceleration on youtube.

962:16962:0125/122815.176763:ERROR:vaapi_wrapper.cc(1119)] vaQuerySurfaceAttributes failed, VA error: invalid parameter
[16962:16962:0125/122815.176885:ERROR:vaapi_wrapper.cc(1066)] FillProfileInfo_Locked failed for va_profile VAProfileH264Main and entrypoint VAEntrypointVLD
[16962:16962:0125/122815.176951:ERROR:vaapi_wrapper.cc(1119)] vaQuerySurfaceAttributes failed, VA error: invalid parameter
[16962:16962:0125/122815.177014:ERROR:vaapi_wrapper.cc(1066)] FillProfileInfo_Locked failed for va_profile VAProfileH264High and entrypoint VAEntrypointVLD
[16962:16962:0125/122815.180161:ERROR:gpu_init.cc(457)] Passthrough is not supported, GL is desktop, ANGLE is 
[16919:16944:0125/122817.713745:ERROR:chrome_browser_main_extra_parts_metrics.cc(227)] START: ReportBluetoothAvailability(). If you don't see the END: message, this is crbug.com/1216328.
[16919:16944:0125/122817.713761:ERROR:chrome_browser_main_extra_parts_metrics.cc(230)] END: ReportBluetoothAvailability()

@ishaanbhimwal Finally got it,

the trick is to install libva-vdpau-driver-chromium
standard libva-vdpau-driver (installed with manjaro-vaapi) does not work!

output of vainfo now is

vainfo: VA-API version: 1.13 (libva 2.13.0)
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API - 0.7.4
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG4Simple            : VAEntrypointVLD
      VAProfileMPEG4AdvancedSimple    : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD

I think this should be installed by default, otherwise impossible to figure out.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.