Numpad behaves unusually at LUKS boot screen

Hi, doens’t seem a perfect match but likely the best board for my inquiry.

I’ve recently reinstalled Manjaro XFCE, with a LUKS encrypted home partition.
At the boot screen where you enter the LUKS password during startup, I’ve noticed that pressing a number on the numpad enters about 4 characters (seen by the number of obfuscated *'s), but a number from the homerow enters only one character as expected.

Has anyone got some suggestions on why the numpad is behaving so weirdly during boot, or how to fix it?

Did you try pressing NumLock first? The four characters you mention sound like they might be the up/down keycodes.

I feel silly that I didn’t try that. Yes, after pressing numlock the numpad can be used like normal, thanks! I’m sure I had numpad at boot enabled in bios…

In my experience, I’ve found that some OSes are able to change that setting and need to be configured within the OS itself. However, I have no idea how to do that with LUKS and/or XFCE.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.