Number of windows opened (Panel on XFCE)

Hi All,

Before my question, let me show you my specs:

My specs
System:    Host: gemini Kernel: 5.1.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: Xfce 4.13.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 7472 v: N/A serial: <filter> 
           Mobo: Dell model: 082HPJ v: A03 serial: <filter> UEFI: Dell v: 1.1.9 date: 01/10/2019 
Battery:   ID-1: BAT0 charge: 39.9 Wh condition: 39.9/42.0 Wh (95%) model: SMP DELL Y3F7Y6B status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A 
           L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
           Speed: 822 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 822 2: 852 3: 1030 4: 1227 5: 1034 6: 1757 
           7: 1056 8: 892 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.1.1 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.1.15-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8168 
           v: 8.047.01-NAPI port: d000 bus ID: 02:00.0 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci 
           v: kernel port: d000 bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-7:4 
Drives:    Local Storage: total: 1.03 TiB used: 440.41 GiB (41.9%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-75Z10T2 size: 931.51 GiB 
           ID-2: /dev/sdb vendor: A-Data model: SU810NS38 SATA 128 GB size: 119.24 GiB 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 898.75 GiB used: 404.86 GiB (45.0%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 17.12 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 42.0 C mobo: 29.0 C sodimm: 33.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 281 Uptime: 1h 47m Memory: 15.56 GiB used: 4.42 GiB (28.4%) Init: systemd Compilers: 
           gcc: 9.1.0 Shell: bash v: 5.0.7 inxi: 3.0.34

Now, my question:
I am using XFCE and after the 03/07/19 update I noticed that my panel now shows a little black circle when I have more than one window of the same program running (e.g., Firefox). After changing the appearance of my desktop with dark themes I noticed that the little back circle in fact shows a number inside with the amount of windows open. When I use light themes the circle has dark grey background and the number inside is black! When I use dark themes (any one works) the circle has white background and black number.

Does anybody know how to change those colours, so I can see the numbers within the circle when using Light themes?

Cheers.

EDIT: Solved in the 2019-07-09 update.

It is your theme/icons that's faulty. Matcha-dark-azul and my custom theme are working fine. Tried with papirus-dark-icons and korla-icons. I see a white ball with black number even with dark theme.
Are your qt5ct-settings correct ?

btw: - I don't use kvantum -

Hi @banjo.

Thank you for your interest in solving my problem.

Yes, I also can see the number in the circle with dark themes, but my problem is with light themes. If you want to try the same I am using now: currently I have Adwaita as the chosen style and Papirus-Light-Maia as icons set.

My qt5ct-settings are completely different from what I am seeing right now. I am wondering now which programs are affected by those settings. Everything I am seeing is following what is set by xfce4-appearance-settings.

I will research more the influence of qt5ct on my desktop appearance.

Thank you for your help.

You are right, Adwaita is faulty. I misread your first post. thought you had problems with dark themes.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by