Noto Sans Mono font not usable after noto-fonts update

unstable

#1

After the latest noto-fonts upgrade today

[2018-04-06] [ALPM] upgraded noto-fonts (20171025-2 -> 20180322-1)

I can no longer select Noto Sans Mono as my default KDE Fixed Width Font in System Settings -> Fonts, it doesn’t appear.

Cannot select it either in Konsole as my default profile font.

It is on the system …

$ pkgfile -l noto-fonts | grep Mono
extra/noto-fonts        /usr/share/fonts/noto/NotoSansMono-Black.ttf
extra/noto-fonts        /usr/share/fonts/noto/NotoSansMono-Bold.ttf
extra/noto-fonts        /usr/share/fonts/noto/NotoSansMono-Light.ttf
extra/noto-fonts        /usr/share/fonts/noto/NotoSansMono-Medium.ttf
extra/noto-fonts        /usr/share/fonts/noto/NotoSansMono-Regular.ttf
extra/noto-fonts        /usr/share/fonts/noto/NotoSansMono-Thin.ttf

KDE recognizes it within System Settings -> Fonts -> Font Management …

This has occurred on all my systems and I don’t know why … same for other KDE users?

Any idea why a font displays in Plasma Font Management but is omitted from system and app font selection dialog boxes?

Not a huge deal, changed to Droid Sans Mono, but it is bugging me why an installed font I like now cannot be used.


#2

Does Noto Mono appear like this ?
image
I think it lost the Sans :sunglasses:
but since i use Hack as fixed width and in terminal, i didn’t noticed nor i can’t remember how was previously, so maybe i’m off topic here …


#3

The only options I get are in the first capture image above.

I wonder if KDE is simply not picking Noto Sans Mono up as monospaced font, thus filtering it from the available options?

It is available in the Kate font settings dialog.


#4

just noticed that too.
and now my konsole fonts are messed without doing any config changes… :thinking:


#5

I got the exact same issue. :frowning:


#6

it seems that Noto Mono as been removed or replaced by Noto Sans Mono familly.
why it does not get selectable I don’t know… :thinking:


#7

Close, font spacing config issue upstream with noto-fonts, KDE correctly filtering it out, waiting for upstream patch.


[Testing Update] 2018-04-08 - LibreOffice, Calamares, Inxi, Illyria Alpha 2
[Testing Update] 2018-04-11 - ZFS, Firefox, Gnome v3.28.1, Haskell, Python
[Testing Update] 2018-04-10 - Systemd, Gnome v3.28.1, Python, Perl, Haskell
[Testing Update] 2018-04-09 - Kernels, Gnome v3.28.1, Illyria KDE, Haskell, Python
[Stable Update x32] 2018-04-08 - Kernels, ICU and rebuilds, OpenSSH, OpenSSL, OpenJDK 10
[Testing Update] 2018-04-07 - Kernel v4.17-rc0, Python, QCA
[Stable Update] 2018-04-28 - Kernels, Cinnamon, Browsers, Mesa, KDE Apps, KDE Framework, Virtualbox
Noto-fonts Testing Update
[Testing Update] 2018-04-06 - Linux v4.17, Browsers, Mesa, LibreOffice, Upstream fixes
[Testing Update x32] 2018-03-30 to 2018-04-06 - icu, kernels, OpenSSH, OpenSSL
[Testing Update] 2018-04-13 - Kernels, Gnome v3.28.1, Deepin, Haskell, Python
[Stable Update] 2018-04-14 - Kernels, Gnome v3.28.1, Libreoffice, Browsers, Mesa, Deepin, Mate
[Testing Update] 2018-04-12 - ALSA, Gnome v3.28.1, Deepin, Python
#8

How do you come to that conclusion? I don’t see any fixes yet.


#9

You are right, Script-Monospace is a github issue label, I misread.


#10

This topic was automatically closed after 90 days. New replies are no longer allowed.