Notification area tooltip issue

Hello,

I didn’t find a similar topic and I was unsure where to start it, so I’m doing it in the newbie corner.

I’ve noticed this issue after the last update. I’ve updated 205 packages at once, so I can’t put my finger if anyone might be responsible (I would also appreciate an advice if this is a bad practice).

So, it seems tooltips for the notification area items (power manager, network manager etc.) are always shown bellow the mouse pointer, while tooltips for other panel items are normally shown accordingly to their position on the screen. This makes them unusable for me since I’m a recent Windows refugee, and I prefer my panel at the bottom of the screen.

up1

You can clearly see a couple of pixels from the tooltip, most of which is out of the screen bounds.

Same issue here. Changing appearance theme or icon theme has no effect.

I noticed that the tooltips appear when reducing the row size of the panel, or when increasing the maximum size of the icons in the Notification Area (for me setting the maximum icon size to something more than 25 pixels when the panel row size is 30 pixels fixes the issue).

1 Like

If I move the panel at the top of the screen, the tooltips are clearly visible.

u2

I suspect a theme problem… my tool tips work fine on the bottom. Try using greybird as your windows theme (not the windows decoration/ border). I use greybird and as I noted it works. At least you can eliminate the theme as a problem if you are still borked.

es tema de tamaño de iconos:
modify the size of the icons in the notification area

image

ahora funciona bien

I tried changing between various themes, including Greybird. The tooltips are still not displayed properly with any of them. It doesn’t look like a theme issue to me.

There is definitely a panel row size / notification area icon size ratio for which the tootlips are properly shown, as @bill_t and @manjaromanyarolibre suggested, but this makes either the panel too small or the icons too large and the whole thing ridiculously disproportionate.

I noticed another way the tooltips are correctly shown, if I check the “Don’t reserve space on borders” option in the Panel settings. However, this makes the panel hide the lowest part of a maximized active window, usually hiding the status bar or other valuable UI segment.

I guess I’m out of ideas then…

unstable, automatic… length on/off. Work


59/5000
varies the pixel size … 27 or other you will see that it is solved

see what changes to the network icon … with 22pix fails message

have a nice day

Cita
There is definitely a panel row size / notification area icon size ratio for which the tootlips are properly shown, as @bill_t and @manjaromanyarolibre suggested, but this makes either the panel too small or the icons too large and the whole thing ridiculously disproportionate.

PD: that’s why the checkbox to show activated frame …

image

Since there is different behavior, this should be a bug with the widget.
Have you checked xfce bugtracker?

1 Like

I downgraded GTK3 to the previous installed version (from 3.24.1+8+g220f77d8c1-1 to version 3.22.30-1) and tooltips seem to be working properly.
Screenshot_2018-10-16_01-09-53

It’s obviously not a solution, but I would rather not upgrade until this issue is solved.

Why not use the default gtk3-classic in XFCE? Was made default and definitely works better for XFCE :slight_smile:

1 Like

problem persists with

gtk3-classic

downgraded gtk3 to version 3.22 and it works as it should, gtk3 bug???

The problem is still there with the latest update. I’m still using gtk3 3.22.30.

Upgrading the kernel doesn’t help either.

I was still using 4.14 and thought maybe this could be a kernel related issue because I did have some trouble setting up virtual machines with the old kernel. But after installing 4.19 and upgrading gtk3 the glitch was still there.

I’m back at gtk3 3.22.30 now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by