Not sure if NVIDIA drivers are properly installed

Hello,

I made the jump from Windows to Manjaro maybe one month ago on my laptop and I still have some slight issues that I need to fix.

Problem I originally set out to resolve
I noticed that I was experiencing some screen tearing issues from time to time and I’ve read that the nvidia configuration on linux is prone to cause this problem.

New problem discovered
While trying to apply some fixes found online, I discovered that I am unable to perform some of the most common and basic steps needed to reduce screen tearing. For instance, the command sudo nvidia-settings yields:

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

That sounded to me like I wasn’t using the NVIDIA graphic card but rather the integrated intel gpu instead.

Googling this error brought me to this thread. I did the same thing as the OP in that thread. The command inix -Fxz proved that the graphic card is properly detected but that maybe drivers weren’t properly installed.

  Host: Neph Kernel: 4.14.67-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.0 Desktop: N/A Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: N551JK v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: N551JK v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: N551JK.203 date: 10/06/2014 
Battery:
  ID-1: BAT0 charge: 32.4 Wh condition: 32.4/56.2 Wh (58%) 
  model: ASUSTeK N551-52 status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i7-4710HQ bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 39923 
  Speed: 864 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 798 2: 799 
  3: 798 4: 798 5: 798 6: 799 7: 799 8: 798 
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915 
  v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA GM107M [GeForce GTX 850M] driver: N/A bus ID: 01:00.0 
  Display: x11 server: N/A driver: intel unloaded: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.1.7 
  direct render: Yes 
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.14.67-1-MANJARO 
Network:
  Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel bus ID: 04:00 
  IF: wlp4s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 05:00.1 
  IF: enp5s0f1 state: down mac: <filter> 
Drives:
  Local Storage: total: 922.21 GiB used: 30.65 GiB (3.3%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS721075A9E630 
  size: 698.64 GiB 
  ID-2: /dev/sdb vendor: Mushkin model: MKNSSDCR240GB-G2 size: 223.57 GiB 
Partition:
  ID-1: / size: 117.63 GiB used: 10.09 GiB (8.6%) fs: ext4 dev: /dev/sdb4 
  ID-2: /home size: 74.02 GiB used: 14.85 GiB (20.1%) fs: ext4 
  dev: /dev/sdb5 
  ID-3: /var size: 11.72 GiB used: 3.48 GiB (29.7%) fs: btrfs dev: /dev/sdb3 
  ID-4: swap-1 size: 15.62 GiB used: 2.23 GiB (14.3%) fs: swap 
  dev: /dev/sdb2 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 1900 
Info:
  Processes: 256 Uptime: 9h 24m Memory: 15.55 GiB used: 1.97 GiB (12.7%) 
  Init: systemd Compilers: gcc: 8.2.0 Shell: bash v: 4.4.23 inxi: 3.0.21 

The command mhwd -li yielded:

Name Version Freedriver Type
video-hybrid-intel-nvidia-bumblebee 2018.08.09 false PCI

An answer in the thread said that to get to the nvidia-settings, the command optirun -b none nvidia-settings -c :8 had to be run. When I did, I could run the nvidia-settings configuration windows, but some elements were a bit screwed up. For instance, it seems like my laptop screen isn’t discovered by the graphic card.

I then refered to the wiki graphic card driver installation page to see whether I did everything right but after running a few commands suggested in the page, I still wasn’t sure what my problem was and how to fix it.

For the sake of info, the command mhwd -li -d --pci yields:

   NAME:	network-r8168
   ATTACHED:	PCI
   VERSION:	2016.04.20
   INFO:	RealTek RTL-8168 Gigabit Ethernet driver
   PRIORITY:	0
   FREEDRIVER:	true
   DEPENDS:	-
   CONFLICTS:	-
   CLASSIDS:	0200 
   VENDORIDS:	1186 10ec 

   NAME:	video-hybrid-intel-nvidia-bumblebee
   ATTACHED:	PCI
   VERSION:	2018.08.09
   INFO:	Hybrid bumblebee solution for NVIDIA Optimus Technology - Closed source NVIDIA driver & open source intel driver.
   PRIORITY:	8
   FREEDRIVER:	false
   DEPENDS:	-
   CONFLICTS:	video-intel video-nvidia video-nvidia-304xx video-nvidia-340xx video-nvidia-390xx video-hybrid-intel-nvidia-390xx-bumblebee video-hybrid-intel-nouveau-bumblebee 
   CLASSIDS:	0300 0302 0300 
   VENDORIDS:	10de 8086 

mhwd-gpu --check outputs:

xorg configuration symlink valid...

and glxinfo | grep OpenGL prints this:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.1.7
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.1.7
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.1.7
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

My question
I am currently very confused as to what is my graphics card situation:

  • Are the drivers for the NVIDIA card properly installed?
  • Am I right to believe that the NVIDIA card doesn’t detect my monitor?
  • Are the drivers installed correct for this version of NVIDIA card?
  • Does the screen tearing actually happens because of the NVIDIA card or because of the integrated intel card?
  • How can I tell if the laptop properly performs the switch between the two cards when necessary?

I am sure I made a stupid newbie mistake somewhere while installing or configuring stuff. If someone would be kind enough to help me figure this thing out, it would be really appreciated!

yes drivers are installed correctly (else the optirun command wouldn’t work)
use xrandr to manage monitor settings
screen tearing: dont know, sorry
to test switching:
glxinfo | grep renderer (should show OpenGL rendere string: mesa something)

primusrun glxinfo | grep renderer (should show OpenGL rendere string: nvidia something)

Hello Neph,
Just a small typo observation from me in case anyone tries to copy and paste your sudo nividia-settings command … it should read of course nvidia-settings :grin:

The randomness may mean they appear when one of the two GPUs is active, probably nvidia.
There are some advice at Archwiki about video tearing. Enable vsync on nvidia.
You may need to add it to Xorg conf, I am not sure. First backup your current configurations at /etc/X11/* to be safe, because both nvidia-settings GUI and mhwd do changes on some files.

try the classic tearing fix: add a command in your session manager with the following:

nvidia-settings --assign CurrentMetaMode=“nvidia-1360x768_60.00 +0+0 { ForceFullCompositionPipeline = On }”

you need to replace the bold text with your settings (you can use xrandr to check this or nvidia-settings.

1 Like

Wow, thank you all for those answers! It’s super appreciated. I’ll try/investigate every answer and report if I hit roadblocks. I’ll also try to document whatever worked for my case in the interest of future users that may get the same problems.

Corrected it, thanks!

[Disclaimer: I am not sure how the following advice can apply to Bumblebee drivers since nvidia-settings cannot be run directly and Intel drivers are used on the desktop from what I’m reading. Someone who actually runs hybrid drivers should know better on this matter.]

It is not necessary to give a resolution to this command. Unless it’s different for hybrid drivers. And some people report using ForceFullCompositionPipeline fails. So here is an alternative:

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"

This is the classic method for a permanent solution:
https://wiki.manjaro.org/index.php?title=Simple_fix_for_screen_tearing_-_nVidia

And if you have login problems:

I just want to add that because of bumblebee, that Option setting for nvidia needs to be in the bumblebee config.

/etc/bumblebee/xorg.conf.nvidia

IIRC

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.