Not keeping display layout settings correctly

I recently cloned my drive to a new one, and everything except this works perfectly. At first it seems fine, I have my laptop display as the primary, and an external display extended up. Everything works fine, even if I disconnect the display and reconnect it, it remembers how it should be. However, after being asleep for a while, opening it up gives me just the external display as the primary. It’s set to sleep when I close the lid, and if it’s not for very long it wakes up like it should, but after a while it does this. I tried moving the ~/.local/share/kscreen directory and setting it up again, but I’m having the same issue still. I’m not really sure where to go from here.

That has become a quite annoying side of Plasma lately. It started a while ago - not quite sure when or why.

I haven’t been able to make it work - so I have decided to wait for upstream KDE to fix it.

On idea it to write a script invoking xrandr and execute it through a systemd service.