Not Getting any graphical desktop after booting a new installation of kde

I’m having some weird issue using the iso for the community version of LXQT Manjaro. i can use the default greeter with no problems, and login but after that i get only the desktop background, but can’t switch to my main display which is a desktop screen with Ctrl + Alt+ P, i’ve noticed some hotkeys do work like ctrl + alt + l, but other than that i can only use the tty. i’m able to right click the screen and i get a menu but nothing that i click there works. i’ve already tried updating the desktop enviroment on tty2 and reinstalling it. also tried changing from lightdm to slim correctly disabling the previous systemd service and enabling the one i intend to use but… neither of these have helped me on getting an actual working desktop. just that default background.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

There is two choices of lxqt - both got rebuilt on 2022-05-09

The default lxqt based on openbox and a version based on kwin

To which one are you referring?

I am not familiar with the shortcut you mention

none of the current lxqt editons uses ligtdm - they both uses sddm

EDIT: I checked the latest versions in VirtualBox VMs (1 vCPU - 10GvHD,)

I found an issue with the sddm greeter - only on the lxqt (openbox version) - it is caused by some deprecated code and I quite likely forgot to update the ISO profile - so it loads the default greeter and presents an error message. This does - however - not cause malfunction later for the desktop.

I will check the profile and fix the bug - then request a rebuild of the ISO.

Until we get this fixed I suggest you download the lxqt-kwin ISO - as it works as expected.




I have now fixed the greeter themes for lxqt and openbox - I am in the process of building ISO to verify the fix.

@oberon - when you find the time - will you please initiate a runner rebuilding lxqt and openbox to accomodate these fixes?


Testbuild screenshots