Not every iso works after dd to usb. How to solve this problem?

DD works with Manjaro and pretty much any other distro I tried.
I usually do:

dd bs=4M if=path/to/xxx.iso of=/dev/sdx conv=fsync oflag=direct status=progress

But from time to time I have iso files that do not boot after DD.
For example, I tried with VMware vSphere. It didn’t boot.

As a solution, I can use rufus. It can handle “problematic” isos.

I’m not sure, but those are iso hybrid or something.

Why would you boot a VM from a real USB drive?
(that is what I understood you tried to do)

dd works as well as cp works as well as cat works as well as … a few other options

or install Ventoy to your USB drive - and then simply copy whatever .iso to it
and keep using the free space on the USB for other files
instead of having it hogged by one single iso and being unusable otherwise

1 Like

I wouldn’t.
I have VMware vSphere Hypervisor 7.0 iso. I wanted to try level 1 hypervisor.
It has bootable iso but it didn’t work with DD nor CAT.

I’ll try Ventoy

ahh, sorry! - I just went by the VM reference
and even after quick google I didn’t realize what VMware vSphere was.

nonetheless - if it is a bootable .iso
any of the options should work

I never used anything else than dd or cat (to the device - not to a partition on it)
… or Ventoy, since I was aware of it’s existence

1 Like

So you were lucky :slight_smile:
It wasn’t my first ISO that didn’t work.
And as I said. DD works everytime for Manjaro, Arch, Ubuntu or any other distro. I believe that it didn’t work for Windows ISO.
And for vSphere too.

Ventoy looks nice. Especially for USB drive with 64GB free space :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.