Not booting after installation. grub problems?

That’s confusing then as yesterday morning I had a working system:

uefi (legacy first) + mbr partitions + netrunner (based on manjaro) + grub.

As in, I didn’t change the partitions that were already there (although I think the installer deleted and remade the partition I installed manjaro to - might that have caused an issue?).

And don’t you need an efi partition to boot from uefi with gpt partitioned disks? I don’t have one set up on this disk.

You’ve installed in uefi to a msdos partitioned device.
See here and though installer allows it, it is not good.
Suggest redo everything, and if it is going to be a new system like here, then follow the steps outlined.

If it is not going to be a new system but have existing OS’s, find out what these OS’s are (uefi or bios-legacy - most likely bios-legacy) and proceed the same (meaning reinstall Manjaro in bios-legacy to msdos).

Thanks for those pointers. I gave them a try with no luck:

The usb installer boot screen for 17.0.1 seems to be different from your screenshot, so I can’t go off those, but /sys/firmware/efi is absent (and so is in BIOS mode) once the installer boots up.

again, keeping my existing partitions (1 windows restore, 1 windows 7, 1 swap, 1 data and 1 system that is being replaced by manjaro), the installation seems to go well (and getting at grub via a usb disk, I can boot into it), but trying to boot normally just fails.

It doesn’t even seem to get as far as grub.

I’ll see what else I can try…

If your installation is completed (with message : installation completed) but cannot boot, come back here and we’ll fix it.
Note: the install media start up menu (the screen shots):
if it is just black background and white text, it is booted in uefi.
If start menu has green colour (anywhere), it is booted up in bios-legacy.
So make sure your start menu has green colour to boot up in bios-legacy.

1 Like

Hi gohlip

Yes, the installer claims to have completed successfully.

The usb installer boot menu was green, so that was booting in bios mode.
edit - mostly green - it looks like this We need your help

To step back and try something else, I installed linux mint - again the installer claimed complete successfully and again the system didn’t boot.

So I can only assume that the manjao installer did something fundamental (seeing I had a working netrunner installation a couple of days ago and this issue arose from trying to replace that with manajaro).

I’m a bit out of touch with some of the more fundamental problems with installations - I haven’t had any issues in years aside from with the occasional graphics driver.

Thinking about the “operating system not found” message I mentioned in my first post, at this point would replacing the mbr using syslinux be a good next step?

Thanks for your help.

Try this first.
If this does not help, it may mean something else.
Let us know all error messages if this does not work.
Info from

sudo parted -l
sudo fdisk -l

will help , as a start.

Just checked a moment ago (to be sure)
In the screen shots for the new grub iso (v 17.0.1) install media.
Check the line above the last line "Reboot!"
If UEFI booted , the line will show "Detect EFI bootloaders"
If bios-legacy booted, the line will show “Installed BIOS-System on hd1,msdosxx”

I’ll post screen shots later.

Here’s how it look like booted in bios-legacy

And here’s booted in UEFI

Note the difference above the last Reboot! line.
“Installed BIOS-System on hd1,msdosxx” in bios-legacy boot
“Detect EFI bootloaders” in UEFI boot.

And if install isofile is booted by a grub2 entry as outlined here,,
If booted from a uefi grub, install media will be booted uefi.
If from a bios-legacy grub, install media will be booted in bios-legacy.


As already established, I believe this is some kind of UEFI<->Legacy bootloader installation mishap.

As a first step, indeed list your partition scheme.

I know for a fact: you can not install an UEFI bootloader if you have booted in a Legacy mode. I.e.; if you have booted from an USB live Linux / installation media in legacy mode, it can only install a boot loader in Legacy mode.

My guess is this: You have previously installed grub in UEFI mode (from a UEFI enabled installation media), perhaps on an MBR partition scheme. Now when you boot from Legacy USB media, the bootloader is installed in Legacy mode, but does not overwrite all of the existing UEFI bootloader data. On the next bootup, the laptop BIOS tries to boot vai UEFI mode -> failure.

But this is a lot of guesswork. Print the partition scheme here.

Possible remedies:

  1. Change your laptop BIOS into Legacy mode only
  2. Download any Live Linux installation media image, that is known to be UEFI only, and boot from it. Use it to re-install GRUB. Check with efibootmgr that everything is in order.

Hi Everyone.

I’m definiately booting into bios mode judging by the boot screens.

Here is the output of the commands you asked for. I’m currently on the live medium, so I limited fdisk to sda:

[manjaro@manjaro ~]$ test -d /sys/firmware/efi && echo UEFI || echo BIOS
[manjaro@manjaro ~]$ sudo parted -l
Model: ATA HITACHI HTS54505 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  1574MB  1573MB  primary   ntfs
 2      1574MB  51.6GB  50.0GB  primary   ntfs
 3      51.6GB  500GB   449GB   extended
 5      51.6GB  53.6GB  2001MB  logical   linux-swap(v1)
 7      53.6GB  104GB   50.0GB  logical   ext4            boot
 6      104GB   500GB   397GB   logical   ext4

Model: Lexar USB Flash Drive (scsi)
Disk /dev/sdb: 15.7GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  2130MB  2130MB  primary               boot
 2      2130MB  2134MB  4194kB  primary               esp

[manjaro@manjaro ~]$ sudo fdisk -l /dev/sda
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xf0a8fe4a

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1            2048   3074047   3072000   1.5G  7 HPFS/NTFS/exFAT
/dev/sda2         3074048 100730297  97656250  46.6G  7 HPFS/NTFS/exFAT
/dev/sda3       100730878 976771071 876040194 417.7G  5 Extended
/dev/sda5       100730880 104638463   3907584   1.9G 82 Linux swap / Solaris
/dev/sda6       202297344 976771071 774473728 369.3G 83 Linux
/dev/sda7  *    104640512 202295295  97654784  46.6G 83 Linux

Partition 3 does not start on physical sector boundary.
Partition table entries are not in disk order.

Note that “partition table entries not in disk order” happened after the manjaro installation - it must have deleted the old sda6, so the old sda7 moved up one, then created a new sda 7.

So judging by the messages above it looks like my netrunner installation might have been at fault - managing to boot when it shouldn’t have and this installation has ran into that old problem?

Where did you install grub, MBR? You may want to try an update of grub menus by issuing the command
$ sudo update-grub
While you are change rooted into your installed Manjaro.

So actually see this

OK, now we know that you have a MBR (=dos) partition table.

Does your laptop have a BIOS menu? If so, can you list / see your EFI boot entries (if any have been stored) there? If you can, and find one for your old OS, try deleting it.

I’d also try booting from an USB stick in UEFI mode and run ‘efibootmgr’.

If my theory (I wrote previously) is correct, i.e. your laptop is trying to boot according an (out-of-date) EFI boot entry, re-installing grub in Legacy mode will achieve nothing (but it is still worth a shot, though).

anika200 - yes, I tried that without success, but I can always have another go.

Wild_Penguin - yep mbr partition table. I do have a BIOS menu, but nothing allows me to list efi boot entries. I tried setting the options to UEFI boot only to boot in the installation usb like that, but that fails (sorry no handy camera):

welcome to grub ...........

my excellent ascii representation there shows the screen I get when I try to boot the usb - a black screen with “welcome to grub” in inverted text at the top left. A couple of lines down there is a white rectangle. Not entirely white - it almost looks like the whole screen had been shrunk down to one character. I can’t get it to respond to grub commands though.

The usb boots into uefi mode on another laptop I have handy.

I’ve been through a couple of rounds of re-installing (legacy) grub with no success both via chroot and booting into the installation via the grub command line on the usb installer. But I can always try that again.

I’ll have a look around for a UEFI only linux installer.

Thanks for everyone’s help.


Which media/Linux image are you specifically trying to boot from USB? Manjaro installation media is UEFI enabled, IIRC. Also Arch Linux ISO image seems to be UEFI enabled. IIRC if you try to boot a Legacy device in UEFI mode, you get the behavior you describe (I’ve seen it sometime myself).

It is also possible your laptop has a buggy UEFI BIOS (just a guess).

Also, one important point (that hasn’t been mentioned yet I think): Does your BIOS have secure boot options? Make sure it is disabled.

Also look at Manjaro UEFI installation and Arch UEFI bootable USB flash installation guides.

What I’d try in a Live Linux environment, is to run efibootmgr. Does it list any entries or spit an error message? If the latter, try to install efivars module (sudo modprobe efivars) and run efibootmgr again.

If you can not list the entries, it means you 1) do not have UEFI boot setup (at all) or 2) the BIOS does not expose the information in case you have not booted in UEFI mode (and you have not booted in UEFI mode), but you may still have UEFI entries stored somewhere in BIOS.

If you can list UEFI entries, you can 1) try to install GRUB again in UEFI mode or 2) remove the entries (efibootmgr -B -b XXXX), and re-install GRUB in Legacy mode (reboot in Legacy mode first, to make sure the installation is done correctly this time).

Oh, one more important thing:

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  1574MB  1573MB  primary   ntfs
 2      1574MB  51.6GB  50.0GB  primary   ntfs
 3      51.6GB  500GB   449GB   extended
 5      51.6GB  53.6GB  2001MB  logical   linux-swap(v1)
 7      53.6GB  104GB   50.0GB  logical   ext4            boot
 6      104GB   500GB   397GB   logical   ext4

What are the contents of partitions 1 and 2? I.e. mount them and post the ls output of them here.
(this way we can confirm if you have ever had an EFI boot installation or not).

EDIT: Actually partition 2 does not matter, it seems it is your Windows partition (?). What I’m more specifically interested in, where are your grub config files, and if there is an “efi” folder on that partition. It could be partition 1, or partition 7.

Partial progress. Even though the grub menu was sort of screwed up, I managed to get the mangaro kde 17.0.1 install usb to boot.

sda1 is a windows 7 system restore partition
sda2 is windows 7

[manjaro@manjaro ~]$ dmesg | grep "EFI v"
[    0.000000] efi: EFI v2.00 by Phoenix Technologies Ltd.
[manjaro@manjaro ~]$ test -d /sys/firmware/efi && echo UEFI || echo BIOS
[manjaro@manjaro ~]$ sudo efibootmgr 
BootCurrent: 0008
Timeout: 0 seconds
BootOrder: 0005,0006,0007,0008,0009
Boot0000  Setup
Boot0001  Boot Menu
Boot0002  Diagnostic Splash Screen
Boot0003  Rescue and Recovery
Boot0004  Startup Interrupt Menu
Boot0005* USB CD
Boot0006* USB FDD
Boot0007* ATA HDD0
Boot0008* USB HDD
Boot0009* PCI LAN

So to install grub I need to specify an efi partition? and the next step is to ideftify if I have one of those?

[manjaro@manjaro ~]$ sudo mount /dev/sda1 /mnt                             
[manjaro@manjaro ~]$ find /mnt
/mnt/System Volume Information
/mnt/System Volume Information/tracking.log

And the grub config files:

[manjaro@manjaro ~]$ sudo umount /mnt
[manjaro@manjaro ~]$ sudo mount /dev/sda7 /mnt
[manjaro@manjaro ~]$ find /mnt/boot -maxdepth 2

This UEFI stuff is quite new to me, so thanks for bearing with me.

My first post. I know much has been said since. But I think this is still valid.

Cheers to all.

I think gohlip is on the right track.

It seems your EFI boot entries contain no actual OS entires - only recovery entries for Windows. There is no old Linux installation entry, either. There is no EFI system partition (ESP), and hence no EFI folder, either.

Changes are, considering your previous installation worked and current one doesn’t:

    1. GRUB was installed correctly in Legacy mode previously, but is not anymore
    1. GRUB was installed in UEFI mode previously (but the ESP partition is now removed), and:
  • a) GRUB is not installed correctly in Legacy mode currently or
  • b) GRUB is installed correctly, but your laptop can not boot GRUB in Legacy mode.

I’d once more try to restore GRUB, by either booting in Legacy mode to another live distribution, and chrooting into your Manjaro, or booting from a Legacy USB -installed GRUB into your Manjaro installation (I understand you have already achieved this?). Then follow these intructions (already linked before).

Can you boot into Windows currently? If, how do you do that?

Hi Everyone.

Thanks for all your help - it did seem to be in an odd state.

I thought the best thing I could do was just to re-install entirely on a new disk, seeing I had the opportunity of one.

Everything is all fully functional in UEFI mode now.

Thanks again.

1 Like

Forum kindly sponsored by Bytemark