Not automatically mounting removable drives

When I connect phone through USB nothing shows up on thunar and no removable drive shows up on desktop (the icons are all turned on). Then I downloaded Dolphin file manager and it shows up in Dolphin but not in thunar nemo or anything else. No extra device is being shown even if I enter “fdisks -l” command on terminal.

Depending on the phone, the USB connection defaults to : Power supply only …

Verify on the phone in the notifications details if that is marked to : PTP , MTP or other such as Storage or similar ( depends on the phone android version ) …

Only when selecting storage mode will Thunar starting to recognize the phone as a removable device …

Also it’s not set to default open automatically. You should get a notification to open it. Also as soon as you close your file browser the connection will end and you have to remount it.

Do you have the required package installed?

To view the contents of your Android device’s storage via MTP in your file manager, install the corresponding plugin:

  • For file managers that use GVFS (GNOME Files), install gvfs-mtp for MTP or gvfs-gphoto2 for PTP support.
  • For file managers that use KIO (KDE’s Dolphin), MTP support is included in kio-extras (dependency of dolphin).

Media Transfer Protocol - ArchWiki

everything has been set the way you said but still thunar does not recognize or mount my phone, only dolphin does

i am not getting any notifications or anything unfortunately

I just installed gvfs-mtp, gvfs-gphoto2 but still no results. I am using dolphin because only dolphin shows up my phone or any other phone but yesterday I tried with a sandisk sdcard and it mounted successfully.