Not able to boot kernel after update

Yes I know this topic gets posted on basically a daily basis, but I swear its different this time! Hopefully.

I have already chrooted into my machine from usb and installed a kernel, but grub is not recognizing it? I actually have other kernels installed 519, 518 and it did not recognize those either, the only options available in advanced settings are 515 and 517, but if I try to boot from either of those it gives the error

error: file ‘/boot/vmlinux-(kernel)’ not found
error: you need to load the kernel first.

any suggestions?
this is on my desktop with nvdia graphics

Thank you for your time

so chroot and post output from:
mhwd-kernel -li

Currently running: 5.15.16-1-MANJARO (linux515)
The following kernels are installed in your system:

so reinstall them all:
remove them:

mhwd-kernel -r linux518
mhwd-kernel -r linux519
mhwd-kernel -r linux519-rt

install only one:
mhwd-kernel -i linux518

any errors post here

this error message pops up when removing 518:

(4/5) Refreshing PackageKit…
Error connecting: Could not connect: No such file or directory
error: command failed to execute correctly
(5/5) Updating Grub-Bootmenu
/etc/default/grub: line 5: splash: command not found
error: command failed to execute correctly

probably the grub needs to be reinstalled too … post output from:
test -d /sys/firmware/efi && echo efi || echo bios

so I installed linux515 and that let my machine boot, but I want to be able to use a more recent kernel than 515, so the problem is not yet fixed because I still cant use any new kernels, and the output of that command was


so post output again from:
mhwd-kernel -li

Currently running: 5.15.60-1-MANJARO (linux515)
The following kernels are installed in your system:

  • linux515

the gui tool still displays 519 and 519rt as being installed
I also ran that command right after I booted and the list was different, it had 515 519 519rt listed as installed, then I ran the uninstall command for 519 and it threw the same errors.

your grub is also probably broken … run this command:
sudo update-grub
and post the output from it here

/etc/default/grub: line 5: splash: command not found

post the whole output!

that is the whole output

so when you run update grub, this one line is everyhting?


[sudo] password for jakw:

other than that, yup

post output from:
cat /etc/default/grub

edit: I am an idiot, i did post the wrong output

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi=force apm=power_off”

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki:

open the grub conf and check if in it this line has the same quotes:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi=force apm=power_off”

if yes change the quotes to look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force apm=power_off"

save the file, and run again sudo update-grub

where is that file located?

in /etc/default/grub
you can open it via your text editor, im using kate so the command is:
kate /etc/default/grub - you replace kate with the name of the text editor you are using;
or you can navigate there via your file manager