Not able to boot after a fresh install

So basically: I downloaded Manjari gnome edition. And after successful installation, I’m not able to boot. It just shows a black screen on reboot.

I tried all the methods listed on another thread (fix-system-doesn-t-boot-boots-to-a-black-screen-or-stops-at-a-message/3906) … But none of them seem to work ( and not relevant as I’m not able to get anything on the display).

I’m very new to linux, and this is my first time trying out manjaro; please excuse me for my lack of knowledge.

Hey can you answer this questions?

Are you using a laptop?
Are you using Nvidia?
Are you using a external monitor?

If your answers are yes to all, try to disconnect first the external monitor and try again.

yes, i’m on a laptop running on a nvidia gpu.
and no, i’m not connected to an external monitor.

But, my display is connected to the radeos iGPU.

Can you try doing an install with the open source drivers (none proprietary/nvidia) and see if it boots? If it does we can look at the nvidia drivers after that

I tried both, none worked … Then wiped the drive using gpart from live usb … Installed it again.

And now the problem is that it boots up, but takes a very long time ( 10+ mins; on a nvme ssd ) and then a dash appears in the upper right corner, then I have to close the lid, and only then it boots up.