Nordvpn-bin breaks every 4 hours

For anyone that is interested, there is a solution to this problem up on the AUR site:
AUR (en) - nordvpn-bin (second comment)
Basically it involves downgrading nordvpn-bin to an earlier version, the link explains how.
In my case I also had a missing dependency called ipset which I had to install before running makepkg.
It all seems to be working again now although I haven’t been running it for long.

Been using the workaround I mentioned before for 2 days now, have not had the issue in the OP occur again for those 2 days.

It solves the main issue but it does create a new one, which is that every 3 hours you switch vpn servers and therefore get a short connection interrupt which can posisbly cause you other issues (though I have not experienced any of those yet myself, I haven’t tested this while doing something like say online gaming to see how it responds to this)

I imagine most games would handle this fine so long as your server is in the same country (which is why I ensured that in my workaround) at least applications like for instance steam are (steam will disconnect you if you change your vpn server to one in a different country, it will also require password whenever you connect from a different country, but everything’s fine if it’s the same one), but there are bound to be exceptions.

SERVER=$(nordvpn status | grep -o "[a-z]\{2\}[0-9]\+")
nordvpn c $SERVER

Here is an edited version of your script to reconnect to the exact same server and hopefully minimize service interruptions.

(second output line of “nordvpn status” contains the exact server you are currently connected to)

1 Like

Sweet! Thank you! I’ll edit my post and add this in.

Also welcome to the manjaro forums! :slightly_smiling_face:

Urgh, their ■■■■■■■ support man…

I tried contacting them again now that I have more accurate data on the issue (first time around they just asked me to turn ipv6 on), e.g. that it occurs after exactly 4 hours and 20 minutes every time.

They asked me to provide daemon logs, which I did.

Then they asked me if I tried anything to fix the issue and I told em I tried with ipv6 on and off, and that it had no effect.

They asked me if it was on now, and I said it was, they asked me to turn it off and see if that solved the issue :angry:

When I explained to them that it didn’t, they just said they didn’t support Manjaro/Arch, I mean their website says:

  • Install the .rpm package and enjoy your favorite Linux distribution

Then you contact support and when someone discovers a bug in their software they go “sorry, your favorite distro is not supported”

What a waste of my ■■■■■■■ time.

Just a bit of feedback for those that has similar issues.

I had similar problems, didn’t time the intervals as OP did but had mutliple disconnects per day and only a restart of iptables service and noredvpnd resolved it.

By following the mentioned links from linux-aarhus: to change to systemd-resolved, and the aur linux discussion by unmasked
to install wireguard-tools, this problem was resolved. (note this is using nordlynx, killswitch enabled and ipv6 disabled in nordvpn)

I have had no connection droppage for 35hours now and added bonus is network-manager now correctly reflects the connection to nordvpn.

1 Like

i ddn’t have wireguard-tools installed, but I will certainly try that now that you’ve suggested it.

Also I have a bit of an update on the issue, after the latest nordvpn update (3.12.1) it started happening sometimes every 2 hours and 10 minutes, which is quite interesting, since it went from 4 hours 20 minutes to 2 hours and 10 minutes, it’s like the duration between connection breaks got cut exactly by half.

Yep and my cronjob is set to three hours??? I have gone back to 3.12.0 and though it is not perfect, it is better than the current. When disconnecting with the new version, the disconnect message is different and cryptic, too. I don’t see where to report bugs on their site either. Where can the daemon logs be found?

Please follow-up and give your feedback on the wireguard-tools/systemd-resolved workaround, if you give it a try.

1 Like

It’s promising, I’ve been connected for 6 and a half hours now without issue, not 100% sure if it fully solved the issue but at least at first glance though, it worked.

Update: now been 10 hours without a disconnect, I’m pretty sure installing wireguard-tools solved the issue I was having.

1 Like

I installed wireguard-tools and changed to systemd-resolved. I am going to leave the cronjob intact. I think wireguard-tools or systemd-resolved made my network manager icon indicate that my vpn is active. When I go to VPN connections via Network Manger, “nordlynx” is checked. When I uncheck that “nordlynx” the icon changes, but I am still connected to the VPN. Strange behavior there. Also when I hover over the network manager icon it claims “starting VPN connection Nordlynx”, but I am already connected and confirmed by nordvpn status in terminal.

Is there a way to configure this wireguard-tools?

Update: I deleted the problematic Nordlynx/wireguard connection in network manager, then reconnected. NM recreated the Nordlynx entry, but now when I hover over it says “VPN connection active”.

Update 2; When cronjob executed at 3 PM, the NM icon now shows "Starting VPN Connection “Nordlynx”

Update 3: At 6 PM upon reconnect via cronjob, tray icon shows “VPN connection active” when I hover over.
I guess I will keep this setup as it appears it needs some time to see for sure. I just upgraded to 3.12.1-1.

1 Like

I marked this answer as the solution, it’s clearly solved the issue at least until I see evidence otherwise, but if it’s already working for 3 of us, I think that paints a pretty clear image :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.