Nordvpn-bin breaks every 4 hours

@linux-aarhus
I also added ipv6_disable=1 to the grub for be sure ipv6 totally deactivate (or is it useless???)

I’ve tried now both with ipv6 disabled (after fixing hosts file) and with ipv6 enabled. Issue was the same (I noticed it frequently happens exactly around the 4 hour 20 minute mark after connecting to nordvpn)

Next up I’m trying your dns thingy, I don’t even understand what problem it is supposed to solve though, I mean in practice.

Sure it resets the DNS properly after nordvpn disconnects, but I still can’t use the internet when nordvpn is disconnected in the first place so I’m not sure what it’s really supposed to do to help.

I noted from your journal that you have set NordVPN to nordlynx - is it the same with OpenVPN?

I am going to test nordlynx extensively today.

Started NordVPN using nordlynx @ 2021-09-06T05:40:00Z

Running …

Stopped @ 2021-09-06T18:40:00Z

No problems

1 Like

I don’t know how nordlynx works, and as you want to use wireguard, ask Nord about you installing wireguard-tools, and them sending a config file for each wireguard server (you need) that also include the keys per server.

I use that with another VPN provider, and all you need to connect in the terminal is wg-quick up servername or disconnect wg-quick down servername.

The config files are downloaded and moved into etc/wireguard.
The ones from my VPN provider have this structure:

[Interface]
PrivateKey = dPy2Q...
Address = 
DNS = 

[Peer]
PublicKey = YQ0fi8...
AllowedIPs = 0.0.0.0/0, ::/0
Endpoint = wg-servername:port number
PersistentKeepalive = 25
1 Like

I have yet to test with OpenVPN, but the thing is each test run takes at least 3 hours, sometimes 4 hours and 20 minutes, but I do not recall any point it didn’t disconnect after 4 hours and 20 minutes except once or twice when I was entirely afk. I can’t always test this everyday cuz sometimes I’m troubleshooting other issues I’m having (audio and some issues with VMs which sometimes break my host when I run them :grimacing: and I haven’t even gotten the VMs to work right yet) and those require me to restart sometimes frequently; meaning they’d interrupt any testing of this specific issue.

This also means that testing to see if possible reconfigurations help solve the issue can take a quarter of a day, so even the smallest tweak takes that long to test.

@tharangalion this might actually be worth a try, I heard nordvpn used to provide such files to people who asked but I saw a thread from 2020 where people were complaining about them having stopped doing it, (probably because they just want people to be using nordlynx instead).

It looks like I found an actual workaround that prevents the issue from occurring, If, before the point of disconnection I run the nordvpn c command it seems to reset whatever is causing the issue.

This of course still results in a periodic disconnect, but it prevents the actual breakage. I have created a script that automatically does this every 4 hours.

#!/bin/bash

#SERVER=$(nordvpn status | grep -o "[a-z]\{2\}[0-9]\+")
COUNTRY=$(nordvpn status | grep Country | sed 's/Country: //g' | sed 's: :_:g')

nordvpn c $COUNTRY

To run every four hours I use the command crontab -e and add this line:

 */4 * * * /path/to/the/script

(If anyone’s actually following this, don’t forget to make the script executable).

To try and prevent any server switching related issues I made sure the client will always connect to the same country too. (There’s an option for connecting to the same server instead of country, but I sometimes had issues with it)

Update: I have been running with this workaround active for a few days now and nordvpn has not broken once.

Update: Changed 3 hours to 4 hours, have tested it for a couple of days and it’s fine this way too.

Update: Thanks to TheMikiey, script can now connect to the same server rather than just the same country.

Update: Nordvpn suddenly started spitting out errors when trying to connect to a specific server instead of to a country, reverted to just connecting to the same country instead.

1 Like

I was having similar issue with the vpn, I searched many place to solve the issue. On of my friend suggested me Ivacy vpn to give it a try and It really works good.

I have been having issues recently with nordvpn disconnecting randomly. I connect via Network Manager and openvpn as my speeds are about the same with NordLynx. The error in the journal is this:

nm-openvpn ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted

I followed the guide at the following link and so far it seems fixed, but I just implemented and will have to wait and see. I had to enable systemd-networkd as it was not enabled by default on my system and then I masked systemd-networkd-wait-online.service as I don’t need that. The creation of the nm-openvn@.service, I couldn’t make work. The bottom post labeled “correction” is what I am using.

https://bbs.archlinux.org/viewtopic.php?pid=1881081

Update: It stayed connected according to the icon in the taskbar, but I could not connect to any websites when I returned home after 3 hours. Reconnecting to VPN via network Manager/ OpenVpn worked fine. I reversed the fix outlined above.

1 Like

Not getting any errors related to tun.

But I did notice some possibly related errors from nordvpnd:

ERROR: (nordlynx) 2021/09/06 02:45:32 - Failed to send handshake initiation: network is unreachable
ERROR: (nordlynx) 2021/09/06 03:50:04 - Failed to send data packet: network is unreachable
2021/09/06 23:57:55 [Error] connected to nordlynx server but there is no internet as a result
nordvpnd[1690]: 2021/09/07 12:29:56 [Error] refresh ipv6
nordvpnd[1690]: 2021/09/07 12:29:54 [Error] refresh ipv6

I saw this thread and thought I would add my recent problems with Nordvpn. I have been using it for several years and until last Sunday (5th Sept) had no problems with it. Since then there have been many. First of all autoconnect stopped working, and manual connections were extremely slow, very often after a long wait, I would end up being connected not to the country I had asked for but to Israel instead (always Israel, nothing else). Looking at Nord help files one of their suggestions was to logout and login again to your nord account, so I did this and now every time I try to connect with nordvpn-bin I get told that my account has expired. It has about 14 months left to run.
After that nothing worked as everything I did ended up on their ‘update your subscription page’.
I decided to try nordpy instead (I had used it before) this would not connect via my usual ikev2 protocol but at least it didn’t tell me that my account was out of date, so I tried switching protocols to UDP and surprisingly I got a connection so that is what I am using now.
I emailed their support, but I don’t hold out much hope there, but basically my experiences coupled with the OP’s report must point to a recent problem with Nord and Manjaro whilst using nordvpn-bin though not with nordpy?

For anyone that is interested, there is a solution to this problem up on the AUR site:
AUR (en) - nordvpn-bin (second comment)
Basically it involves downgrading nordvpn-bin to an earlier version, the link explains how.
In my case I also had a missing dependency called ipset which I had to install before running makepkg.
It all seems to be working again now although I haven’t been running it for long.

Been using the workaround I mentioned before for 2 days now, have not had the issue in the OP occur again for those 2 days.

It solves the main issue but it does create a new one, which is that every 3 hours you switch vpn servers and therefore get a short connection interrupt which can posisbly cause you other issues (though I have not experienced any of those yet myself, I haven’t tested this while doing something like say online gaming to see how it responds to this)

I imagine most games would handle this fine so long as your server is in the same country (which is why I ensured that in my workaround) at least applications like for instance steam are (steam will disconnect you if you change your vpn server to one in a different country, it will also require password whenever you connect from a different country, but everything’s fine if it’s the same one), but there are bound to be exceptions.

#!/bin/bash
SERVER=$(nordvpn status | grep -o "[a-z]\{2\}[0-9]\+")
nordvpn c $SERVER

Here is an edited version of your script to reconnect to the exact same server and hopefully minimize service interruptions.

(second output line of “nordvpn status” contains the exact server you are currently connected to)

1 Like

Sweet! Thank you! I’ll edit my post and add this in.

Also welcome to the manjaro forums! :slightly_smiling_face:

Urgh, their ■■■■■■■ support man…

I tried contacting them again now that I have more accurate data on the issue (first time around they just asked me to turn ipv6 on), e.g. that it occurs after exactly 4 hours and 20 minutes every time.

They asked me to provide daemon logs, which I did.

Then they asked me if I tried anything to fix the issue and I told em I tried with ipv6 on and off, and that it had no effect.

They asked me if it was on now, and I said it was, they asked me to turn it off and see if that solved the issue :angry:

When I explained to them that it didn’t, they just said they didn’t support Manjaro/Arch, I mean their website says:

  • Install the .rpm package and enjoy your favorite Linux distribution

Then you contact support and when someone discovers a bug in their software they go “sorry, your favorite distro is not supported”

What a waste of my ■■■■■■■ time.

Just a bit of feedback for those that has similar issues.

I had similar problems, didn’t time the intervals as OP did but had mutliple disconnects per day and only a restart of iptables service and noredvpnd resolved it.

By following the mentioned links from linux-aarhus: https://forum.manjaro.org/t/nordvpn-bin-breaks-every-4-hours/80927/10?u=zylan to change to systemd-resolved, and the aur linux discussion by unmasked https://forum.manjaro.org/t/nordvpn-bin-breaks-every-4-hours/80927/21?u=zylan
to install wireguard-tools, this problem was resolved. (note this is using nordlynx, killswitch enabled and ipv6 disabled in nordvpn)

I have had no connection droppage for 35hours now and added bonus is network-manager now correctly reflects the connection to nordvpn.

1 Like

i ddn’t have wireguard-tools installed, but I will certainly try that now that you’ve suggested it.

Also I have a bit of an update on the issue, after the latest nordvpn update (3.12.1) it started happening sometimes every 2 hours and 10 minutes, which is quite interesting, since it went from 4 hours 20 minutes to 2 hours and 10 minutes, it’s like the duration between connection breaks got cut exactly by half.

Yep and my cronjob is set to three hours??? I have gone back to 3.12.0 and though it is not perfect, it is better than the current. When disconnecting with the new version, the disconnect message is different and cryptic, too. I don’t see where to report bugs on their site either. Where can the daemon logs be found?

Please follow-up and give your feedback on the wireguard-tools/systemd-resolved workaround, if you give it a try.

1 Like

It’s promising, I’ve been connected for 6 and a half hours now without issue, not 100% sure if it fully solved the issue but at least at first glance though, it worked.

Update: now been 10 hours without a disconnect, I’m pretty sure installing wireguard-tools solved the issue I was having.

1 Like

I installed wireguard-tools and changed to systemd-resolved. I am going to leave the cronjob intact. I think wireguard-tools or systemd-resolved made my network manager icon indicate that my vpn is active. When I go to VPN connections via Network Manger, “nordlynx” is checked. When I uncheck that “nordlynx” the icon changes, but I am still connected to the VPN. Strange behavior there. Also when I hover over the network manager icon it claims “starting VPN connection Nordlynx”, but I am already connected and confirmed by nordvpn status in terminal.

Is there a way to configure this wireguard-tools?

Update: I deleted the problematic Nordlynx/wireguard connection in network manager, then reconnected. NM recreated the Nordlynx entry, but now when I hover over it says “VPN connection active”.

Update 2; When cronjob executed at 3 PM, the NM icon now shows "Starting VPN Connection “Nordlynx”

Update 3: At 6 PM upon reconnect via cronjob, tray icon shows “VPN connection active” when I hover over.
I guess I will keep this setup as it appears it needs some time to see for sure. I just upgraded to 3.12.1-1.

1 Like