Nordvpn-bin AUR installer

I want to install “nordvpn-bin” but the file won’t download due to restrictions in the country I’m connected to the internet. I have downloaded nordvpn_3.16.3_amd64.deb locally on the computer and need to change PKGBUILD, but unfortunately do not know which changes should be made.

# Maintainer: Cabel <mxzcabel at proton dot me>
# Contributor: metiis <aur at metiis dot com>
# Contributor: Julio Gutierrez <bubuntux at gmail dot com>
# Contributor: Martoko <mbastholm at gmail dot com>

pkgdesc="NordVPN CLI tool for Linux"
arch=('x86_64' 'i686' 'armv7h' 'aarch64')

# There is also ArmEABI architecture for android devices available. Download with:

package() {
    bsdtar -O -xf *.deb data.tar.gz | bsdtar -C "${pkgdir}" -xJf -

    mv "${pkgdir}/usr/sbin/nordvpnd" "${pkgdir}/usr/bin"
    rm -r "${pkgdir}/etc/init.d"
    rm -r "${pkgdir}/usr/sbin"
    echo "g nordvpn - -" | install -Dm644 /dev/stdin "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"

Please see

You don’t need to change the PKGBUILD - just place the downloaded file in the same folder as the cloned PKGBUILD

git clone
cd nordvpn-bin
makepkg -is

You may need to switch your system to use systemd-resolved - as described in above linked topic - otherwise you may get weird errors when your resolv.conf is not restored correctly.

I haven’t tested the issue, which caused me wtring the linked topic, since.

If you at a later point in time download a new file - you only have to change pkgver, save the file and run updpkgsums

I don’t know this, so I’m completely unsure, but I presume the filename should match between the PKGBUILD and the downloaded file?

If he downloaded the file like he said he did, the name will be what the PKGBUILD expects to find …

1 Like

That’s good. Just wanted to make sure and that it’s noted, if nothing else.

hey there im pretty noob, followed the Arch-wiki and got Nordvpn working.
(archlinuxorg.slash title.slash NordVPN) sry it says can’t include link so search it yourself.

Things to note:
the gaswd username is the username of your installed linux (not the nordvpn account)
to start the service i used “sudo systemctl restart nordvpnd”
section 4.1
use the “Token” Method, log into Nordvpn website,
find and create the token string (it’ll do a email/ phone confirmation)
copy it and use the command provided. tick the last forever option.

then just type nordvpn login.

lastly, run: (thanks to mr. linux-aarhus)
sudo systemctl enable --now nordvpnd.socket
if you get the .sock not found error after restart.

to set auto-connect on Nordvpn, do this:
nordvpn s autoconnect off (turn it off first)
nordvpn s autoconnect on us1234
(replace the us1234 to the server you like)

that’s all and it’s been stable everythings working for me. Hope this helps.