Noobie problem - why might install fail when live CD works fine?

That sucks… yet we know the hardware can handle what comes off your USB. So maybe it’s the hard drive. I had something similar on an old computer that simply couldn’t understand a drive over 2TB. I had to reformat it as ext3 or 4 before it would work and even then had to keep my partition less than 2TB in size, but I doubt that’s your problem with a brand new machine that will definitely have an up to date BIOS.

Yeah, the BIOS is FHCN22WW. I don’t know how to check how old that is, but I assume less than a year, since the CPU is 11th gen Intel Core i5 ‘Tiger Lake’, which launched in September.

I checked that it didn’t have an Nvidia card before choosing Manjaro, as I’d heard there were problems. But Mint works, assuming I can resolve the video acceleration problem, so I should be able to fall back on that. I just have more confidence in a distro like Manjaro that works out of the box and doesn’t need to be fixed like Mint does.

And yeah, the drive/partition size doesn’t seem to be a problem. I want to partition the drive anyway, but even so it’s only 1/2 TB (SSD).

But surely there’s got to be a way to pause the scrolling when it installs so I can see what the error is!

BTW, I just installed MX Linux KDE. No touchpad, but the rest seems okay. I also scanned my USB boot drive and didn’t find any read or write errors.

Can you try another arch based distro like garuda or endeavour? So far you’ve managed to install debian, we’ll soon see if its manjaro specific then

Do that from LiveCD.
inxi -Fazym

Looks like it’s an Arch problem. I tried Endeavor, and it ran off the USB (no sound when I watched YouTube, but the touchpad worked, same as Manjaro), but after I installed, there was a single FAIL when I shut down (presumably the same one as Manjaro, but it zipped by too fast to tell), and when I restarted I got a very similar error message:

 Starting versions 246.5-1-arch
 ERROR: device 'UUID=[16digit#]' not found. Skipping fsck.
 mount: /new_root: can't find UUID=[same 16digit#].
 You are now being dropped into an emergency shell.
 sh: can't access tty: job control turned off
 [rootfs ]#

ArchBang won’t even run off the USB. I get ACPI BIOS errors, ‘could not resolve symbol [(backslash)_SB.PC…]’ etc.

Ran it, but I don’t know where in the returned data is the partition scheme. I would think it’s under “Drives” or “Partition”, but I don’t see it.

Hi all. Thanks so much for all your help, but I got Mint working (just needed to change the kernel), and I think I’ll go with that instead. It was my second choice anyway. Maybe someday I’ll get more than just a first impression of what Manjaro’s like.

1 Like

I enjoyed Mint for a few years - and you can install KDE, which I think is better than Cinnamon - though I’d advise installing a new user (after doing a timeshift backup) to play with it.