None of the GNOME settings menus open

System:
  Kernel: 5.10.79-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=dad97322-5903-4ff0-9441-555f41020ef6 rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: GNOME 41.1 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 41.0
  Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20NFCTO1WW v: ThinkPad E595
  serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20NFCTO1WW serial: <superuser required> UEFI: LENOVO
  v: R11ET41W (1.21 ) date: 06/07/2021
Battery:
  ID-1: BAT0 charge: 34.4 Wh (78.5%) condition: 43.8/45.3 Wh (96.8%)
  volts: 11.8 min: 11.1 model: SMP 01AV446 type: Li-poly serial: <filter>
  status: Unknown cycles: 53
Memory:
  RAM: total: 13.6 GiB used: 2.37 GiB (17.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
  bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 18 (24)
  stepping: 1 microcode: 8108102 cache: L1: 384 KiB L2: 2 MiB L3: 4 MiB
  bogomips: 33551
  Speed: 2150 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz):
  1: 1925 2: 2583 3: 1629 4: 1580 5: 1229 6: 1230 7: 1234 8: 1231
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36
  rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme
  smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce
  topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
  disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Picasso vendor: Lenovo ThinkPad E595 driver: amdgpu v: kernel
  bus-ID: 05:00.0 chip-ID: 1002:15d8 class-ID: 0300
  Device-2: Chicony Integrated Camera (1280x720@30) type: USB driver: uvcvideo
  bus-ID: 3-2:3 chip-ID: 04f2:b604 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.org 1.21.1.1 compositor: gnome-shell driver:
  loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
  resolution: <missing: xdpyinfo>
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0
  5.10.79-1-MANJARO LLVM 13.0.0)
  v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio
  vendor: Lenovo ThinkPad E595 driver: snd_hda_intel v: kernel bus-ID: 05:00.1
  chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
  vendor: Lenovo ThinkPad E595 driver: N/A
  alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5
  chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Lenovo ThinkPad E595
  driver: snd_hda_intel v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3
  class-ID: 0403
  Sound Server-1: ALSA v: k5.10.79-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Lenovo ThinkPad E595 driver: r8168 v: 8.049.02-NAPI modules: r8169
  port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel bus-ID: 04:00.0
  chip-ID: 8086:2526 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
  v: 0.8 bus-ID: 3-1:2 chip-ID: 8087:0025 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 465.76 GiB used: 48.28 GiB (10.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
  model: SSD 970 EVO Plus 500GB size: 465.76 GiB block-size: physical: 512 B
  logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
  rev: 2B2QEXM7 temp: 40.9 C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 80.8 GiB size: 79.03 GiB (97.81%) used: 48.25 GiB (61.1%)
  fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 label: N/A
  uuid: dad97322-5903-4ff0-9441-555f41020ef6
  ID-2: /boot/efi raw-size: 259.5 MiB size: 258.9 MiB (99.80%)
  used: 31.1 MiB (12.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  label: SYSTEM uuid: 7640-B410
Swap:
  Alert: No swap data was found.
Unmounted:
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
  label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 236.53 GiB fs: ntfs label: Windows
  uuid: 01D56A0A8E345830
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 707 MiB fs: ntfs label: N/A
  uuid: 76E6521CE651DD45
  ID-4: /dev/nvme0n1p5 maj-min: 259:5 size: 1000 MiB fs: ntfs label: WinRE_DRV
  uuid: 01D56A0A96426AD0
  ID-5: /dev/nvme0n1p6 maj-min: 259:6 size: 146.48 GiB fs: ntfs label: Games
  uuid: 94F22E63F22E4A36
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Intel Wireless-AC 9260 Bluetooth Adapter
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 8087:0025 class-ID: e001
  Device-2: 3-2:3 info: Chicony Integrated Camera (1280x720@30) type: Video
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
  chip-ID: 04f2:b604 class-ID: 0e02 serial: <filter>
  Hub-4: 4-0:1 info: Super-speed hub ports: 1 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 55.2 C mobo: 0.0 C gpu: amdgpu temp: 55.0 C
  Fan Speeds (RPM): cpu: 3300
Info:
  Processes: 306 Uptime: 11m wakeups: 1 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1354 pacman: 1339 lib: 393
  flatpak: 8 snap: 7 Shell: Bash v: 5.1.8 running-in: gnome-terminal
  inxi: 3.3.09

Any settings options I try to open, nothing happens. This could be right clicking display and trying ‘display settings’ or just ‘settings’ or going to power options, bluetooth/wifi options etc. in the top right - any sort of settings do not open.
Have had Manjaro GNOME installed for 2 years and normally any issues like this are resolved by disabling GNOME extensions, and/or updating these extensions. No luck this time.
I have tried changing themes as well.
Please advise if I can give any more info. - as per the “how to provide good info page” I am currently studying Computer Science and have spent many years as an IT/Printer Technician, but reasonably inexperienced with the inner workings of Linux.

I guess Xorg was default 2 years ago.

You are using Xorg or Wayland?

echo $XDG_SESSION_TYPE

One diagnostic to trick to try is starting the settings from the terminal and see if there are any errors. You start the settings windows in the terminal with:
$ gnome-control-center

Did you remove gnome-control-center by accident? :wink:

Thanks for the quick response!
I must’ve uninstalled it accidentally.
Re-installing solved the problem.
Thanks all.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.