Non Wacom tablet settings

I just brought a Trust TB-7300 drawing tablet and while it works just fine when I plugged it in, I can't set which display to use or modify the sensitivity and the macros.
How do I change those kind of settings?

Hello,

For that tablet you need the xf86-input-wizardpen package from AUR
http://aur.archlinux.org/packages/xf86-input-wizardpen

Reboot after that. Not sure if will provide options in the Graphical UI Settings (depends what DE you are using).
More information about it here
https://digimend.github.io/support/howto/drivers/wizardpen/
If you are on KDE Plasma, it might work with kcm-wacomtablet but i'm not sure, never tested that device.

Usually the xsetwacom commands work for most tablets, or trough the use of xinput (you need xorg-xinput installed for that) you can also set some parameters but only from terminal and you need to investigate. The creation of scripts with particular set is possible, then you can map buttons or shortcuts to run that particular script.

Maybe you can make use of this


in case you use a DE that has no other utility for tablets configuration.
1 Like

I tried to use wacom-gui but I can't install PyQT4

That is why i pointed you to the Qt5/PyQt5 migration branch :slight_smile:

Oh ok. I'll try that and see if it helps.

UPDATE: I tried from the fork but it stills says to install PyQT4.

Try to run the binary from the source folders where you downloaded them. Since is not a proper Arch package and has some rpm related things, you can first test that way ...

That's what I do. I clone the repo and run python2.7 wacom-gui.py.

Works with the default version of python, no need to run it trough the 2.7 version. :slight_smile:

Really? When i try it give me

  File "wacom-gui.py", line 194
    print e
          ^
SyntaxError: Missing parentheses in call to 'print'. Did you mean print(e)?

While with python2.7 it gives me the PyQT4 error.

My Cintiq is in service right now and i don't have any other tablet at the moment, but this is on my end:

It trows some messages too, but it starts. From the wacom-gui folder just use:
./wacom-gui.py

The line 194 on my end has
#delete file
entry.
Maybe something changed in the code lately that i didn't check ...

Did you made the file executable, right?

So I modified the problematic line and it worked... I now have the same PyQT4 error as with python2.7

I think you downloaded/cloned the old one, not the fork


Download it as wacom-gui-qt5-migration.zip

extract it, and use that wacom-gui folder and wacom-gui.py

Ok, so i downloaded the .zip in your response and It worked but gave me those errors :
Capture d’écran de 2020-05-23 17-53-54 Capture d’écran de 2020-05-23 17-53-54

Well, it detected your model. That is a starting point. Get in touch with the developers of this and they will ask how to provide the information needed to add your model to the list of devices. Once that is in place, there might be a way to have it fully working. Just open an issue ticket ...

See for example this one

Forum kindly sponsored by