No wired network (Realtek RTL8111/8168/8411)

realtek
xfce
network
8168

#8

@fhdk
And this is on left click


#9

when I put ip link into the terminal i just get this.

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00


#10

Okay, I have this exact same problem since the last stable update with this exact same network card. I’m running Cinnamon DE.

In /etc/modprobe.d I have a blacklist for r8169, so that should not apply to my card/driver.
When I try to sudo modprobe r8168 it says: modprobe: ERROR: could not insert 'r8168': Exec format error

So, this machine was working fine, update, driver gone.


#11

Have you tried switching kernels? Had a similar problem on 4.11-rc6.


#12

And it does not yet work on 4.11 - that I know - I tried to build an ISO with 4.11 kernel and had to remove r8168 because it does not exist for that kernel yet


#13

not sure if this is related but i had something like this after installing manjaro deepin…

I have the realtek r8169 witch is a wired ethernet onboard card, however after installing deepin it had blacklisted the r8169 and was using the r8168 which i believe is a wireless network. I had to go into etc/modeprobe.d and change the file from blacklist r8169 to blacklist r8168 and everything is working fine.

I also noticed after, if you goto manjaro settings manager, hardware configuration you can see it has the network-r8168 driver installed instead of the r8169

Hope this helps


#14

Yes, I tried booting with Kernel 4.4 and 4.8 (it’s default on 4.9) and while it worked there in the past, now it doesn’t. Booting the fallback images doesn’t help either.

It works fine from live-usb though.

And since this machine now has no internet connection anymore, it’s a bit difficult to get it to update anything. I’m thinking of chrooting in and seeing if updating it will solve anything.


#15

Well, inxi reports the card as Realtek RTL8111/8168/8411… but I’ll give removing the blacklist a try.


#16

It says that for me but its not:

inxi -N

Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169


#17

No driver exist for r8169 in repo neither AUR has one

pacman -Ss r8169

#18

Okay, this is weird! I removed the blacklist for r8169 and I have a working ethernet connection again. Inxi reports driver: r8169


#19

Wonder if it could be compiled into the kernel?

Which also might explain why a kernel update could break it - if it is blacklisted due to previous problems?


#20

Possibly. But pacman now gives me 65 packages to update, amongst which linux49-r8168 kernel modules…

The article linked above mentioned that in the absense of the r8168 module, the r8169 is loaded, but that this module is considered far from stable.

I’m starting to think it’s botched update where the right kernel modules were not automatically updated too.


#21

I don’t think so. While the team does a great job at making Arch more friendly to approach - Manjaro shares many of Arch peculiarities including possible breaks on updates. It is inevitable consequence of rolling release.


#22

Ah, no, I didn’t mean the team botched it. Something probably went wrong on my side when updating :slight_smile:


#23

Okay, I have applied the updates, the r8168 kernel modules were updated too. I have reinstated the r8169 blacklist and everything works normally again.

When you don’t blacklist the r8169 driver, it gets loaded, even if you have the r8168 kernel modules properly installed. So I guess it’s some inbuilt kernel fallback. When you blacklist it, the r8168 module gets loaded and used.

I hope this info helps @RobM recover as well :slight_smile:


#24

I don’t think so, for me this problem appeared after a clean install of manjaro deepin, luckily for me I was able to fix it. Otherwise I would have move on to another distro, definitely something up somewhere.


#25

Cheers for the input and info everyone I will give this a try now and report back need to write it down as no access via linux machine
I will say I have not changed kernel since version 4.10 and that was installed cleanly so no other kernel is on the machine.


#26

Thank you all so so much for your inputs it was the blacklisting that had somehow happened
Thanks Fred for sticking with me and everyone else for your valid inputs.

Posted from my Linux machine :slight_smile:


#27

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.