No wifi visible or can connect to any wifi unless I restart my pc

System:    Kernel: 5.7.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=de6b5b01-5d6e-4001-8da9-840acde5fe79 rw quiet apparmor=1 
           security=apparmor resume=UUID=f086c8c3-05e4-48ec-84e8-f7d63955ed79 udev.log_priority=3 
           Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK (MS-7C02) v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: 1.D0 date: 11/07/2019 
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) model-id: 71 (113) 
           stepping: N/A microcode: 8701013 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86438 
           Speed: 2801 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 2956 2: 1949 3: 2052 4: 3600 5: 1955 
           6: 2053 7: 2054 8: 3601 9: 3065 10: 1887 11: 1956 12: 2056 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 26:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: amdgpu FAILED: ati unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: HDMI-A-1 res: 1920x1080 hz: 75 dpi: 102 size: 480x270mm (18.9x10.6") diag: 551mm (21.7") 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.37.0 5.7.14-1-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.5 
           direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Sapphire Limited driver: snd_hda_intel 
           v: kernel bus ID: 26:00.1 chip ID: 1002:aaf0 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 28:00.4 chip ID: 1022:1487 
           Sound Server: ALSA v: k5.7.14-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: f000 bus ID: 22:00.0 chip ID: 10ec:8168 
           IF: enp34s0 state: down mac: <filter> 
           Device-2: Ralink RT5370 Wireless Adapter type: USB driver: rt2800usb bus ID: 1-3:2 chip ID: 148f:5370 
           serial: <filter> 
           IF: wlp3s0f0u3 state: up mac: <filter> 
Drives:    Local Storage: total: 894.25 GiB used: 8.40 GiB (0.9%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: A-Data model: SU650 size: 894.25 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 1c31 scheme: GPT 
Partition: ID-1: / raw size: 29.79 GiB size: 29.19 GiB (98.01%) used: 8.13 GiB (27.8%) fs: ext4 dev: /dev/sda7 
           ID-2: /home raw size: 59.56 GiB size: 58.37 GiB (98.01%) used: 282.9 MiB (0.5%) fs: ext4 dev: /dev/sda8 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A gpu: amdgpu temp: 34 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 771 
Info:      Processes: 284 Uptime: 12m Memory: 15.65 GiB used: 1.68 GiB (10.8%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Packages: pacman: 1183 lib: 318 flatpak: 0 Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.05 

After I boot, I cannot see any wifi available, nor can I connect to any. I have to restart my pc to do so.

Edited the OP for proper inxi information formatting.

If you have tlp installed, you can remove it and see if the issue persist, or keep it and disable power management on that USB port the wifi is connected to.
tlpui can give a graphical interface for that. Also make sure is not a USB3 port.

You could disable MAC address randomization in /etc/NetworkManager/NetworkManager.conf and change it to have this lines:


save it and then run from terminal:
systemctl restart NetvorkManager

1 Like

Thanks a lot for helping!!!
I have connected my adapter to the front panel which (3 or 3.1) as for some reason, i am not getting the wifi connection as strong as i used to on windows.
So what should i do? you said make sure it is not a usb3 port, will that be a problem?
also do i have to disable mac address randomization if i disable power management or if i want to remove tlp?
i am thinking to keep tlp to save power.

In some situations disabling IPv6 also helps, but also try different channel width frequency, switch channels …

i tried disabling tlp and also mac randomization, nothing worked.
However i found this when i type ip link
wlp3s0f0u3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000

the interface is Dormant mode for some reason. i changed it to Default by typing ip link set interface-name deafult

But that did not solve the problem and it goes to dormant mode after starting pc.
I guess if i am able to change it permanently, my issue will be fixed. What do you think?
Also, please share how to do it if you know how.
Thanks a lot for your support!!!

Can someone help?

What do you get if you run from terminal:
rfkill list

Maybe the wifi is locked? Do you disabled in Windows the fast boot and hybrid sleep ? Sometimes that puts some devices in a zombie state when booting back in linux.

sorry for such a late reply. I had my exams going on and didn’t open my linux and forgot to check the forum.

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

fast boot and hybrid both are disabled by default and never have been enabled.

I found this…
sudo systemctl --failed

  UNIT                               LOAD   ACTIVE SUB    DESCRIPTION                
● NetworkManager-wait-online.service loaded failed failed Network Manager Wait Online

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.

1 loaded units listed.

sudo journalctl -p 3 -xb

-- Logs begin at Fri 2020-08-21 21:59:39 IST, end at Tue 2020-09-08 19:38:08 IST. --
Sep 08 18:44:30 username-ms7c02 kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
Sep 08 18:44:40 username-ms7c02 kwin_x11[955]: kwin_xkbcommon: XKB: couldn't find a Compose file for locale "en_IN"
Sep 08 18:45:01 username-ms7c02 systemd[1]: Failed to start Network Manager Wait Online.
░░ Subject: A start job for unit NetworkManager-wait-online.service has failed
░░ Defined-By: systemd
░░ A start job for unit NetworkManager-wait-online.service has finished with a failure.
░░ The job identifier is 322 and the job result is failed.
Sep 08 18:55:15 username-ms7c02 systemd-coredump[3253]: Process 3059 (pamac-manager) of user 1000 dumped core.
                                                        Stack trace of thread 3059:
                                                        #0  0x00007fa822b5de40 g_menu_model_get_n_items ( + 0xd0e40)
                                                        #1  0x00007fa822e11576 n/a ( + 0xa9576)
                                                        #2  0x00007fa822e11a7e n/a ( + 0xa9a7e)
                                                        #3  0x00007fa822a6280a g_signal_emit_valist ( + 0x2f80a)
                                                        #4  0x00007fa822a62980 g_signal_emit ( + 0x2f980)
                                                        #5  0x00007fa82309f329 gtk_widget_realize ( + 0x337329)
                                                        #6  0x00007fa8230bf780 n/a ( + 0x357780)
                                                        #7  0x00007fa822a46052 g_closure_invoke ( + 0x13052)
                                                        #8  0x00007fa822a6e2fc n/a ( + 0x3b2fc)
                                                        #9  0x00007fa822a6241d g_signal_emit_valist ( + 0x2f41d)
                                                        #10 0x00007fa822a62980 g_signal_emit ( + 0x2f980)
                                                        #11 0x00007fa82309fcf7 gtk_widget_show ( + 0x337cf7)

The network manager wait online issue has gone after checking after 1 day automatically.
the other two are still there.
Would the watchdog hardware issue cause my wifi problem??

the full journalctl is very very big. i cant even copy paste it here as the limit is 15(somethin)
and it is 16(someting)

I mask that service, always.
systemctl mask NetworkManager-wait-online

I will honestly say that i don’t know.
It seems that Pamac got into a coredump here

You have to make sure you update the system. Use a cable Lan connection. Switch the kernel to 5.8 or LTS 5.4

i masked it,
also tried 5.4 ,5.7,5.8
Nothing is working…