No wifi traffic after update (but connectivity)


after doing an pacman -Syyu and rebooting I can not access the internet via wifi any more. Only ethernet is working. It’s strange because the connection to the router works and I can see the machine listed in the active connections.

Does anybody have some idea what’s wrong?

System:    Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: Xfce 4.14.2 
           Distro: Manjaro Linux 
Machine:   Type: Unknown System: Apple product: MacBook4,1 v: 1.0 serial: <filter> 
           Mobo: Apple model: Mac-F22788A9 v: PVT serial: <filter> UEFI: Apple 
           v: MB41.88Z.00C1.B00.0802091535 date: 02/09/08 
Network:   Device-1: Broadcom and subsidiaries BCM4321 802.11a/b/g/n vendor: Apple AirPort Extreme 
           driver: wl v: kernel port: efa0 bus ID: 02:00.0 
           IF: wls4 state: up mac: <filter> 
           Device-2: Marvell 88E8058 PCI-E Gigabit Ethernet driver: sky2 v: 1.30 port: 5000 
           bus ID: 03:00.0 
           IF: ens5 state: down mac: <filter> 

And the network log:

66.7170] NetworkManager (version 1.26.4-1) is starting... (for the first time)
66.7218] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity.conf)
66.8282] bus-manager: acquired D-Bus service "org.freedesktop.NetworkManager"

66.8600] manager[0x55d9561f5030]: monitoring kernel firmware directory '/lib/firmware'.
68.4428] hostname: hostname: using hostnamed
68.4428] hostname: hostname changed from (none) to "white-book"
68.4444] dns-mgr[0x55d9561b0220]: init: dns=default,systemd-resolved rc-manager=symlink
68.4449] manager[0x55d9561f5030]: rfkill: Wi-Fi hardware radio set enabled
68.4449] manager[0x55d9561f5030]: rfkill: WWAN hardware radio set enabled
68.4870] Loaded device plugin: NMWifiFactory (/usr/lib/NetworkManager/1.26.4-1/
68.4907] Loaded device plugin: NMOvsFactory (/usr/lib/NetworkManager/1.26.4-1/
68.4927] Loaded device plugin: NMAtmManager (/usr/lib/NetworkManager/1.26.4-1/
68.5094] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/1.26.4-1/
68.5342] Loaded device plugin: NMTeamFactory (/usr/lib/NetworkManager/1.26.4-1/
68.5433] Loaded device plugin: NMWwanFactory (/usr/lib/NetworkManager/1.26.4-1/
68.5444] manager: rfkill: Wi-Fi enabled by radio killswitch; enabled by state file
68.5449] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
68.5453] manager: Networking is enabled by state file
68.5472] dhcp-init: Using DHCP client 'internal'
68.5534] settings: Loaded settings plugin: keyfile (internal)
68.5851] device (lo): carrier: link connected
68.5872] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/Devices/1)
68.5905] manager: (ens5): new Ethernet device (/org/freedesktop/NetworkManager/Devices/2)
68.6117] ovsdb: Could not connect: No such file or directory
68.6204] device (ens5): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
68.6559] settings: (ens5): created default wired connection 'Wired connection 1'
68.6628] modem-manager: ModemManager available
69.0497] manager: (wlan0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/3)
69.0568] rfkill0: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.4/0000:02:00.0/ieee80211/phy0/rfkill0) (driver wl)
69.0655] device (wlan0): interface index 3 renamed iface from 'wlan0' to 'wls4'
69.0796] device (wls4): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
69.1390] device (wls4): set-hw-addr: set MAC address to x.x.x.x (scanning)
69.2345] device (wls4): supplicant interface state: internal-starting -> disconnected
69.2348] device (wls4): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
75.4828] agent-manager: agent[79073e098c916b5f,:1.31/org.freedesktop.nm-applet/1000]: agent registered
76.1309] policy: auto-activating connection 'SchildiOne 2' (b86d1c60-51c4-4dca-aa82-ca33b3165bdc)
76.1441] device (wls4): Activation: starting connection 'SchildiOne 2' (b86d1c60-51c4-4dca-aa82-ca33b3165bdc)
76.1452] device (wls4): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
76.1499] manager: NetworkManager state is now CONNECTING
76.1612] device (wls4): set-hw-addr: reset MAC address to x.x.x.x.x (preserve)
76.1627] device (wls4): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
76.1667] device (wls4): Activation: (wifi) access point 'SchildiOne 2' has security, but secrets are required.
76.1678] device (wls4): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
76.1983] device (wls4): supplicant interface state: disconnected -> interface_disabled
76.1987] device (wls4): supplicant interface state: interface_disabled -> inactive
76.2053] device (wls4): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
76.2093] device (wls4): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
76.2111] device (wls4): Activation: (wifi) connection 'SchildiOne 2' has security, and secrets exist.  No new secrets needed.
76.2113] Config: added 'ssid' value 'SchildiOne'
76.2115] Config: added 'scan_ssid' value '1'
76.2117] Config: added 'bgscan' value 'simple:30:-70:86400'
76.2118] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256'
76.2120] Config: added 'auth_alg' value 'OPEN'
76.2121] Config: added 'psk' value '<hidden>'
76.2303] device (wls4): supplicant interface state: inactive -> scanning
79.6723] device (wls4): supplicant interface state: scanning -> associating
79.7512] device (wls4): supplicant interface state: associating -> associated
79.7598] device (wls4): supplicant interface state: associated -> 4way_handshake
79.7749] device (wls4): supplicant interface state: 4way_handshake -> completed
79.7750] device (wls4): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "SchildiOne"
79.7755] device (wls4): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
79.7779] dhcp4 (wls4): activation: beginning transaction (timeout in 45 seconds)
82.0075] dhcp6 (wls4): activation: beginning transaction (timeout in 45 seconds)
24.9743] dhcp4 (wls4): request timed out
24.9744] dhcp4 (wls4): state changed unknown -> timeout
26.9748] dhcp6 (wls4): request timed out
26.9749] dhcp6 (wls4): state changed unknown -> timeout
26.9749] dhcp6 (wls4): canceled DHCP transaction
26.9749] dhcp6 (wls4): state changed timeout -> done
26.9779] device (wls4): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
27.0020] device (wls4): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
27.0029] device (wls4): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
27.0046] manager: NetworkManager state is now CONNECTED_LOCAL
27.0092] manager: NetworkManager state is now CONNECTED_SITE
27.0119] policy: set 'SchildiOne 2' (wls4) as default for IPv6 routing and DNS
27.0166] device (wls4): Activation: successful, device activated.
27.0223] manager: startup complete

Maybe someone can see tell me what this output means?

$ ip neighbor show dev ens5 lladdr dc:39:6f:03:73:77 REACHABLE
fe80::de39:6fff:fe03:7377 dev wls4  router INCOMPLETE
fd00::de39:6fff:fe03:7377 dev wls4  FAILED
fe80::de39:6fff:fe03:7377 dev ens5 lladdr dc:39:6f:03:73:77 router REACHABLE

it also looks like my wls4 interface has no ip V4 address but only (2?) ip V6 adresses


Before we begin, could you please provide me the output of cat /etc/resolv.conf ?

Thank you!


Generated by NetworkManager

nameserver fd00::de39:6fff:fe03:7377

Great! Thank you!

Let’s try to change this…

Enter sudo nano /etc/resolv.conf into a terminal, then erase everything, to then paste the following:


These are openDNS IPs.

Hit ctrls then ctrlx.

May then execute sudo systemctl restart NetworkManager.service

Hope it helps!

No this didn’t help. I think the problem is that my wifi interface has no ipv4 assigned.
But if I look into my router there is an ipv4 shown.

I also tried “sudo dhcpcd -4” as suggested somewhere else. But this did also not fix my problem.

May I ask for the output of ip neigh show , please? :upside_down_face:

Oh, and may i ask which desktop environment you are using?

The file /etc/resolv.conf generally should not be edited by hand. Most linux systems use a program called resolvconf that will automatically generate /etc/resolv.conf every time you connect to the LAN (as the post describes). Instead, you want to edit the file /etc/resolvconf.conf .

Check man resolvconf for more information.


Most of the time when we are told not to modify certain system files, it’s because the developers assume that a thorough knowledge of the functions and usefulness is required.

While a certain file can be explicitly linked to a certain process or application, certain parameters can be changed manually in a safe way if one knows its functions.

In the case of resolv.conf, it was cleaner to modify it manually. I assure you that it is just as safe and viable to do so on the above basis!

I understand your concerns on this subject, but I assure you the legitimacy of my clause is the result of a thorough reflection on this issue.

On that note, I wish you a wonderful day!

This changed now after rebooting - also see my 2nd post dev ens5 lladdr dc:39:6f:03:73:77 REACHABLE
fe80::de39:6fff:fe03:7377 dev ens5 lladdr dc:39:6f:03:73:77 router REACHABLE
fe80::de39:6fff:fe03:7377 dev wls4 lladdr dc:39:6f:03:73:77 router STALE


Can you try ping into a terminal, see if a connection is established, please?

Ping works fine as long as my ethernet cable is connected (ens5) but as soon as I disconnect it and use wifi (wls4) it will not work.

Sure, it’s safe to change the DNS there, however the next time a network is connected it will use that network’s DNS and those settings will be lost.

'Course, to test another DNS server briefly it will indeed accomplish that.

Let’s try to reset the arp & dhcp cache, shall we?

Enter the following into a terminal:

sudo dhclient -r wls4
sudo dhclient wls4

Reboot, see if it worked!

Did it already before but nevertheless still no ip address for wifi

Is there a way to enter the address provided by my router manually to test it?

Okay, may execute nm-connection-editor in a terminal, then select your wireless connection, hit the gear icon in bottom left corner, to then navigate to the IPv4 tab.

You may want to tick the box where it says IPv4 is required for this connection.

Doubt this may fix the issue, but we’ll eliminate surface possibilities before diving too deep :sweat_smile:!

Static IP address did not solve it. :frowning:

Just to make sure, can you please run sudo dhclient -v wls4 ? :thinking:

whatever this means:

Internet Systems Consortium DHCP Client 4.4.2
Copyright 2004-2020 Internet Systems Consortium.
All rights reserved.
For info, please visit

Listening on LPF/wls4/3a:a7:fd:f8:f9:b8
Sending on   LPF/wls4/3a:a7:fd:f8:f9:b8
Sending on   Socket/fallback
DHCPDISCOVER on wls4 to port 67 interval 6
DHCPDISCOVER on wls4 to port 67 interval 14
DHCPDISCOVER on wls4 to port 67 interval 11
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Interesting… Seems like i thought, a DHCP issue…

Might want to configure the IP address manually… :thinking:

sudo ifconfig netmask

See if it works…