No wifi showing up in the networks tab. BCM4360 802.11ac

Hi, I’m new to Manjaro and I’ve noticed that no wifi connections are appearing. I’m using a wifi dongle as a temporary solution, but I want to be able to just use my wifi card. I’ve looked around the archived forum for solutions, but I’m not really sure what I’m supposed to be doing.

inxi -Fxxn

System: Host: achernar-pc Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux

Machine: Type: Desktop Mobo: ASUSTeK model: ROG STRIX B360-F GAMING v: Rev 1.xx
serial: <superuser/root required> UEFI: American Megatrends v: 1101 date: 11/05/2018

CPU: Topology: 6-Core model: Intel Core i7-8700 bits: 64 type: MT MCP arch: Kaby Lake
rev: A L2 cache: 12.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 76831
Speed: 2130 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 1123 2: 1144 3: 1076
4: 1088 5: 1099 6: 836 7: 935 8: 930 9: 1096 10: 1042 11: 1010 12: 1143

Graphics: Device-1: NVIDIA GP104 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia
v: 440.100 bus ID: 01:00.0 chip ID: 10de:1b83
Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: nvidia resolution:
1: 1920x1080~60Hz 2: 1920x1080~60Hz s-dpi: 95
OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100
direct render: Yes

Audio: Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 00:1f.3 chip ID: 8086:a348
Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 01:00.1 chip ID: 10de:10f0
Sound Server: ALSA v: k5.6.19-2-MANJARO

Network: Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: efa0
bus ID: 00:1f.6 chip ID: 8086:15bc
IF: eno1 state: down mac: 04:92:26:c0:0f:b1
Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network Adapter
vendor: ASUSTeK driver: bcma-pci-bridge v: N/A port: 3000 bus ID: 05:00.0
chip ID: 14e4:43a0
Device-3: ZyXEL NWD2705 type: USB driver: rt2800usb bus ID: 1-7:7 chip ID: 0586:3421
IF: wlp0s20f0u7 state: up mac: fc:f5:28:fa:31:86

Broadcom always been a pain. Have you tried the solutions listed at the Arch Wiki? Broadcom wireless - ArchWiki

I checked the arch wiki page, which led me to downloading broadcom-wl-dkms, as the non broadcom-wl drivers did not work with BCM4360 according to en:users:drivers:b43 [Linux Wireless] which was linked in the wiki page. I also downloaded linux-headers as the wiki said the driver required it. And it ended up working… somewhat. While yes, I could connect to networks, the connection itself felt unstable and slow, sometimes it would just drop to 0 bits download for a second—it fluctuated too much to be usable.

Since the downloaded driver and package werent exactly compatible with my wifi dongle, I temporarily uninstalled broadcom-wl-dkms. Somehow, I could still connect to networks when I removed the wifi dongle. Though the same problems as I had before still manifested albeit even worse.

The wiki page lists troubleshooting options, but none of them match my case. rfkill list showed no blocked cards, and installing linux-lts didin’t affect the connection. I’m unsure whether I need to blacklist modules or not.

What else can I do?

Just found this post from the old forum Broadcom BCM4360 wifi not working - Drivers - Manjaro Linux Forum

Might be a solution there.

I’ve experienced similar problems when installing on Mac, also Broadcom wifi.

Hi there,

I also use the a Broadcom BCM4360, the Tp-link Archer T9E Download for Archer T9E | TP-Link United Kingdom . By default, the linux drivers don’t support it you can look through the packages to find working drivers. The connection is very often lost (I tried everything), but I can confirm that some drivers will make it into a somewhat usable. Common ways are known to try and make a better connection. I do remember disabling MAC address randomization being one of them. Ubuntu’s ‘‘keep connection alive’’ setting can make the connection much better. Maybe you could try finding the script that setting actually runs. I’d be much interested in that script myself.

I’ve tried older kernels with their respective broadcom-wl drivers, but the problem still persists. Broadcom BCM4360 wifi not working - Drivers - Manjaro Linux Forum OP’s solution in this thread was to use the right version of the driver to work with the right kernel, but I’m not sure it’s any help to me since I’ve already tried the older stable LTS kernels.

As far as I know it’s a issue with loading kernel modules or starting some service when booting up. I was having similar issues after last update and I tried almost everything I could think of… In the end I just had to reinstall manjaro and I’m not going to upgrade it till I know that the issue has been resolved